• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 723
  • Last Modified:

XP Windows 7 Workgroup Connection Issue

I have an XP SP3 machine connected to network via LAN (rj45) and a Windows7 Home Premium netbook (connects via wi-fi). I want to do simple file sharing. Both machines are in the same workgroup. File-sharing is enabled on both machines. The XP machine can access the Windows7 netbook (W7N) successfully.  If I go to the W7N Network and Sharing Center and select "See full map" the XP machine is recognized, but it appears at the bottom of the Results page under the heading, "The following discovered device(s) cannot be placed in the map." Any suggestions for getting the W7N machine to access the XP machine? Thanks.
0
bfgllc123
Asked:
bfgllc123
3 Solutions
 
Dave4125Commented:
That section is for devices it doesn't knlw how they're connected to the network. You should still be able to access the file share.
0
 
FastSiCommented:
I have dealt with quite a few problems recently could try installing the LLTD component on Windows XP if its not already installed, this component allows Windows 7 to map the hosts but is not included on XP.

http://technet.microsoft.com/en-us/library/cc749119%28WS.10%29.aspx
0
 
Jackie ManCommented:
Is the xp machine has a fixed/ static ip address? A static ip address will be much easier to config file sharing.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
bfgllc123Author Commented:
FastSi, some progress w your suggestion. I installed the Link-Layer Topology Discovery Responder via the hotfix associated w your link, then made sure the box was checked for  the XP Machine lan adapter. Then I set up a new workgroup on both computers.  On the Windows7 netbook (W7N), If I select "see full map" in the Network and Sharing Center, the map shows both computers  connected to the wi-fi router, but if I right-click the xp machine icon from W7N and select "open", a blank screen appears to the right. Meanwhile the XP machine still has access to W7N. Any more ideas?
0
 
ocanada_techguyCommented:
Some would say that for "security purposes" you actually turn off network discovery, it being a "nicety" that allows browsing.  Instead, run \\machinename and then you'll see the shares on that machine.  Since the username and password on each machine are unlikely to be the same, you might be tempted to enable the Guest account, and that's ok as long as you're giving the Guest account only read access not write access on shares.
Normally it is more secure to have read-only shares, and to get a file from machine A to machine B, go over to machine B and "pull" it from A, not try to push it A to B.
To gain that "push" priviledge, at machine A connect to machine B \\machineB\sharename using a different credential and furnish machineA\machineAusername and it's password.  You'd go to Explorer, press Alt to get menu, Tools, Map Network Drive, see the "Connect using a different user name"
 Map Network Drive Credentials
0
 
bfgllc123Author Commented:
These 3 comments all were helpful. I did need the LLTD component on the XP machine. "Adding a network place" on the xp machine using the xp ip address is what eventually worked. Thanks!
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now