SharePoint configuration wizard failing

Hi Friends,

Need your help on the following;

Our sharepoint site suddenly failed (We suspect this is after an updating of symantec AV). When trying to load the sharepoint site it gives the following error.
Retrieving the COM class factory for component with CLSID {BDEADEE2-C265-11D0-BCED-00A0C90AB50F} failed due to the following error: 8007013d.
Central admin is also down. Says run time error
We tried running the configuration wizard. After few steps it failed with the message failed to register sharepoint services.  (The diagnostic log is attached herewith.)
In the event log we found event ID 6483,
Event Type: Error
Event Source: Office SharePoint Server
Event Category: Office Server Shared Services
Event ID: 6483
Date: 2/25/2011
Time: 12:35:16 PM
User: N/A
Computer:
Description:
Application synchronization failed for Microsoft.Office.Server.Administration.UserProfileService.
Reason: Cannot complete this action.
Please try again.
Techinal Support Details:
Microsoft.SharePoint.SPException: Cannot complete this action.
Please try again. ---> System.Runtime.InteropServices.COMException (0x80004005): Cannot complete this action.
Please try again.
  at Microsoft.SharePoint.Library.SPRequestInternalClass.ListRegionalOptions(UInt32 dwCategory, UInt32 dwOption, String bstrUrl)
  at Microsoft.SharePoint.Library.SPRequest.ListRegionalOptions(UInt32 dwCategory, UInt32 dwOption, String bstrUrl)
  --- End of inner exception stack trace ---
  at Microsoft.SharePoint.Library.SPRequest.ListRegionalOptions(UInt32 dwCategory, UInt32 dwOption, String bstrUrl)
  at Microsoft.SharePoint.SPRegionalSettings.GetInstalledLanguages(SPRequest req, String url, UInt32 lcid)
  at Microsoft.SharePoint.SPRegionalSettings.get_GlobalInstalledLanguages()
  at Microsoft.Office.Server.Administration.UserProfileApplication.SynchronizeProfilePropertyLocalization()
  at Microsoft.Office.Server.Administration.UserProfileApplication.Synchronize()
  at Microsoft.Office.Server.Administration.SharedResourceProvider.SynchronizeApplications(SharedComponentSecurity sharedApplicationSecurity)

thanks in advance
amila
PSCDiagnostics-2-25-2011-13-9-26.log
LVL 11
Amila HendahewaLead ConsultantAsked:
Who is Participating?
 
sabby447Commented:
Uninstall, reinstall and run the wizard as Admin.

Make sure you are using the SQL DBO user for this configurationi for Adding the server

if this is farm environment : Try running it on another server and add to farm



0
 
geowrianCommented:
The log indicates an access denied error. Are you running the configuration wizard under an account with administrative privileges? Do all the accounts used for the farm administrator, SQL server, etc. have the required privileges? Is the farm setup admin in the Administrators group on the server?
0
 
Amila HendahewaLead ConsultantAuthor Commented:
Yes, i am using an admin account. These accounts are in the local admin group.
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

 
AlMothanaAlOmariCommented:
Rerun the configuration wizard again
0
 
Amila HendahewaLead ConsultantAuthor Commented:
I tried two times, result is the same.
0
 
Amila HendahewaLead ConsultantAuthor Commented:
I observed that SharePoint Services tracing service is not running. I tried to restart this several times but failed. It gives the message "error 1053; the service did not respond to the start or control request in a timely fashion". I think this is the reason why config. wizard is failing. in the config. wizard log there is an error saying "cannot start service sptrace on computer"

So if I can get this service up, I think I'l be able to run the config wizard.
0
 
sabby447Commented:
Reinstall will setup the service to default, Thus try to uninstall and reinstall to get back all things to default

Your data is all stored in Database and configuration i.e. web.config and other file level changes you can backup by backing up c:\inetpub\wwrwroot\wss folder and c:\program files\common files\microsoft shared\web server extensions\12 or 14 directory
0
 
Amila HendahewaLead ConsultantAuthor Commented:
Tried to uninstall but failed. It says installation is corrupted. So i am not able to repair, uninstall or reinstall.
How can i use a new server to install and connect?
0
 
Amila HendahewaLead ConsultantAuthor Commented:
I got MS support and get it solved.

We used OffScrub07.vbs ALL /FORCE  to uninstall SharePoint. Then we reinstall and completed the config wizard by choosing “Do not disconnect….”

Once this is completed all sites were up again including central admin.
0
 
Amila HendahewaLead ConsultantAuthor Commented:
the solution was not complete as I was not able to uninstall. However it did help me a lot. thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.