there is a problem with the proxy server's certificate

Posted on 2011-02-26
Last Modified: 2012-05-11
I'm getting the same error but mine is error code 8.  Mine started showing up after we edited our zone files and directed our emails to a hosted spam filtering server.  I tried the solution above, but that didn't work.
Question by:y2kane4eva
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
LVL 27

Expert Comment

ID: 34990992
First thing to check is thr certificate for the proxy server.
Log into the proxy via https (eg webmail if available) and note the certificate and any warnings u get.

Let us know any warnings u get and also note the address you use ti access it vs the address the certificate is registered for (amend the domain name for privacy before posting)
LVL 74

Expert Comment

by:Glen Knight
ID: 34991005
When you redirected the mail to hosted spam service why records did you change?

Is it the one wing used fr RPC/HTtPS?

If so, my advice would be to change that A record back, create a new A record (with a different name) and point that to the hosted SPAM service, then configure your MX record to use the new A record you just created.
LVL 26

Expert Comment

ID: 34992385
> When you see the cert. on the CAS server
notice the "Certificate issued to" value

> On the CAS server properties....third tab "External Host name" should match the value as per the above "Certificate issued to" value

Else...we would end-up in the error.

The other option is to use the "CertprincipalName" for the organization to match the same value as per the "Certificate issued to" one.
When, if and how do you modify Outlook Providers?
Free eBook: Backup on AWS

Everything you need to know about backup and disaster recovery with AWS, for FREE!


Author Comment

ID: 34999217
Would getting a third party CA get rid of this error?  right now Exchange is using a self signed certificate
LVL 74

Expert Comment

by:Glen Knight
ID: 34999303
Not if the records are not correct no.

Author Comment

ID: 35010071
The records are correct.

Author Comment

ID: 35010285
I added the selfsigned exchange certificate to the local trusted root certificate, now the error message is gone, but the server wants me to authenticate to it every time i start outlook.  This only happens when in cached exchanged mode.  Everything works fine when not using cache mode.
LVL 74

Accepted Solution

Glen Knight earned 500 total points
ID: 35010302
can you try the solutions in my article here:

It talks about SP2 for Exchange but you should now be using SP3.

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Utilizing an array to gracefully append to a list of EmailAddresses
In-place Upgrading Dirsync to Azure AD Connect
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…

732 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question