Solved

CRDefaultDateFormat

Posted on 2011-02-26
6
217 Views
Last Modified: 2012-08-14
Crystal Reports XI and BOE XI server seem to have awkward date format "YYYY-MM-DD".

Is there a way to change this default to "MM/DD/YYYY" or "DD-MON-YYYY"
0
Comment
Question by:sam15
  • 2
  • 2
  • 2
6 Comments
 
LVL 100

Expert Comment

by:mlmcc
ID: 34990210
Not that I know of.

You can try setting the default date format through the OPTIONs screen but I don't think that it applies to parameters.

What is wrong with using the calendar?

mlmcc
0
 

Author Comment

by:sam15
ID: 34991811
yes ,some use the calendar. but if you want to go back a few years,some users type in the date.

Are you using crystal XI. Create a data parameter and run the report. You do not see the default format?
0
 
LVL 100

Expert Comment

by:mlmcc
ID: 34992378
I see the default format.  I don't think it can be changed.

mlmcc
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 34

Expert Comment

by:James0628
ID: 35005953
I don't know about CR XI, but in CR 10, the date parameter format comes from the short date format in the Windows "Regional and Language" settings.  Mine is set to M/d/yyyy, and that's the format of a CR date parameter.  I just tried changing it to yyyy-MM-dd, and that was the format that CR used for a date parameter when I refreshed the report.

 James
0
 

Author Comment

by:sam15
ID: 35023927
you mean windows on the client O/S?

Where do you see that windows have default date format of YYYY-MM-DD
0
 
LVL 34

Accepted Solution

by:
James0628 earned 500 total points
ID: 35025567
I'm honestly not sure if it would be on the client machine or the server in your case.  I don't use the CR/BO "server" products.  I just run reports from CR on each machine.

 For the date format, I go to "Control Panel" > "Regional and Language Options", "Regional Options" tab.  There it shows the current format settings for number, etc., including "Short date" and "Long date".  I clicked Customize, went to the Date tab and changed the "Short date format", and used Apply/OK to back out of there and out of the "Regional and Language Options" windows, and when I went back to the report, CR used the new format for the date parameter.  The change was immediate.  I didn't have to close the report or CR.  I just refreshed the report, chose to re-enter the parameter, and CR used the new format.

 I'm using Windows XP.  If you're using something else, those regional settings might be located somewhere else.

 James
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

There have always been a lot of questions related to when Crystal Reports evaluates report components (such as formulas, summaries, cross-tabs, charts, to name a few examples). Crystal Reports uses a two-pass reporting process to provide greater …
Hello everyone, Hope you find this as helpful as we did. We have on the company I work for an application built in Delphi V with Crystal Reports 8. We all know that Crystal & Delphi can be temperamental sometimes and the worst thing is, nearly…
This video discusses moving either the default database or any database to a new volume.
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now