Windows 7 rdp to windows 7 PC does not work after IP change

Hello All:

First, let me say Google's announcement today to remove experts-exchange.com from their search algorithm's is so wrong. This site, to me, as an IT prefessional,  has been invaluable. Bad on google.

That said, here is my latest problem:

We changed internet providers at one of my clients. Everything worked well until a W7 client at home tried to access his W7 workstation at work, after the IPs were changed. We have a 1-2-1 NAT address in their firewall to make this work. So I changed the public ip for this PC, and now the client cannot connect anymore, nor can I from any other W7 based workstation outside of the network. Connecting to the W7 host from a remote XP client works fine, and from what I have found so far, it appears it is somehow related to a certificate problem between W7 and W7. I have followed those threads, removed certs from the intermedaite store on the client on the RDP side, I have even changed the hosts IP address, and associated 1-4-1 nat address to the internet, thinking that would issue a new cert but the problem remains.

Through many scenarios I can see that it is a W7 to W7 problem, as Xp to the W7 host computer works fine.  

Thanks as always for any and all of your help.  
classanetsAsked:
Who is Participating?
 
classanetsConnect With a Mentor Author Commented:
Well, we figured it out this morning. To answer the last posted comment, yes, it was setup for any version - as mentioned it worked fine until the internet address space changed. It turns out it had nothing to do with certificates......The message received when tring to login was that the credentials were not correct.

The domain name was longer than 15 characters. We had  for grins, tried the "other user" option  with  "domain\user" instead of just "user"  in the user name field but this did not work. just for grins we tried the other user with domain\user with the domain name shortened to 15 characters. This worked.  The interesting thing is before we got in, the domain shown on the login screen was the correct name.

As most people know when you switch users with "domain\user" after the first time after that just the user name is required as the system remembers the last domain logged into.

Go figure.  
0
 
classanetsAuthor Commented:
As always, any help appreciated...
0
 
TbabaCommented:
hmmm, you dont want to setup VPN and have remote users dial in before connecting?  Its a safer option...
0
 
bhanukir7Commented:
did you verify if the client is ready to accept connections running any version of RDP client.

can you check the remote settings on W7 workstation if that is set to accept remote connections running any version of RDP client.

regards
bhanu
0
 
classanetsAuthor Commented:
We figured this out ourselves.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.