Solved

Cognos - Unable to open cognos using localhost/cognos8

Posted on 2011-02-27
8
1,379 Views
Last Modified: 2012-05-11
Experts... I have installed Cognos 8.4 and Oracle 10g. I have the cognos connection working. When I open the url http://localhost/cognos8  the cognos configuration page briefly opens and I get a 404 error. Please help....
0
Comment
Question by:chickanna
  • 3
  • 3
  • 2
8 Comments
 
LVL 8

Expert Comment

by:SNeupane
ID: 34991869
Have you configured IIS with cognos8 directory?
Also, make sure the user account for content store has full access to create/update tables.
0
 

Author Comment

by:chickanna
ID: 34992736
Yes. I have configured IIS with cognos8 directory.
0
 
LVL 3

Expert Comment

by:Guillermin-go
ID: 34996067
Hi:

     Dont you have to imput a port in the URL?
0
 

Author Comment

by:chickanna
ID: 34997096
no. I am using the default port of 80
0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 
LVL 3

Expert Comment

by:Guillermin-go
ID: 34997380
Clasic questions:
   
    Firewall, antivirus?
0
 
LVL 8

Expert Comment

by:SNeupane
ID: 34998177
Give more info:
1. Operating system: 32 or 64 bit?
2. Is Cognos service started?
3. Cgi or isapi used in Cognos configuration?
--if isapi in 64 bit, you need to add the isapi extension.
4. cgi-bin in IIS must have scrip and execute checked.
5. Remove everything from IIS and readd, stop and start default web site.
0
 

Author Comment

by:chickanna
ID: 35001454
Guillermin-qo  -- Yes, I have firewall ON and Antivirus software installed. Do these interfere with the IIS rendering Cognos pages?

SNeupane --
  OS - windows XP sp-3
  Cognos service is started
   Cognos 8.4 -- cognos.cgi is used (I think)
  cgi-bin in IIS has all permissions
  stopped and started default web site. Also, tried with Apache web server. but same thing happens. configuration page comes up  and dissappears.
0
 
LVL 8

Accepted Solution

by:
SNeupane earned 500 total points
ID: 35001817
Hmmm...
1. Disable antivirus and firewall to check if they are causing the issue.
2. In IIS on the server level go to Application Pools. Under the Actions Pane select "Set Application Pool Defaults".
Set Enable 32-bit Applications = TRUE (If that option is available--it is for 64 bit but just check)
3. IIS on Windows 2003 has security features that disallow unknown cgi and
ISAPI file extensions.
Solution:
Add a new file extension in IIS and allow execution of the specific Cognos
executable like cgi (for example, cognos.cgi) or ISAPI (for example
cognosisapi.dll) file.
Steps:
Allow Cognos Web Service Extensions as required:
1. From the Windows Control Panel open Administrative Tools, and then
Internet Information Services Manager.
2. In the left pane of the IIS Manager window, expand your local computer
directory.
3. Right-click Web Service Extensions, and then select Add a new Web service
extension.
4. In the Extension name box, enter some descriptive name, for example "CRN
MR2 CGI"
5. In the Required Files box, enter the file: for ReportNet use
installation_location\crn\cgi-bin\cognos.cgi.
6. Set the Set extension status to Allowed and then click OK.
7. Stop and Start the IIS services.
Repeat the process for each ISAPI or cgi extension that applies in your
installation.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I annotated my article on ransomware somewhat extensively, but I keep adding new references and wanted to put a link to the reference library.  Despite all the reference tools I have on hand, it was not easy to find a way to do this easily. I finall…
SSL stands for “Secure Sockets Layer” and an SSL certificate is a critical component to keeping your website safe, secured, and compliant. Any ecommerce website must have an SSL certificate to ensure the safe handling of sensitive information like…
Google currently has a new report that is in beta and coming soon to Webmaster Tool accounts. This Micro Tutorial will highlight new features for Google Webmaster Tools.
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now