Solved

RDP in Windows 7

Posted on 2011-02-27
4
439 Views
Last Modified: 2012-05-11
have new windows 7 and want to setup how it was on old xp pro. workstation. THe ports come through the sonicwall so that they are like 49XX. i.e. would be mail.mydomain.com:4985 but just dont know how to setup in "exceptions" in the firewall like it was on xp firewall. In xp we created the port 4985 and had it link to 3389 and then you could remote in. Win7 is diff. enough that i am just not sure of how i have it setup. I belive you have to create it mostly the same except under inbound/outbound...and then i kind of get lost....please explain step by step instruct. for sonicwall
0
Comment
Question by:gstevederby
  • 2
4 Comments
 
LVL 2

Expert Comment

by:mattsam
ID: 34991223
You dont need to mess around with the firewall for windows 7 to allow RDP.

You just have to enable remote desktop and it will configure the firrewall rules for you automatically.

Goto - Control panel - System - Remote Settings - change the settings to - Allow connections from computers running any version of Remote desktop (less secure)

Windows 7 will change the firewall rules for you.
If you want to do it manually (not reccommeded)
Contril panel - windows firewall - advanced settings - inbound rules - Remote desktop (tcp-in) -  Right click and "enable"


0
 
LVL 1

Expert Comment

by:Tbaba
ID: 34991295
From your Q, you want to change RDP port that Windows 7 listens on , right?

Ok, here it is:

1.  Rune the registry editor in your window 7 computer by pressing the windows key+R and typing regedit.

2. Navigate to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber

3.  Double click it and choose decimal, you'll see 3389, change it to the desired port then click ok

4. exit registry editor and restart the PC.

Good luck!
0
 
LVL 1

Accepted Solution

by:
Tbaba earned 500 total points
ID: 34991301
Check the RDP port in the firwall inbound rules as detailed by@mattsam, if its still 3899, you'll have to add the port number you changed it to in the registry.
0
 

Author Closing Comment

by:gstevederby
ID: 35065397
still work to do , to get to accept ports from sonicwall
0

Featured Post

Flexible connectivity for any environment

The KE6900 series can extend and deploy computers with high definition displays across multiple stations in a variety of applications that suit any environment. Expand computer use to stations across multiple rooms with dynamic access.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
using BGP Attributes 2 110
MAC address learning of Riverbed 4 67
How analyse your IT Outsourcing provider 3 53
Factory Reset of Juniper SSG20 2 19
Imagine you have a shopping list of items you need to get at the grocery store. You have two options: A. Take one trip to the grocery store and get everything you need for the week, or B. Take multiple trips, buying an item at a time, to achieve t…
In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

820 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question