Issue with WCF security

Hi,

  I`ve created a WCF service (http://wcf.boaviagemdistribuidora.com.br/McSoftPersistenciasSistema.svc?wsdl) and it works fine in the development machine. When I put it in Internet I get the message that says "No connection could be done because the destin machine actively refused my IP".

  The binding I'm using is wsHttpBinding. In the server the configuration is:

  <system.serviceModel>
    <behaviors>
      <serviceBehaviors>
        <behavior name="McSoftPersistenciasBasico">
          <serviceMetadata httpGetEnabled="true" />
          <!-- Colocar FALSE para receber as falhas -->
          <serviceDebug includeExceptionDetailInFaults="false" />
        </behavior>
      </serviceBehaviors>
    </behaviors>
    <services>
      <!-- Modulo de Sistema -->
      <service name="McSoft.Persistencias.Sistema.DadosAtivos" behaviorConfiguration="McSoftPersistenciasBasico" >
        <endpoint address="" binding="wsHttpBinding" contract="McSoft.Persistencias.Sistema.IDadosAtivos" />
        <endpoint contract="IMetadataExchange" binding="mexHttpBinding" address="mex" />
      </service>

  What is needed in the client application? Seems to be a password... But I don't know how to set it up.

  The clients configuration is:

  <system.serviceModel>
    <bindings>
      <wsHttpBinding>
        <binding name="WSHttpBinding" closeTimeout="00:01:00" openTimeout="00:01:00" receiveTimeout="00:10:00"
            sendTimeout="00:01:00" bypassProxyOnLocal="false" transactionFlow="false"
            hostNameComparisonMode="StrongWildcard" maxBufferPoolSize="524288" maxReceivedMessageSize="2147483647"
            messageEncoding="Text" textEncoding="utf-8" useDefaultWebProxy="true" allowCookies="false">
          <readerQuotas maxDepth="32" maxStringContentLength="8192" maxArrayLength="16384" maxBytesPerRead="4096" maxNameTableCharCount="16384" />
          <reliableSession ordered="true" inactivityTimeout="00:10:00" enabled="false" />
          <security mode="Message">
            <transport clientCredentialType="Windows" proxyCredentialType="None" realm="" />
            <message clientCredentialType="Windows" negotiateServiceCredential="true" algorithmSuite="Default" />
          </security>
        </binding>
      </wsHttpBinding>
    </bindings>
    <client>
      <!-- Module Sistema -->
      <endpoint address="http://wcf.boaviagemdistribuidora.com.br/McSoftPersistenciasSistema.svc" binding="wsHttpBinding" bindingConfiguration="WSHttpBinding"
                contract="ServiceReferenceSistema.IDadosAtivos" name="WSHttpBinding_IDadosAtivos">
      </endpoint>


  Thanks,
  Marco Castro
MarcoCastroAsked:
Who is Participating?
 
DarrenDConnect With a Mentor Commented:
Hi,

Are you using certificates for security?

This seems to be an issue.

Have a look in this document and see if it helps:
http://wcfsecurityguide.codeplex.com/releases/view/15892

Thanks,

Darren

0
 
cubaman_24Commented:
Hello:
I would take a look at the system/network firewall, as the message says that connection to destination have been refused..
Best regards.
0
 
MarcoCastroAuthor Commented:
Good reference.
0
All Courses

From novice to tech pro — start learning today.