Solved

Outlook 2007 error 503

Posted on 2011-02-27
22
358 Views
Last Modified: 2012-05-11
Running Outlook 2007 on a Windows 7 platform, I have recently begun receiving the following message occasionally:

 The following recipient(s) cannot be reached:    '[recipient name]' on 2/27/2011 7:03 AM
            503 Saw MAIL within this transaction already

I am not sure whether this mail is being delivered and would like to know a remedy for the error.
0
Comment
Question by:ddantes
  • 12
  • 10
22 Comments
 
LVL 11

Expert Comment

by:Plantwiz
Comment Utility
I've seen this with BCC's being sent, How are them messages your user is creating being sent?

Are they trying to send a large group BCC?  And is there a particular domain name being rejected?
0
 
LVL 11

Expert Comment

by:Plantwiz
Comment Utility
Otherwise:

Check your e-mail before sending and haev it use server authentication.

Outlook:
Tools/e-mail account
change
more settings
outgoing server tab
click - SMTP requires authentiation and confirm incoming is same
advance tab and select outgoing to Port 587
Ok and test settings
0
 

Author Comment

by:ddantes
Comment Utility
The messages which are affected are not group mailings and there is no BCC.  It seems random.
0
 
LVL 11

Expert Comment

by:Plantwiz
Comment Utility
So this is your machine (not a network machine)?

Have you checked the event logs to see what is reported at that time?
0
 

Author Comment

by:ddantes
Comment Utility
This machine is the server in a home office. Nobody  else uses the LAN except myself.  I just checked Event Viewer, and nothing was reported at the time of the last incident.  Can you tell me the meaning of the error message "Saw Mail within this transaction already"?
0
 
LVL 11

Expert Comment

by:Plantwiz
Comment Utility
Do you have any anti-virus running with your mail?

I've not seen a 'Saw MAIL' as you indicated with a 503 error previously, nor do I see that when I search either.

As mentioned, I've also seen this as a problem when the Outlook isn't configured to authenticate, but that isn't the only time I've seen this error.  I've seen it when someone tried to routinely send 300+ BBC e-mails as part of their marketing.

Do you always see the 'Saw MAIL' as a response?

And how recently did this problem begin for you?

Are your Office and Windows apps updated?  
AV updated? (if you use it)
Do you have any firewalls that are new (recently) that may be blocking you.

And are you using POP or IMAP for your e-mail?
0
 

Author Comment

by:ddantes
Comment Utility
Thank you for your comments.  This only started a few days ago.  I do not send bulk mail, this has occurred when sending an ordinary message to a single recipient.  It is infrequent, perhaps twice a day.  Office and Windows are updated.  I use NAV 2009 and it is current on virus definitions.  There have been no changes to my firewall or other security features.  I use POP mail.
0
 
LVL 11

Expert Comment

by:Plantwiz
Comment Utility
And, when you stated the machine IS the server, you mean this is your 'main' system, not a AD server or Exchange server, but a 'server' as one might have in a Peer-to-peer network correct?
0
 
LVL 11

Expert Comment

by:Plantwiz
Comment Utility
I can find 503 errors on MS site (office area) for Communicator and Access referencing duplicate data.

I can find 550 and 553 error for Outlook.

I do not see anything referencing 'Saw MAIL', but I have a couple additional places to check.  

IS this the same error each time?  Or have you received other error codes?
0
 

Author Comment

by:ddantes
Comment Utility
Yes, this machine is my main system, in a peer-to-peer network. The error is the same each time, but it seldom occurs -- perhaps 2% of the time I send messages.
It may be relevant to mention that my outgoing Email is routed through one of two third-party servers which embed an image in the message in order to verify receipt.  But I have used these services for many years without encountering this error.
0
 
LVL 11

Expert Comment

by:Plantwiz
Comment Utility
Interesting...
Perhaps they have made some changes or upgrades then??

Have you tested a message without this routing?
Have you confirmed if they have any other complaints or concerns noted?  

And would you be willing to list where you are routing through?  If not, please contact them as well as this may be part of the issue.

I'll continue to search though

0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 

Author Comment

by:ddantes
Comment Utility
Since the problem is infrequent, it is difficult to test.  Confirming if these services have had other complaints is not easy, because their support is relatively inattentive.   I think it would be useful if the exact error message  "Saw Mail within this transaction already"?  could be interpreted.  Thank you for continuing to investigate.
0
 
LVL 11

Accepted Solution

by:
Plantwiz earned 125 total points
Comment Utility
ddantes,

You have stated the problem is 'infrequent' but previously stated you see the error a couple times a day.  I would put 'couple times a day' in the frequent column.

Do you send an unusal amount of e-mail?  Say more than 100 messaegs a day?  Or more along the lines of 'more than 20 messages a day'?

Are you able to send mail for a day or two without routing through your 3rd party?  And you stated you use 2 of these places, do you see the error when using one vs the other?

I understand this may be difficult to track, but I'd recommend going back to basics on this and see what may have changed if anything.

-If you are rounting mail through Norton, stop that temporarily to test this.
-Stop sending through 3rd parties temporarily to see if you can isolate the issue.
-Contact these 3rd parties, to confrm if there are issues, I do understand that this may see pointless, but without knowing who they are to research further, you'll need to inquire if this is a problem only you are seeing or their other users.  It does need to be ruled out.

Likewise:
- do you have more than one e-mail account?  Does this problem occur with that account?

Something just seems strange here.  There is no Event Log problem recorded, which somewhat points to the problem being outside of the Windows/Office environment.  

"Saw MAIL" is not an error I'm finding any place.  I can find issues with the Saw domain, but you have not indicated you use Saw.

Why are you unable to check receipt of your messages?  Do you know know the people who you are mailing?  Certainly someone would be able to alert you of a receipt during your testing period.
0
 

Author Comment

by:ddantes
Comment Utility
Thank you for your comments.  I send around twenty Email messages a day.  The third party Email tracking vendors are MSGTAG.com and Productivemail.com    The problem first occurred after I began using Productivemail around a week ago.  I did that because the MSGTAG server was down -- they experience infrequent but sometimes lengthy service failures.  Although I disabled tagging temporarily in MSGTAG, I think there may have been some issue because both services have servers associated with my pop mail accounts.  The grammer "Saw Mail" makes me suspect Productivemail, which is based in Spain, and English is a second language.

I would prefer not to send mail without tracking, if it can be avoided, but I understand the relevance of this test if the problem persists.

I have never gotten a response to an online or Email support request from Productivemail, and sometimes my Email is returned undeliverable.   MSGTAG support is better, but I am currently waiting for a reply from them on another issue, and it appears they are not going to respond.

I have three Email accounts on Outlook.  I know of one account where this issue happened, but I haven't noticed whether it occurred on the other account(s).  I will look into this.

I'm not sure what you mean by  "Why are you unable to check receipt of your messages?"  
0
 
LVL 11

Expert Comment

by:Plantwiz
Comment Utility
Thanks,
I'll look into those two sites.


As far as the comment "Why are you unable to check receipt of your messages?"  I'm curious, how one might be sending e-mail but not know the receipiant well enough to call them or have them confirm they received what you sent.

Ex, When I send to someone, I can call or tell them when I see them I sent them a message, they will indicate the received the message....make sense?

Why not set yourself with a receiver account and send it with your other messages - you'll see for yourself that your message delivered or not, as well as note if you get your 3rd party tracking message.


It's funny you mention Spain, as I was finding some sites that indidcated the SAW was a Spanish site so, I'll look more closely at that when I go back in.

Thank you for the additional infomation.
0
 
LVL 11

Expert Comment

by:Plantwiz
Comment Utility
...just thinking (and need to dig to confirm if this is a problem)


But are you running BOTH programs at the same time?

The 503 error's I've seen indicate duplicate info of varing degrees depeding on the other syntax...but if you are running both MSGTAG and ProductiveMAIL together, perhaps one program is seeing the tag of the other and cannot tag the message??

Just a thought.

If the above is true, have your run ProductiveMAIL alone ?   Perhaps turn off MSGTAG and only run ProductiveMAIL.



***

Also curious, if you just wrote to them, why do you think they will not respond?  24-48 hours for replies is unfortunately common for some places.
0
 

Author Comment

by:ddantes
Comment Utility
Most of the Email I send is in response to inquiries about renting our B&B in Hawaii.  I do not have a personal relationship with these potential guests and they usually don't provide a telephone number.  So I rely on the tracking service to let me know if and when my messages are received, and I've found it quite useful.  Thanks for your continuing input.
0
 

Author Comment

by:ddantes
Comment Utility
Our postings crossed in the ether.  My last response was to your 8:28 comment.   The  history of unresponsiveness for the services I mentioned is based on around two years of experience, not on the past few days.  

I think you have a point about a conflict between the two tagging services.  Since I disabled tagging on one, I thought that would prevent a conflict.  But having the program running probably results in outgoing messages routing through their server, tagged or not.  This seems likely to be the problem, and I will close one of the applications and see what happens.  
0
 

Author Comment

by:ddantes
Comment Utility
My web host, whose server handles Email from one of the accounts which experienced the 503 error, says it is not related to his system.  I'll post again when there is something new to report.
0
 
LVL 11

Expert Comment

by:Plantwiz
Comment Utility
Ok.

Thank you for the update.  Cross that one off the list :)

I didn't locate anything 'new' but I'll continue to dig.  I was a little concerned with ProductiveMAIL, as their webpage only lists Copywrite up to 2007. It's a detail thing that bothers me as well as sending a flag that the site may not be monitored well.

I also couldn't access their forums (continued to get browser errros) and their FAQ didn't load.  So, I mostly had access to their home page, and the download page.  So, I'll look at it again in a bit and may just do a test install to see how it responds for me.
0
 

Author Comment

by:ddantes
Comment Utility
I haven't seen this error in 48 hours, and I think de-activating Productivemail and just using MSGTAG resolved it.  Although I had turned off message tagging in Productivemail, I had not disassociated Productivemail from my Email accounts.  So outgoing mail probably tried to go through both third party servers.  Thank you for your diligent feedback.
0
 
LVL 11

Expert Comment

by:Plantwiz
Comment Utility
Thank you for the update.

I did not uncover anything additional.  Good luck with your programs and thank you for your prompt replies to faciliate working through the troubleshooting process!
0

Featured Post

Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

Join & Write a Comment

Resolve Outlook connectivity issues after moving mailbox to new Exchange 2016 server
Outlook Free & Paid Tools
Get people started with the process of using Access VBA to control Outlook using automation, Microsoft Access can control other applications. An example is the ability to programmatically talk to Microsoft Outlook. Using automation, an Access applic…
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now