IIS 6 Directory browsing and default document not working after update to .Net 4

Hi

On my dev machine running IIS6 on Win 2003 Server I recently installed the .Net 4 framework. (Previously was running .Net 3.5)  Since then directory browsing no longer works.  I get this error:
===============================
Server Error in '/' Application
The resource cannot be found etc etc
===============================

Same goes for default documents.  Rather than loading the default document I get the error message above.  

Anyone know what the deal is with that?  Thanks!
DanziggerAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Alan HardistyConnect With a Mentor Co-OwnerCommented:
Check to see what version of ASP.NET the site is using and put it back to v1.1 if available and that might resolve the issue.

The ASP.NET tab should be available on the properties of the Website in IIS.
0
 
Richard AmissOwner/Developer/ConsultantCommented:
You need to gather a bit more info before we can determine what "resource" cannot be found. By default IIS will not show detailed errors to remote clients.

The first step is to get the detailed error by visiting the site from the browser on the server. Report back what you discover.
0
 
DanziggerAuthor Commented:
Thanks - that did it!  The site I did it on was set to 2.0.  I set it back to 1.1 and the dir browsing / default doc started working again.  I put it back to 2.0 and it still works.  

And doing that to that one site has resolved the issue for all other sites - except the one running 4.0.  Will need to look further at that.
0
All Courses

From novice to tech pro — start learning today.