• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1514
  • Last Modified:

WAMP Server

Hello! I can't get the newly installed WAMP to work correctly on the server I'm working on. I have disabled IIS, but can't get wampapache service to start. When I run the following command, I get an error that says it can't locate php_mbstring.dll.

c:\wamp\bin\apache\apache2.2.17\bin\httpd.exe

Any ideas what might be wrong?
0
Karessa
Asked:
Karessa
  • 2
1 Solution
 
psimationCommented:
Maybe try XAMPP instead - works like a charm for me?

http://www.apachefriends.org/en/xampp-windows.html#641
0
 
KaressaAuthor Commented:
Thanks for your time, but unfortunately it's not my server. I don't have permission to use anything but WAMP.

Thanks again!
0
 
shaunakCommented:
Hello,
It must be because php_mbstring.dll is not present on your system. Locate your php.ini file in php folder and look for the string: extension=php_mbstring.dll. Temporarily disable this extension by adding a semi-colon ";" at the start of the line. So your line should look like:

;extension=php_mbstring.dll

OR
You can also download the php_mbstring.dll file and put it in php/ext folder to resolve this issue.  php-mbstring.dll
0
 
KaressaAuthor Commented:
Hi, Shaunak.

I commented out the line but the service still won't start. It's funny, too, because the file was already in the ext folder.

The error I am getting when I try to start the service is Error 1067: The process terminated unexpectedly. Any idea what that might be? I'll start a new question.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now