• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1040
  • Last Modified:

Exchange 2003 SSL

I'm trying to set up Active Sync for Exchange 2003 SP for a droid.  It appears to work, but I never get any mail  and its just a black screen

I'm not sure what i'm doing wrong.  

When I go look at the SSL I got from GODaddy.com     it gives Windows does not have enough information to verify this certificate"

But my Outlook Web mail works fine and uses HTTPS

       SLL ERROR
0
13years
Asked:
13years
  • 7
  • 5
  • 4
  • +1
1 Solution
 
jrwarrenCommented:
Has the server been updated?
  specifically the Root Certificate Authorities.

The server may nto be sync'd with the more recent authorities and is not responding/recognizing this updated cert.

  I have no idea regardign Droid OS and it syncing to outlook, but I do know seevral people that stated they had to import the certificate to their droid...  May want to do that, as well.  Be sure to add the cert to the trusted authority, not the local authority, if it gives you a choice.
0
 
MegaNuk3Commented:
Do you have any other devices where ACtiveSync is working fine? If not, then test ActiveSync from www.testexchangeconnectivity.com
0
 
MegaNuk3Commented:
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
Suliman Abu KharroubIT Consultant Commented:
To resolve this you will need to install all of the certificates (intermediate certificates) that were sent from godaddy.
0
 
Suliman Abu KharroubIT Consultant Commented:
0
 
13yearsAuthor Commented:
Hi I thought I installed the cert in the correct location.  Maybe I did not.  Do I only install the sub cert in the intermediate certificates?

Also, Meg, I have looked over your information, and several hours later I have not moved forward.
This is the results of the Active Sync test.


      An ActiveSync session is being attempted with the server.
       Errors were encountered while testing the Exchange ActiveSync session.
       
      Test Steps
       
      Attempting to send the OPTIONS command to the server.
       The OPTIONS response was successfully received and is valid.
       
      Additional Details
      Attempting the FolderSync command on the Exchange ActiveSync session.
       The test of the FolderSync command failed
0
 
13yearsAuthor Commented:
OWA works fine on HTTPS, despite the error
0
 
Suliman Abu KharroubIT Consultant Commented:
IF OWA works fine, then the certificate had been installed on the correct place.

what type  of device are you try to use ?
0
 
MegaNuk3Commented:
Install this hotfix:
http://support.microsoft.com/kb/957191

Then create a new account and mailbox, send it a couple of items and then test with www.testexchangeconnectivity.com again.
0
 
13yearsAuthor Commented:
A Samsung Fascinate;  

Mega,

'wow' I will test it as soon as I get home.

0
 
13yearsAuthor Commented:
I decided to look over Mega and reset the Virtual Exchange server and start over and baby step it.   First get the OWA working per the guide.  Then I will add SSL

I will report back tommorow
Thanks!
0
 
13yearsAuthor Commented:
excuse me,

I looked over Mega's guide last, and decided to "start over".  I followed Method 2, from Megas guide to  reset the Exchange virtual folders.
 
I will then follow Mega's guide to the letter to get a working Active sync connection working.

After that I will try to configure a SSL cert

I will report back when that is finished.
0
 
MegaNuk3Commented:
Since you werent getting a server specific error (like 503) I would of gone straight for the hotfix and then troubleshooted after that if it still wasn't working...
0
 
13yearsAuthor Commented:
Mega, I followed your guide agian, and when it did not work.  I applied the patch.  Works

Thank you!  Amazing!!  thank you so much
0
 
13yearsAuthor Commented:
oops, guess this does not really resolve the original question.  I apologies to all those involved.

I should have separated my questions out.  
0
 
MegaNuk3Commented:
Thanks for the points.

Yes, suliman should of got some points or all the points for your cert question... ;-)
0
 
Suliman Abu KharroubIT Consultant Commented:
No problem :-)

Glad that I can help....

Thanks all
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

  • 7
  • 5
  • 4
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now