Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Changing default truststore and keystore passwords in WebSphere

Posted on 2011-02-28
3
Medium Priority
?
8,670 Views
Last Modified: 2013-12-11
I am following this document to change the default passwords

http://www-01.ibm.com/support/docview.wss?uid=swg21243038

In step 4, when i try to open the files

Use IKeyman to change the password for the actual key.p12 and trust.p12 pointed to in step 3:

com.ibm.ssl.keyStore=${user.root}/etc/key.p12
com.ibm.ssl.keyStore=${user.root}/etc/trust.p12

   1. <WAS_HOME>/bin/ikeyman.bat
   2. Key Database File -> Open
   3. Browse to the files and open with the default password (WebAS)
   4. Key Database File -> Change Password


I am getting the error "The specified file is not a well-formatted key database file

Please help how to rectify
0
Comment
Question by:wasadmin11
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 12

Accepted Solution

by:
Radek Baranowski earned 2000 total points
ID: 35006085
did you change type to P12  in the "Open database" dialog ? you must tell ikeyman what store type it is going to open.

check it.

other option is that the passwords have been already changed - then you would need to create a new set of files.
0
 
LVL 2

Author Comment

by:wasadmin11
ID: 35015266
working now ..i had to change the type to pkcs12. Thanks..Got another doubt.

I changed the password in the ssl.config.props in the Dmgr01 profile. But after restarting all the JVMS , I do not see the new password in the AppSrv01 ssl.config.props. I thought any change made to the Dmgr01 profile should be propogated to the Nodes ?

0
 
LVL 12

Expert Comment

by:Radek Baranowski
ID: 35015313
no, it doesn't work that way, I mean, when you change ssl.config.props in Dmgr/properties directory it works only locally eg. when you perform operations to Dmgr profile. if you want to use the same settings on other profiles you need to make the same changes in their properties directory as well.

take this as an example - when putting credentials to soap.client.props to use wsadmin without explicit authentication every time, you make it work in the profile you make this change to - the others not. if you want ot use wsadmin without credential prompt on other profiles, you need to put creds there as well to soap.client.props.

is it clear to you ?
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Configure Web Service (server application) I. Configure security for Web Services methods First, we need to protect Session bean which implements the service: 1. Open EJB deployment descriptor (ejb-jar.xml) in the EJB project that contains you…
This exercise is about for the following scenario: Dmgr and One node with 2 application server. Each application server contains it owns application. Application server name as follows server1 contains app1 server2 contains app1 Prereq…
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…
Despite its rising prevalence in the business world, "the cloud" is still misunderstood. Some companies still believe common misconceptions about lack of security in cloud solutions and many misuses of cloud storage options still occur every day. …

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question