Solved

Virtualizing a Windows 2000, Exchange 2003 server using Acronis True Image Echo Enterprise backups

Posted on 2011-02-28
4
664 Views
Last Modified: 2016-10-27
I have tirelessly worked for two weekends straight trying to create a new virtual machine from an Acronis image, with no success.

I'm using Microsoft VMM 2008 and Hyper-V on a Windows Server 2008 R2 host machine. I'm also using an Acronis True Image Echo Enterprise Server boot disc to make offline images of the server that needs to be virtualized.

I created blank VHDs for the C, E, and G partitions, which are all on our Exchange server. Our Exchange server is a Windows 2000 server, running Exchange 2003, and is also a domain controller that manages DHCP and DNS. The physical box works fine, boots fine, and seems to be fully functional. It is on almost 10 year old hardware though, and the CPU fan just died, and we want to migrate it to a virtual machine to have it on reliable hardware.

C: - Boot and Windows partition
E: - Exchange partition. This is where the Private Information Store lives
G: - Was empty, but for disk space reasons on E:, it recently became the home of the Public Info Store

I boot the Exchange server into an Acronis Boot CD, and create a new full backup. When that finishes, I boot the new Virtual Machine with the blank VHDs to that same Acronis Boot CD and begin the Recovery Wizard. It is during this process that I've tried almost every option possible. I've restored each partition to their VHD equivalents, using Universal Restore and supplying the necessary PERC2 RAID drivers. However, upon reboot of the VM, I am continually receiving the attached screenshot which tells me the SYSTEM hive is missing or corrupt.
Error I receive after restoring the full Acronis backup
I've used a VHD explorer program to view the contents of the VHD after the restore process finishes, and can certainly guarantee that the SYSTEM hive is present. So, is it corrupt? And if so, why does the Physical server boot fine, no problems?

I've tried both online and offline backups with Acronis. Both are resulting in the same error above. I will admit that at first, I was only trying by making online backups (while the server was still powered on). The next time I tried to make a backup, I booted to the CD and did a full offline backup of C:. The very next time I restored just the C: partition, I had a bootable OS in the VM, so I was sure it was going to work! However...once in the VM, the Exchange System Attendant and Information Store services would fail to start and thus I was back at square one. I figured the difference then, was the fact that I made my backups offline this time. But now, even offline backups and then restoring them results in the SYSTEM hive showing as missing or corrupt.

I have attempted to boot the bad VM into a Windows 2000 Server disc and performing a repair. I created a new Emergency Repair Diskette on the original Physical Exchange server, and used that in conjunction with the Windows 2000 Server disc to perform the repair. I chose the default repair option (fast) and it went through a progress bar for about 15 minutes. When it got to about 95% complete it was asking to insert another diskette labeled OEM Disk2, but I don't know what this is. It gave me options to skip the files in question but warned that the repair may not work. I had no other option but to skip those files though...there were about 5 or 6 that I had to skip before it continued with the rest of the repair. Upon reboot, I still received the same error about the SYSTEM hive being missing or corrupt.

I feel I've tried every single option. Oh, and I cannot do a proper offline P2V conversion of the Exchange server into a VM using the VMM 2008 software. I get another error message when trying. It is attached as well. I searched a little bit on that error and had one person suggest that it is because there is a mirror on the RAID. They said to break the mirror and it should do a P2V successfully. However, as you might imagine, breaking the mirror on such an old server doesn't sound very appealing to me.
Error I receive when trying to do an offline P2V conversion with VMM 2008
Sorry this is so lengthy, but I feel it is necessary to explain all that has been involved thus far. Please, experts, I need help!!!
0
Comment
Question by:columbusdata
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 42

Expert Comment

by:kevinhsieh
ID: 35003174
Can you do an online conversion of the Exchange server? You can even just stop the exchange services so that you don't need to try to handle the new mail. You can also maybe just start with the C drive to see if you can get it to boot. If you can, you can always copy over the data drives afterwards.
0
 
LVL 24

Expert Comment

by:Nagendra Pratap Singh
ID: 36436936
Assuming 2000 is installed on an IDE controller, change the Disk controller in Wndows 2000 Machine to be a standard IDE controller. The shutdown (no reboot) and take the image.

Windows will pick the new controller in new VM

http://www.tomshardware.com/forum/196922-32-switching-storage-controllers-reinstalling-windows



0
 

Accepted Solution

by:
columbusdata earned 0 total points
ID: 36436979
Wow, old thread. I forgot this was posted. So, I ended up getting it to work the following weekend. As stated before, I attempted at one point to just restore the C: partition instead of all partitions needed for the exchange databases, and this time it booted. So then I went back and restored the E: and G: paritions, and it still booted but as stated before...the Exchange services would hang and never start.

What finally worked: Restoring the paritions in a different order. Strange as it sounds, before I restored C then E then G. This time I restored the data partitions first (E and G), and then restored C. This resulted in an OS that was boots fully, and the Exchange services start.

It does work, and has been working for the past 6 months, but rebooting the server takes a VEEEERY long time. It looks like it hangs during the splash screen with the progress bar, but waiting about 10-15 mins eventually gets it to go and everything functions. Another issue I've noticed over the past 6 months is that if I have to restart the SMTP service ever, it will fail to restart in a timely manner, but continue having a status of "Starting". Again, waiting long enough (approximately 5-7 minutes) will result in the service eventually entering the "Started" state and mail will flow fine again.

I'm going to get off this box soon...but at least things are working for now...

Thanks all for the suggestions. This one was self fixed though.
0
 

Author Closing Comment

by:columbusdata
ID: 36458778
This felt more like a workaround than an actual solution, but it worked. Thus the B rating.
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Azure FTP connection 5 103
AD backup 6 101
Set VMware vSphere 5.5 VMs to power on automatically after host machine powers off 3 129
Replication in Hyper-V 8 65
Learn how the use of a bunch of disparate tools requiring a lot of manual attention led to a series of unfortunate backup events for one company.
Ransomware is a growing menace to anyone using a computer or mobile device. Here are answers to some common questions about this vicious new form of malware.
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question