• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6476
  • Last Modified:

How do I make my local client hard drive available when using RemoteApp on RDS?


I have a Win Server 2008 R2 member server on my domain configured with the RDS role (RemoteApp Manager, RD Gateway Manager, and RD Session Host).  My remote users access our accounting program via RemoteApp, which is working fine.

The one problem we have is that when they generate a report (such as a spreadsheet), they cannot find an option to save the file locally on their client workstation.  I have verified that they are choosing to redirect all local devices (clipboard, printers, local drives, etc), with no luck.  When they generate the report and attempt to save a copy of the file locally, the 'desktop' listed under favorites is actually on the RDS server.  If I have them drill down further, everything listed under 'Computer' is local to the RDS, too.

If I go farther down to network, I can see a node called 'TSClient' that I assume is a 'Virtual' (for lack of a better word) representation of their RDP session with the RDS, but it doesn't have any network shares available to save the file to.

Am I missing something?

1 Solution
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Are you sure Client Drive Mapping is enabled, and not disabled, disabled in Group Policy?
meelnahAuthor Commented:
I haven't set up any new or changed any of the default GPO's... is that a default policy?

I can confirm that they are presented with a checkbox to map local drives upon authentication.
On your RemoteApp server, go to:

Server Manager -> Roles -> RDS -> RemoteApp Manager

Find the option that says "RDP Settings" and click on it. Then make sure that 'Disk drives' are checked under Devices and resources.

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

meelnahAuthor Commented:
all five options (printers, clipboard, pnp devices, disk drives, and smart cards are checked...

Then move on to Roles -> RDP -> RD Session Host Configuration

Under connections, right click on "RDP-Tcp" -> Properties

Look under "Client Settings" and see if any of the redirections are disabled.

If things are OK there, then look for a GPO that might disable the drive redirection as hanccocka suggested.

meelnahAuthor Commented:
Good call... Drive redirection was disabled with a check mark...

testing now
You do have a logon script set in place for these users don't you?? I am sure you do but I would make sure that it is working correctly for those users locally before troubleshooting remote app any further.
meelnahAuthor Commented:
I don't have a logon script for the users, as they aren't actually connecting to any local desktops... they are only running a published remote application.  Do you suggest that I need to have some restriction in place?  The remote desktop functionality is not enabled at this point, so they are only presented the app.
meelnahAuthor Commented:

perfect call with the RDP-Tcp properties... working fine now.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Tackle projects and never again get stuck behind a technical roadblock.
Join Now