Crystal Reports and SQL Port Number Change

I recently had a database restored from backups and the technician who did the job changed the port number for my database to a non-standard number.  Now Crystal Reports cannot access the SQL database unless I am running it on the machine that physically hosts the database. When I try to access the database from other machine son the domain I get cannot connect errors. I know the new port, but I can figure out where in Crsytal reports to enter it.  Can someone just point me in the right direction?  If you give me a direction I will go hunting for info. I realize this question probably generates more questions than it does answers so i dont mind being pointed toward a concept.
hitsendAsked:
Who is Participating?
 
mlmccCommented:
That is just OLE.

Can you test the connection?

mlmcc
0
 
Kurt ReinhardtSr. Business Intelligence Consultant/ArchitectCommented:
How are you connecting to the database?  Native Driver? ODBC?

~Kurt
0
 
hitsendAuthor Commented:
SQL driver I think I would call it.

In the data explorer I follow > More Data Sources > OLE DB > Make New Connection > MSoft OLE DB Provider for SQL Server > Select Next > SQL server is listed, selected > Specific User Name and Pass is entered > Login Fails
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
hitsendAuthor Commented:
Using Windows NT Authintication works but only on the physical machine that hosts the database.
0
 
hitsendAuthor Commented:
I have that option near the bottom of the dialogue but it fails when I test.

The error is "Test connection failed because of an error in initializing provider. Cannot open user default database. Login failed.
0
 
hitsendAuthor Commented:
Ahhhh, when I refreshed the list of server names, and tried to connect again it came to life. The server list didnt change any on the surface but maybe the ports behind the scene updated.  Spooky but Im glad its working.
0
 
hitsendAuthor Commented:
Great help!!!! Thanks alot.
0
 
mlmccCommented:
I had never seen a need or way to enter/change the port so I didn't know what you were looking at.

mlmcc
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.