Solved

Debugging and Running .NET 2.0 web applications in Windows 7

Posted on 2011-02-28
12
468 Views
Last Modified: 2012-05-11
Hello,

I have moved to a new computer and this one has Windows 7 installed. I'm trying to run and debug some of my .NET 2.0 web applications and have difficulties doing it.

When I run an application, a blank page (about:blank) first shown and a notification icon is placed in the system tray saying:
  ASP.NET Development Server
  http://localhost:56200/W7Test
Then in about half a minute an actual application appears in its own window.

When I try debugging (pressing F5 or debug icon). Debugging starts, the balnk page is not shown, but debugging stops right away and application appears in a normal mode (a little green triangle that you use for debugging is not greyed out and you can start debugging again). Breakpoints in page load are not getting hit either. I'm assuming that debugging starts and ends in this extra blank page, which is not show this time.

Would appreciate your help on solving this problem.
Thanks
0
Comment
Question by:Yurich
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
12 Comments
 
LVL 29

Expert Comment

by:Paul Jackson
ID: 35002618
try deleting the suo file for your solution
0
 
LVL 21

Author Comment

by:Yurich
ID: 35002828
where would I find them? is it *.suo files? I don't see them in my folder. Moreover, I have created a new sample web application with on ebutton and the same story

thanks
0
 
LVL 29

Expert Comment

by:Paul Jackson
ID: 35003594
They are hidden files yes *.suo will be in the same directory as your sln file.

Then follow this : http://msdn.microsoft.com/en-us/library/ms247075(v=VS.80).aspx
0
Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

 
LVL 21

Author Comment

by:Yurich
ID: 35012440
Yes, I found it and did as you suggested and then followed instructions on the link... All it's done is removed my settings for projects, toolbars, and editors - good I saved them before doing it. The problem with no debugging and extra page was not fixed.

Regards
0
 
LVL 29

Expert Comment

by:Paul Jackson
ID: 35012817
Which version of visual studio are you using?
0
 
LVL 29

Expert Comment

by:Paul Jackson
ID: 35012839
0
 
LVL 21

Author Comment

by:Yurich
ID: 35013173
I use VS 2005. That link can be related, but I have SP2 (v.2.0.5....) and local admin rights.
0
 
LVL 59

Expert Comment

by:LeeTutor
ID: 35331325
This question has been classified as abandoned and is being closed as part of the Cleanup Program. See my comment at the end of the question for more details.
0
 
LVL 21

Accepted Solution

by:
Yurich earned 0 total points
ID: 35414121
I found a work-around for this problem...

- Go to the property pages (right click on the project) and under start options, select "Don't open a page. Wait for a request from an external application" (by default it's set to "User current page").

- When you start your application in either modes now(non-debug or debug), it will not appear. But ASP.NET Development Server will still start (an icon in the task bar).

- Now, if you right click this icon and select "Open in Web Browser", the application will run. AND if you're debugging, it will jump to your breakpoint in the application!!

I hope it will help someone before they spend as much time as I have before I figured this one out :)
0
 
LVL 21

Author Closing Comment

by:Yurich
ID: 35446468
I have found a solution myself
0

Featured Post

SharePoint Admin?

Enable Your Employees To Focus On The Core With Intuitive Onscreen Guidance That is With You At The Moment of Need.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

By default the complete memory dump option is disabled in windows . If we want to enable the complete memory dump for a diagnostic purpose, we have a solution for it. here we are using the registry method to enable this.
While working, an annoying popup showing below will come and we cannot cancel or close it form the screen. The error message will come again and again.
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question