SQL Server 2008 R2 Express .NET Framework Prerequisite

In the previous question, I asked whether it is required to install .NET framework 3.5 SP1 if I already have .NET framework 4.0 installed before I can install sql server 2008 r2 express.

According to ms (thanks to vadimrapp1), sql server 2008 r2 express will work on .net framework 4.0 FULL. And I was indeed able to make it work.

Now my question is, does the management studio or any other tools require .net framework 3.5 sp1 to run? Because it keeps complaining about .NET framework 3.5 sp1 not installed when I run the installer for sql server express 2008 r2 with management tools.
LVL 22
Who is Participating?
Vadim RappConnect With a Mentor Commented:
According to Microsoft's response you saw, any edition of Express but the database edition, does require framework 3.5. According to the features of different editions listed at http://www.microsoft.com/express/Database/InstallOptions.aspx , Management Studio is not in Database Edition.
ThomasianAuthor Commented:
I can't believe I missed that!

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.