Net use in Win7

Hi.
Have alot of customers that work out of the office from time to time.
Most have terminal servers, but also need access to shared folders from their local pc.
Have for years used VPN software and a bat file with net use command to connect shares.
like:
net use f: /delete
net use f: \\serverIP\Sharename "password"

Where the user is logged in as domain user, and the password in qutationsmarks is their domain password.
Often use servername instead of server ip, but then with host file like:
192.168.20.2     servername.domainname.local   servername

And as long as the bat file manage to disconnect all the network shares connected piror to this bat file being run, it have always worked great. (with xp that is)

But now with Win 7, it very often does not work.
To clearify, get it working on all computers, but maybe on of 3 times it gives error msg.
Some times it helps, manualy disconnecting shares, reboot, and rerun bat file.
Sometimes it gives error msgs like "an atempt to breach sercurity has occured" (loosely transelated from norwegian...)

Any ideas? maybe a diffrent syntax?
And also, this is the same with sbs2003 and sbs2008 servers

Thanx
LVL 1
Tore JacobsenSystem adminstratorAsked:
Who is Participating?
 
dan_blagutConnect With a Mentor Commented:
Hello

Can you try:
net use f: //server/share /user:username@domain_name password

Dan
0
 
Tore JacobsenSystem adminstratorAuthor Commented:
Hi.
Sorry for late response.
Tried:
##
- Click Start
- Click Control Panel
- Click System and Maintenance
- Click Administrative Tools
- Double-Click Local Security Policy
- In the left pane, click the triangle next to Local Policy
- In the left pane, click Security Options
- In the right pane near the bottom, double-click "Network security: LAN
manager authentication level"
- Click the drop-down box, and click "Send LM & NTLM responses"
- Click OK
###
With no luck.

0
 
TolomirAdministratorCommented:
Give this a try:


Click on the Start button and type SECPOL.MSC in the search function.

Browse to "Local Policies" -> "Security Options". Now Look for the Entry "Network Security: Lan Manager

Authentication Level" and open it. Click on the dropdown menu and select "Send LM & NTLM - use  NTLMv2

session security if negotiated". Aplly the Settings.

In the advanced Sharing settings of Network and Sharing center, you need to have it set as Work/Home

Profile. Now Try It!

Please check these related Policy items also!

Enter the "GPEDIT.MSC" in the start search function box.
Open the "Computer Configuration" goto "Windows Settings" then to "Security Settings" followed by the

"Local Policies" and then "Security Settings".
In the right pane window, "Enable" the following Policies:

Network Access: Allow Anonymous SID/Name translation
Network Access: Let Everyone Permissions aplly to anonymous users

Also, Please Disable the Following Policies:

Network Access: Restrict anonymous access to Named Pipes and Shares
Network Access: Do Not Allow Anonymous Enumeration of Sam Accounts
Network Access: Do Not Allow Anonymous Enumeration of Sam Accounts and Shares



from http://social.technet.microsoft.com/Forums/en-US/w7itprovirt/thread/e08c3500-a722-4b44-b644-64f94f63c8e5
0
 
Tore JacobsenSystem adminstratorAuthor Commented:
Also set usercontroll to low
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.