?
Solved

Error Code 500 on connecting to web service

Posted on 2011-03-01
3
Medium Priority
?
575 Views
Last Modified: 2012-05-11
Got a strange one.  I have passed data to a servicer in the past.  they recently updated their system to use restful webservices.  We changed our system to communicate with them using SOAP Protocol and have the following situation:  If I run this normally, I get the error--

User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; MDDR; InfoPath.2; .NET4.0C; .NET4.0E; OfficeLiveConnector.1.5; OfficeLivePatch.1.3)
Timestamp: Tue, 1 Mar 2011 14:00:21 UTC


Message: Sys.WebForms.PageRequestManagerServerErrorException: An unknown error occurred while processing the request on the server. The status code returned from the server was: 500
Line: 4723
Char: 21
Code: 0
URI: https://aw.spectercorp.com/ScriptResource.axd?d=MrnWiMIKYPKYCjnYmW1ltKhtFkknmg0_O4tgUF_N6KzGROgQjU3KevAG1KcpXlPRq27o5zsP8CrPRM3dYs0Bq8HmOpzpJGiYerX5W-zMa-41&t=ffffffffd5a8ec1b

  If I run it through debug mode in VS2007, It works like a charm.  Any ideas?
0
Comment
Question by:fredstov
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 18

Accepted Solution

by:
ChetOS82 earned 2000 total points
ID: 35007533
They changed to REST web services and you changed to SOAP?

The error you are getting means that your UpdatePanel couldn't be updated, but you need to look at the exact contents of the error to diagnose the problem. I would use Fiddler or Wireshark to determine exactly what the server is returning.
0
 

Author Comment

by:fredstov
ID: 35007825
They gave us 3 ways to work with their service-XML, SOAP or JSON.  SOAP was the only one that worked for us.  This update panel is within an ajax tab control.  My biggest concern is why it works in debug mode but not live.
0
 

Author Closing Comment

by:fredstov
ID: 35029604
this worked perfectly.  fiddler isolated the problem in the Web config.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction This article shows how to use the open source plupload control to upload multiple images. The images are resized on the client side before uploading and the upload is done in chunks. Background I had to provide a way for user…
International Data Corporation (IDC) prognosticates that before the current the year gets over disbursing on IT framework products to be sent in cloud environs will be $37.1B.
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question