Error Code 500 on connecting to web service

Got a strange one.  I have passed data to a servicer in the past.  they recently updated their system to use restful webservices.  We changed our system to communicate with them using SOAP Protocol and have the following situation:  If I run this normally, I get the error--

User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; MDDR; InfoPath.2; .NET4.0C; .NET4.0E; OfficeLiveConnector.1.5; OfficeLivePatch.1.3)
Timestamp: Tue, 1 Mar 2011 14:00:21 UTC

Message: Sys.WebForms.PageRequestManagerServerErrorException: An unknown error occurred while processing the request on the server. The status code returned from the server was: 500
Line: 4723
Char: 21
Code: 0

  If I run it through debug mode in VS2007, It works like a charm.  Any ideas?
Who is Participating?
ChetOS82Connect With a Mentor Commented:
They changed to REST web services and you changed to SOAP?

The error you are getting means that your UpdatePanel couldn't be updated, but you need to look at the exact contents of the error to diagnose the problem. I would use Fiddler or Wireshark to determine exactly what the server is returning.
fredstovAuthor Commented:
They gave us 3 ways to work with their service-XML, SOAP or JSON.  SOAP was the only one that worked for us.  This update panel is within an ajax tab control.  My biggest concern is why it works in debug mode but not live.
fredstovAuthor Commented:
this worked perfectly.  fiddler isolated the problem in the Web config.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.