Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1731
  • Last Modified:

Infragistics igedit_getById function not working after upgrade

I recently upgraded my asp.net application to .net 2.0 and my Infragistics controls from 2005 Volume 3 (CLR1.x) to 2009 Volume 1 (CLR2.0).  Now when I run my application I get a runtime error "undefined is null or not an object" when calling the function igedit_getById('Webnumericedit1').  This function worked before the upgrade.  Any ideas on how to resolve this?

0
nreich
Asked:
nreich
1 Solution
 
jcwChrisWalkerCommented:
I had the same problem. I am using NetAdvatange 200.3 CLR 3.5 in VS 2010. When I looked at igedit_getBuId in the debugger it was null.  I reverted to using the AJAX call $find(clientID) to get the object.

      var txtThreshold = $find(Reveille_MonitorUC_Throttle.txtThrottleThreshold_ClientID);
        alert(txtThreshold.get_value());
 
will show the value of the Infragistics editor control.

      var txtThreshold = igedit_getById(Reveille_MonitorUC_Throttle.txtThrottleThreshold_ClientID);
        alert(txtThreshold.get_value());
 
will fail because igedit_getById is null.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now