Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 394
  • Last Modified:

RDP into Windows 7

I've been having this issue for a while now, and it's really driving me crazy. I have a small network with two windows 7 machines and one windows xp machine. All three machines are set up to accept remote connections through the router, and they're all set up the same way. The router forwards like so

IPAddress:3390 -> Windows 7
IPAddress:3391 -> Windows 7
IPAddress:3392 -> Windows XP

The weird thing is that the windows xp machine always works, and the windows 7 machines have had sporadic issues. Right now all three machines are on and connected to the internet, but I can only RDP into the windows xp machine.
0
charlesAMAG
Asked:
charlesAMAG
1 Solution
 
Alan_WhiteCommented:
Have you changed the ports that the Win7 PCs are listening on using HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber ?
0
 
charlesAMAGAuthor Commented:
I have, but there's a recurring issue with that as well. For some reason the windows xp machine will accept port 3392 as the listening port, but the windows 7 machines will reset to port 36158. I don't know what the deal with that is.
0
 
David Johnson, CD, MVPOwnerCommented:
what client are you using to rdp into these machines?
01-03-2011-1-21-16-PM.png
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
David Johnson, CD, MVPOwnerCommented:
Windows Firewall have you set it to allow remote desktop
01-03-2011-1-26-02-PM.png
0
 
charlesAMAGAuthor Commented:
Yup, those settings are in place. I did get one machine up by changing the way I remote into it. I set the external port to 3390 and internal to 3389, rather than mess with having it listen on a different port. The other machine is still having problems, but I'm not sure if they're related or not.

I'm guessing Windows 7 just doesn't like to have to listen to any port but the default, because I was never able to make the listening port switch stay the way it was supposed to. Also, it would reset itself to something like 35186 or whatever, and the other machine was 35187, but they both responded when I RDPed in through the default 3389. If PortNumber says 35186 they won't RDP on that port, only 3389.

It occurred to me that it might make a difference to mention that these machines each have two network cards connected to two separate networks and internet lines.
0
 
charlesAMAGAuthor Commented:
I changed the listening port on the router and left the internal port the same, so it wasn't really a solution, but it did work around the problem.

Windows 7 should still, ideally, be capable of working with its listening port changed.
0
 
keyadviceCommented:
I had the same issue: I have a Windows 7 Professional 64-bit (SP1) workstation that will not respond to RDP on any port except 3389! I had to do the translation through the router, too.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now