?
Solved

OAB Error with MS Exchange 2010

Posted on 2011-03-01
10
Medium Priority
?
529 Views
Last Modified: 2012-05-11
My company recently installed MS Exchange 2010 and we have all mail systems running except the Offline Address Book. Users with Outllok 2003 and 2007 receive the following error

9:44:57 Microsoft Exchange offline address book
9:44:57       0X8004010F

I have been through numerous web searches and checked all settings in Exchange and can not resolve the problem. There seems to be dozens of fixes for this issue but none have been successful for us.

Please help
0
Comment
Question by:smartini67
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
10 Comments
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35008479
this can be a number of different issues from certificate name mismatch to public folders not being specified in mailbox stores.

First thing to check, do you have a 3rd party SSL certificate?
Second, in the Exchange Management Console on the offline address book does it have public folder distribution enabled (outlook 2003 will require this)
Third, on the properties of the mailbox database can you check under client settings does it have the offline address book and public folders specified?
0
 

Author Comment

by:smartini67
ID: 35008724
1st We have an SSL certificate from Verisign for our external domain name installed yes . . .
2nd - Public folder distribution is enabled
3rd - Properties of mailbox database - client settings . . . both are specified and correct
0
 

Author Comment

by:smartini67
ID: 35008746
red flag with certificate name mismatch . . . maybe
the current certificate is for mail.patientaccounts.org (external domain). internal domain server is bls08.bottomlinesystemsinc.com
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
LVL 74

Expert Comment

by:Glen Knight
ID: 35008757
With the SSL certificate do you have the following names in it:

autodiscover.domainname.com (where domainname.com is the part after the @ in your email address)
autodiscover.domainname.local (the internal autodiscover record)
servername.domainname.local (the fully qualified internal domain name of your server)
owa.domainname.com (the OWA URL)
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35008777
Ahh, you posted whilst I was typing :)

You need a SAN/UCC certificate with Exchange 2010, see step 7 of my article here: http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_2881-Migrate-Small-Business-Server-2003-to-Exchange-2010-and-Windows-2008-R2.html
0
 

Author Comment

by:smartini67
ID: 35009398
Currently our cert is only for the external domain. Is redoing the cert the only way to fix this? DO we have to have SSL for internal OAB? Everythign else works fine.
0
 
LVL 74

Accepted Solution

by:
Glen Knight earned 2000 total points
ID: 35009455
Yes, it needs to contain the autodiscover records, this is essential.  And sadly mo way around it.
0
 

Author Comment

by:smartini67
ID: 35009479
Ok. Thank you
0
 

Author Comment

by:smartini67
ID: 35009927
I am reading the AUTODISCOVER is not used nor work with Outlook 2003. Why are we getting the error mentioned on these apps?
0
 

Author Comment

by:smartini67
ID: 35010081
I am trying to understand how the cert issues you refernece are ONLY affecting access to an Offline Address Book?
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
If you troubleshoot Outlook for clients, you may want to know a bit more about the OST file before doing your next job. IMAP can cause a lot of drama if removed in the accounts without backing up.
how to add IIS SMTP to handle application/Scanner relays into office 365.
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question