Solved

Network drives in Windows 7

Posted on 2011-03-01
4
540 Views
Last Modified: 2012-05-11
Hi guys

I am running as SBS 2003 network that consists of 30 laptops.. a few weeks ago i started updating the laptops from XP to Win 7.. Once in a while people would come up to me and tell me that their network drives would take forever to open when they double click on them.. When i had XP i didnt have this problem so it must be an Win 7 issue.. i ran into this issue my self and it took almost 5 min for the network dtive to open.. than 20 min later it would take a few seconds.. what  is causing this problem.. thank you very much
0
Comment
Question by:MXU2011
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 7

Expert Comment

by:jrwarren
ID: 35009598
Direct from Microsoft KB297684
   I experienced a similar problem and this corrected the issues for me.

Use Registry Editor to increase the default time-out period. To do this, follow these steps, and then quit Registry Editor:

NOTE: You cannot use this method to turn off the autodisconnect feature of the Server service. You can only use this method to change the default time-out period for the autodisconnect feature.
Click Start, click Run, type regedit (Windows 2000 or Windows Server 2003) or type regedt32 (Windows NT 4.0), and then click OK.

Locate and then click the following key in the registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters
In the right pane, click the autodisconnect value, and then on the Edit menu, click Modify.

If the autodisconnect value does not exist, follow these steps:
    On the Edit menu, point to New, and then click REG_DWORD.
        Type autodisconnect, and then press ENTER.
    On the Edit menu, click Modify.
        Click Hexadecimal.
            In the Value data box, type ffffffff, and then click OK.

NOTE: The client-side session is automatically disconnected when the idling time lasts more than the duration that is set in KeepConn. Therefore, the session is disconnected according to the shorter set duration value between AutoDisConnect and KeepConn. To change the time-out duration in the client-side during a UNC connection, specify the arbitrary time in KeepConn.

Locate and then click the following key in the registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Service\lanmanworkstation\parametersValue: KeepConn

    Data type : REG_DWORD
    Range : 1 to 65535 (sec)
    Default value: 600 sec = 10 mins
 
Command Line
NOTE: If you use this method, you may turn off the autotuning feature for the Server service.

To change the default time-out period for the autodisconnect feature of the Server service, open a command prompt, type the following line, and then press ENTER

net config server /autodisconnect:number

where number is the number of minutes that you want the server to wait before it disconnects a mapped network drive. The maximum value for this command is 65,535.

NOTE: If you set the autodisconnect value to 0 (zero), the autodisconnect feature is not turned off, and the Server service disconnects mapped network drives after only a few seconds of idle time.

To turn off the autodisconnect feature, open a command prompt, type the following line, and then press ENTER:

net config server /autodisconnect:-1
0
 
LVL 12

Accepted Solution

by:
tgtran earned 250 total points
ID: 35010357
You may want to try disabling IPV6, offload chimney, and autotuning

From elevated CMD:
To sse current settings:
        netsh int tcp show global
To disable:
       netsh int tcp set global chimney=disabled autotuninglevel=disabled

To disable IPV6:
       netsh interface teredo set state disable
       netsh interface 6to4 set state disabled
       netsh interface isatap set state disabled
0
 

Author Comment

by:MXU2011
ID: 35010765
to tgtran:
Ok i will try that but for some reason even when i click on my computer of the printers it sometimes does the same thing.. also can you please give me the instructions to enable all the settings just in case the disabling doesnt fix the problem?  thanks a lot
0
 
LVL 12

Expert Comment

by:tgtran
ID: 35010823
If you want to reverse the settings, just change the "disabled" to "enable"
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

You may have discovered the 'Compatibility View Settings' workaround for making your SBS 2008 Remote Web Workplace 'connect to a computer' section stops 'working around' after a Windows 10 client upgrade.  That can be fixed so it 'works around' agai…
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
This Micro Tutorial will teach you the basics of configuring your computer to improve its speed. It will also teach you how to disable programs that are running in the background simultaneously. This will be demonstrated using Windows 7 operating…
This Micro Tutorial will give you basic overview of the control panel section on Windows 7. It will depth in Network and Internet, Hardware and Sound, etc. This will be demonstrated using Windows 7 operating system.

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question