Solved

Exchange and Server 2008 Networking Issues

Posted on 2011-03-01
15
321 Views
Last Modified: 2012-05-11
I am having a rather serious problem with my exchange 2007 server.  The end result is that Outlook Anywhere, which every single one of our employees requires, fails about every 30 seconds.  If I run the command iisreset /restart in command prompt it works for about 30 seconds to 1 minute tops then fails again.  By fails I mean that when a user opens outlook they are repeatedly prompted for a password.  Strangely enough OWA works just fine.  This problem appears to be from a larger issue so I will try to explain it below.  Just one last thing to add, if I run the testexchangeconnectivity.com tool when Outlook-Anywhere is failing I get the response: "

A Web exception occurred because an HTTP 401 - Unauthorized response was received from Unknown."

Just thought I would add that in.  Now on to my explanation.


About 3 months ago we moved from a single server sbs 2003 environment to a dual server 2008 exchange 2007 environment.  Server 2008 worked beautifully and since we had a need for a few special stand-alone servers we started using Hyper-V.  At the same time I also setup network card teaming on each of my Servers.  Both servers use a dual port intel Pro 1000 PT card.  

One week ago I noticed that the exchange server could not access any of the network shares.  I was able to use ping and nslookup to resolve the address of the file server but if I used something like "net view \\servername" or even went to run and typed \\servername or \\ipaddress I was given the standard 0x800-something error that basically stated there must a network issue check your connection.  I also noticed that Group Policy was not able to apply itself correctly since there were errors stating that \\domainame\share\gpt.ini were inaccessible even though every other computer in the domain could access it.  

I let it slide a few days then tried to fix the issue.  This ended up wreaking havoc.  I noticed that there were a ton of Hyper-V virtual switches on this server so i tried to delete them.  They would not delete.  Around that time we very suddenly lost network connectivity.  The teaming on the network cards failed over the weekend and luckily the server had a single NIC built-in.  I was able to disable the teamed NIC's and simply setup the other NIC with the correct IP information.  However after doing this I started noticing strange errors in the event viewer one in particular is the NetBT Error 4321 which states:

The name "COMPUTERNAME         :20" could not be registered on the interface with IP address x.x.x.x. The computer with the IP address x.x.x.x did not allow the name to be claimed by this computer.

Just an FYI both IP's with x.x.x.x are the same IP.

Also I have noticed a bunch of errors related to the World Wide Web Publishing Server and the Windows Process Activation Service which keep failing simultaneously.  

At this point I do not know what to do.  I am literally just trying to tread water until the weekend and blow out the exchange Server and do a complete reinstall of Server 2008 and Exchange 2007.  Its not an ideal situation by any means but at this point it seems my only option unless someone can help.

Thanks
0
Comment
Question by:Prolumina
  • 7
  • 3
  • 3
  • +1
15 Comments
 
LVL 13

Expert Comment

by:BCipollone
Comment Utility
Did you do all of the updates to your exchange server?
0
 
LVL 13

Expert Comment

by:BCipollone
Comment Utility
Oh just a thought... that interface error may be because the arp cache has not been cleared after switching NIC's. I din't look it up though so don't quote me on that :P
0
 
LVL 16

Accepted Solution

by:
Carol Chisholm earned 333 total points
Comment Utility
I have given up trying to use teaming and Hyper-V. It's a nightmare.

I would not imagine your Exchange server really has a problem, is sounds as if the virtual network underneath it is a mess.

Do some reading :

http://blogs.technet.com/b/jhoward/archive/2008/06/16/how-does-basic-networking-work-in-hyper-v.aspx
http://blogs.msdn.com/b/virtual_pc_guy/archive/2008/01/08/understanding-networking-with-hyper-v.aspx
http://social.technet.microsoft.com/wiki/contents/articles/hyper-v-virtual-networking-best-practices.aspx

What I owudl try but by no means sure it will work in your case.
Back everything up, document what you want your setup to be
Disable your network adapters in the host OS (Windows 2008)
Shut down the VMs get rid of all the virtual networks
Rebuild the virtual networks according to your needs
Reconnect the VMs
Restart your VMs

Remove the
0
 

Author Comment

by:Prolumina
Comment Utility
The only update that I am seeing available at this point is the update to SP2 for Server 2008.  I am hesitant to do this just do to all of our problems right now.  Cleared ARP Cache let me see how things are and I will report back
0
 

Author Comment

by:Prolumina
Comment Utility
In an attempt to fix these issues I actually unistalled the Hyper-V role and moved everything to my second server.  Now the problem is I have 8 or 9 Network Adapters showing up in the Device Manager.  4 of them actually exists the rest are carryovers from the previous Hyper-V install.  

I tried removing the adapters to no avail so I then reinstalled Hyper-V hoping it would let me remove the adapters.  I had no luck there.  If I could find a way to remove the Virtual Switches I would happily do what you suggested but so far no luck.  I even followed this tutorial and got none of the results the tutorial was trying to achieve:

http://eniackb.blogspot.com/2009/10/hyper-v-error-error-applying-new.html

Any thoughts on how to blow these things out?
0
 
LVL 3

Assisted Solution

by:Zach2001
Zach2001 earned 167 total points
Comment Utility
you may be able to -FORCE the issue (as it were) using the powershell
Reference:
http://pshyperv.codeplex.com/
How:
http://www.hypervizor.net/2009/11/deleting-hyper-v-virtual-switch-using.html

Rant:
The one client we have using HyperV is a disaster zone, servers, objects & settings mutate, disapear, reapear and generally misbehave to the point where engineers are scared of doing ANYTHING to the hyperV server.  How did VS2005 evolve into this nightmare?
0
 

Author Comment

by:Prolumina
Comment Utility
I tried that before and it didnt work.  This time around It cant even see any virtual switches even though device manager picks them up.  Any thoughts on how else to remove them?
0
Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

 

Author Comment

by:Prolumina
Comment Utility
UPDATE:  I was able to remove the Virtual Switches by way of this tutorial: http://social.technet.microsoft.com/Forums/en-US/winserverhyperv/thread/0d42129e-fef5-43ee-8247-50874fbc01b8/

Now i ran the testexchangeconnectivity test to no avail however I have yet to restart my server.  I will do that in roughly 20 minutes and see where I am at that point.  

Any ideas from here on out would be greatly appreciated.

0
 
LVL 16

Assisted Solution

by:Carol Chisholm
Carol Chisholm earned 333 total points
Comment Utility
0
 
LVL 16

Expert Comment

by:Carol Chisholm
Comment Utility
0
 

Author Comment

by:Prolumina
Comment Utility
Update:  So all of the old Virtual Switches and Teamed NIC's have been remover but I still have the same problem.  After I reset the server (removing Hyper-V Role again) I tried using Outlook Anywhere.  It worked for the first 5 minutes after startup then crapped out again.  

I dont know where to go from here.  I was tempted to remove the Outlook Anywhere configuration and then rebuild it.  Any thoughts or suggestions?  Still getting the error:

A Web exception occurred because an HTTP 401 - Unauthorized response was received from Unknown.

When using testexchangeconnectivity.com

Thanks again for the help.  
0
 
LVL 3

Expert Comment

by:Zach2001
Comment Utility
have you proven that your perimter security isn't causing the issue, perhaps by adding an entry to an internal machines' hosts file ( 1.2.3.4  webmail.myexternaldomain.com ) and testing RPC over HTTPS directly against the server ?

That error stinks of sonicwall or checkpoints AI filtering.

Also, launcg outlook with /rpcdiag command to see if that throws up any clues, but my current dollar is on perimeter systems.
0
 

Author Comment

by:Prolumina
Comment Utility
Update:

Its not security.  I use a Cisco 2900 ISR for my firewall and that is pretty damn good at keeping flukes like this from occuring assuming that you set it up right of course.  

After all my work i finally started looking at it from solely an exchange CAS issue and not a Hyper-V/NIC/Server 2008/Exchange and what not issue.  I went into the exchange shell and ran get-outlookanywhere to verify my settings.  On a whim I switched from NTLM to basic authen and suddenly it worked.  Its going on 40 minutes or so no problems.  Strangely enough all of my outlook clients are conf to use NTLM and they are working fine with basic.  Even after restarting both IIS and Exchange Information Store to commit changes.  

I think this is solved but will leave the q open for another 2 days to verify.  Thanks for all of your help.
0
 
LVL 3

Expert Comment

by:Zach2001
Comment Utility
heh, wow - that would make some sense, I wonder if it's anything to do with recent patching.  loads of 2010 SP1 people have been having anywhere issues too.

Mind you, domain machines set for LanMan not working....  Could it be simple time offset issue ?
0
 

Author Closing Comment

by:Prolumina
Comment Utility
They were heklpful in this whole endeavor.
0

Featured Post

Do email signature updates give you a headache?

Do you feel like you are constantly making changes to email signatures? Are the images not formatting how you want them to? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today.

Join & Write a Comment

This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
Veeam Backup & Replication has added a new integration – Veeam Backup for Microsoft Office 365.  In this blog, we will discuss how you can benefit from Office 365 email backup with the Veeam’s new product and try to shed some light on the needs and …
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
how to add IIS SMTP to handle application/Scanner relays into office 365.

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now