Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2416
  • Last Modified:

NO tests were run because no tests are loaded or the selected tests are disabled

Hi,
When I compile my UnitTest (C#) project I am getting below error.

The "BuildShadowTask" task failed unexpectedly.
System.NullReferenceException: Object reference not set to an instance of an object.
   at Microsoft.VisualStudio.TestTools.BuildShadowReferences.BuildShadowTask.Execute()
   at Microsoft.Build.BuildEngine.TaskEngine.ExecuteInstantiatedTask(EngineProxy engineProxy, ItemBucket bucket, TaskExecutionMode howToExecuteTask, ITask task, Boolean& taskResult)      UnitTest


And also, when I run it , it says - NO tests were run because no tests are loaded or the selected tests are disabled

Please help me. how can I run my UnitTest. This is one of the projects in my application.
0
GouthamAnand
Asked:
GouthamAnand
1 Solution
 
PJBXCommented:
The accessor file might be causing this issue. If the file exists, delete or remove it from the project folder:

http://blog.hinshelwood.com/archive/2008/07/03/tfs-error-msb4018-the-quotbuildshadowtaskquot-task-failed-unexpectedly.aspx
0
 
GouthamAnandAuthor Commented:
Thanks a lot.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now