Solved

Removing Managed Folders after Migrating to Retention policies

Posted on 2011-03-01
4
1,268 Views
Last Modified: 2012-05-11
We upgraded from exchange 2007 to 2010.    

In 2007 we uses MRM to manage the age of items in the inbox.    After 30 days, the items would be moved to a ManagedCustomFolder called "Deleted Inbox Items".    Now that we upgraded, I created a Retention policy that does the same where after 30 days the items are removed and 14 days after they are gone from recoverable.    

So now that the Retention policy is in place and applied to everyone, I wanted to remove the old Managed Folder items.  

I used 'remove-managefoldermailboxpolicy' and deleted the policy.  

Now the problem...   When I went to remove the custom managed folders I get
[PS] C:\Windows\system32>Remove-ManagedFolder

cmdlet Remove-ManagedFolder at command pipeline position 1
Supply values for the following parameters:
Identity: Deleted Inbox Items
Managed Folder <Deleted Inbox Items> cannot be deleted. Another folder is configured with a retention action that moves
 items into this folder. You must change the destination of the rentention action for folder <Inbox> for content settin
g <Inbox items older than 30 days>.
    + CategoryInfo          : InvalidOperation: (Deleted Inbox Items:ADObjectId) [Remove-ManagedFolder], InvalidOperat
   ionException
    + FullyQualifiedErrorId : 6D00D1AB,Microsoft.Exchange.Management.SystemConfigurationTasks.RemoveManagedFolder


I assume this means that this folder thinks there is still a policy wanting to move items into it....    

But I have nothing listed under Get-ManagedFolder-MailboxPolicy  and AFAIK the retention policies do not support moving to custom managed folders...    So where else can I look to find the culprit that is keeping me from deleted the managedcustomfolders?  
0
Comment
Question by:MikeKane
  • 2
  • 2
4 Comments
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35051139
Where are u running this on 2007 or 2010 Shell

Run this on 2007 and specify the server name for the attribute -Server

If u cant do the above open EMC in 2007 and delete it using the GUI
0
 
LVL 33

Accepted Solution

by:
MikeKane earned 0 total points
ID: 35055982
The question said that I upgraded from 2007 to 2010.  

It actually turns out there was also a "managedContentSetting" on the inbox which prevented the managed folder, which was the recipient of the copy item.    Once I cleared the content setting, I was able to remove the managed folder.
0
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35061417
lol this was a known issue :)
0
 
LVL 33

Author Closing Comment

by:MikeKane
ID: 35115111
See above post for the solution to my issue
0

Featured Post

The problems with reply email signatures

Do you wish that you could place an email signature under a reply? Well, unfortunately, you can't. That great Exchange/Office 365 signature you've created will just appear at the bottom of an email chain. What a pain! Is there really no way to solve this? Well, there might be...

Join & Write a Comment

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
A procedure for exporting installed hotfix details of remote computers using powershell
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now