Solved

Could not load the assembly 'App_Web_jri5b8jc'. Make sure that it is compiled before accessing the page.

Posted on 2011-03-01
5
448 Views
Last Modified: 2012-06-27
hi there,
Im getting this error after i called my page:
Server Error in '/' Application.

Parser Error

Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Could not load the assembly 'App_Web_jri5b8jc'. Make sure that it is compiled before accessing the page.

Source Error:


Line 1:  <%@ page language="VB" autoeventwireup="true" inherits="Contacts, App_Web_jri5b8jc" %>
Line 2:  
Line 3:  <%@ Register Assembly="AjaxControlToolkit" Namespace="AjaxControlToolkit" TagPrefix="cc1" %>

Source File: /site_flash/Contacts.aspx    Line: 1

Version Information: Microsoft .NET Framework Version:2.0.50727.4206; ASP.NET Version:2.0.50727.4209

I have check the bin folder and the dll App_Web_jri5b8jc.dll actually does exist. I have removed everything from the folder and recompiled (meaning publish the website once again) and copy and paste to the directory and not luck. get the same error with a different dll name obviously.
How can i solved this issue? i have spend a few hour online trying to solve the issue but they refer me to hot fix but it does not do anything.

It works on local machine, but not remote server
Im working on VS 2005
Thanks,
COHFL
0
Comment
Question by:COHFL
  • 3
  • 2
5 Comments
 
LVL 13

Expert Comment

by:Rick
ID: 35011506
Have you renamed the page recently?
If so, check the Inherits="partial_class_name"
Make sure that "partial_class_name" is the same as stated in your codebehind file.
0
 

Author Comment

by:COHFL
ID: 35012093
i haven't change anything. I published it and thats it
0
 
LVL 13

Expert Comment

by:Rick
ID: 35017598
Well, have you checked if the partial class name matches what is in the page's markup file?
0
 

Author Comment

by:COHFL
ID: 35017611
actually the problem gto resolved when i put the dll on the root of the directory under wwwroot/bin instead of the directory where the app resides any reason why this happens?
0
 
LVL 13

Accepted Solution

by:
Rick earned 500 total points
ID: 35017881
ASP.NET only reads the bin directory of the application root.
0

Featured Post

Live: Real-Time Solutions, Start Here

Receive instant 1:1 support from technology experts, using our real-time conversation and whiteboard interface. Your first 5 minutes are always free.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

One of the pain points with developing AJAX, JavaScript, JQuery, and other client-side behaviors is that JavaScript doesn’t allow for cross domain request for pulling content. For example, JavaScript code on www.johnchapman.name could not pull conte…
I recently went through the process of creating a Calendar Control of events with the basis of using a database to keep track of the dates that are selectable, one requirement was to have the selected date pop-up in a simple lightbox.  At first this…
Along with being a a promotional video for my three-day Annielytics Dashboard Seminor, this Micro Tutorial is an intro to Google Analytics API data.
This video shows how to use Hyena, from SystemTools Software, to bulk import 100 user accounts from an external text file. View in 1080p for best video quality.

813 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now