Solved

PC crashes when it wakes up from sleep

Posted on 2011-03-01
7
791 Views
Last Modified: 2012-05-11
Hi all,

I know this is a really complicated situation to troubleshoot, but here is my problem. My media PC running windows 7, freezes when waking from sleep. The HDD light remains perminantly on. Sometimes the computer gets to the desktop but I cannot do anything as it freezes after the first interaction I make with the computer.

I have reinstalled Windows 7 with the BIOS already set to S3 before hand and that has made no difference.

When I use 'powercfg /a' it reports it's good for S3, but when I use the program 'dumppo.exe admin' it says the minsleep is S1

If I type the command 'dumppo.exe admin /ac minsleep=S3' it reports the change but after a reboot of the system it's back to S1 again.

'powercfg -energy' reports a few errors with USB but then so does my laptop and that works fine.

Funny thing is, if I put the PC into hybernate it boots up no problem at all!!!

I have spent months on this and been googling for hours but nothing works. The only solution is to leave it on 24/7.

Sometimes after a wake fail, the HDD is not listed in the BIOS so the PC does not boot-up untill I shutdown and power off completely again, then I have to enter the BIOS to place that HDD 1st in the boot seqence.

My question is, does anyone know of any tips?
Is the HDD simply not powering up after resuming from sleep?

MB: ASUS A8N-SLI Premium
HDD: Maxtor 7V300F0

Hope someone can help.

Regards

SNIFFY.
0
Comment
Question by:SNIFFER_dog
7 Comments
 
LVL 6

Expert Comment

by:MISOperations
ID: 35012077
Disable the sleep functionality of the pc and just lock it when not in use, running 24/7 vs locking vs sleep locking is the best alternative.
0
 
LVL 13

Expert Comment

by:upalakshitha
ID: 35013720
The buggy issues came from two words... HYBRID SLEEP

you can see the where from :
- Control Panel > Hardware and Sound >Power Options > Edit Plan Settings
- Open the "Sleep" tree > Open the "Allow Hybrid Sleep" tree and choose "OFF"

http://maximumpcguides.com/windows-7/turn-off-hybrid-sleep-in-windows-7/
0
 
LVL 30

Expert Comment

by:ded9
ID: 35015154
Update you graphics card driver. Go to manufacturer website and install latest graphics card software.

Restart the computer and then check.


Ded9
0
Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 

Author Comment

by:SNIFFER_dog
ID: 35015786
As the main use is for a Media center PC is to come out of standby to record etc... the sleep function is a must, but I might try the lock function but that is not the main aim, but thanks for the tip.

Hybrid sleep is already off, and makes no difference to the situation but again thanks for the try.

Windows 7 Ultimate 64Bit was re-installed 2 days ago and so was the latest drivers for the graphics card so I'm unsure if that's the problem.


My motherboard is ASUS A8N-SLI Premuim, there is very limited driver support for it under W7 so I have used Vista 64Bit drivers where I can. This morning I installed NVidia nForce drivers as the MB uses the old nForce 4 chip. This has provided some success, I have been able to sleep and hybrid sleep and also wake from it! However, after that has happened sometime later the computer ATX simply shuts down and powers off the PC without shutting down windows first. So I now have a situation where I can sleep but after that, the PC has a habit of suddenly switching off which has the obvious disastrous concequences.

It's looking like a MB driver problem for this 5 year old MB, it's frustrating as there is no support from ASUS under W7.

Anyone have any tips as to solving the ATX issue?

However, it looks like I will be forced to buy a new MB to keep up with W7!!!!!!!!!!!!
0
 
LVL 30

Expert Comment

by:ded9
ID: 35151471
Reinstall windows 7 and then check.


Ded9
0
 

Accepted Solution

by:
SNIFFER_dog earned 0 total points
ID: 35283348
Still no solution must need new hardware as there is no support for nForce 4 chipsets in Windows 7
0
 

Author Closing Comment

by:SNIFFER_dog
ID: 35321766
No drivers for nForce 4 in windows 7
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Article by: Lee
Windows 7 Ultimate and Enterprise (and 2008 R2) introduced a new feature you may not be aware of - Boot from VHD.   Boot from VHD (or what Microsoft refers to asNative Boot allows you to install Windows to a VHD (Virtual Hard Disk) file that is t…
On some Windows 7 (SP1) computers, Windows Update becomes super slow even the computer is reasonably fast.  There's one solution that seemed to have worked well for me (after trying a few other suggested solutions).
This Micro Tutorial will teach you the basics of configuring your computer to improve its speed. It will also teach you how to disable programs that are running in the background simultaneously. This will be demonstrated using Windows 7 operating…
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum editing capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question