Solved

SBS 2008 Outlook picking up external URL on Exchnage Setup

Posted on 2011-03-01
5
522 Views
Last Modified: 2012-05-11
I have recently installed an SBS 2008 Server.  I followed the install to the letter, purchased a cert and installed it.  The certificate seems to work correctly when hitting the box from outside the network.  When attaching an Outlook client inside the network however Outlook 2007 prompts for credentials and is referencing the external URL.  I have created an A record in DNS called autodiscover and am pointing it to the file server IP address.  No luck.  Its a single server, flat network with 40 seats so shouldn't be too complicated.  Your help is appreciated.
0
Comment
Question by:Lanopy
  • 2
5 Comments
 
LVL 11

Expert Comment

by:louisreeves
ID: 35014265
SBS 2008 Exchange setup is very easy. There is a certificate you can use in the public download folder. If you are using a third party certificate, What are you trying to achieve? This question leads down the path of outlook anywhere. You should clearify what you are doing and include any documents you are using. Here is the Subject matter you are refering to in the link below. If you are not confortable with the subjust below. you should remove the Third party certificate and get everything working without it and then move forward from that point.

http://msexchangeteam.com/archive/2007/07/02/445698.aspx

To handling your issue in place start by:

1. Hold Control key and simultaneously RT CLICK the mouse, whil hovering over the Outlook Icon in the task tray.
2.  Click test auto configuration -Uncheck guesssmart and secure guessmart
3,. Enter credentials
4. Click test
5. look at the log tab.
6. this will show you how yout Outlook is trying to connect.
7. Verify the outodiscover and SCP connection points
8. Go to the Exchange server and use the following doument to troubleshoot autodiscover.

http://technet.microsoft.com/en-us/library/bb332063(EXCHG.80).aspx

I can give you a brief overview of what you are doing but it is not comprehensive.

1. Get-ClientAccessserver |FL (to see waht connection points are wrong)
2. Get-ExchangeCertificate to make sure the certificate is there and enabled.
3. test-outlookwebservices. to again see if you need to make changes to the SCP, or autodiscover as compared to your outlook test.
4. use the right set command to set the virtual directories that were wrong.
5. Go to IIS default web site bindings and make sure the certificate is binded to the port. rt click default web site and edit bindings. (edit each port and re- associate the certificate)
6. Go to EMC and look in the properties for autodiscover, oab,etc.. and see the internal and expternal URLs there. They should coorestpond to waht you ran in the internet address wizzard and the othere settings you have seen.
7. Run the fix my network wizzard
8. Run the connect to the internet wizzard.
9. Run the Internet address wizzard.
10. Make sure outlook 2007 had the latest office SP
11. Make sure exchange 2007 has the latest sp as well.

If you decide not to use the third party Certificate.

0. remove the certificate from exchange.
1. Run the fix my network wizzard
2. Run the connect to the internet wizzard.
3 Run the Internet address wizzard.
4. Make sure outlook 2007 had the latest office SP
5. Make sure exchange 2007 has the latest sp as well.

I dont know if this helps. There is alot to cover. I can try to answer better if I had a little more infomation, like how you actually set this up and what you were trying to achieve.

L
0
 
LVL 11

Expert Comment

by:louisreeves
ID: 35014314
Good evening.

The third party certificate is an issue of its own. Do you have a doc you used to install the certificate>? Maybe posting will help us understand. For example, Godaddy has this
http://sbs.seandaniel.com/2009/02/installing-godaddy-standard-ssl.html

That said,

you really have to make sure the you used a SAN certificate with the right names, the certificate installed correctly,

http://blogs.technet.com/b/sbs/archive/2009/12/14/how-to-manually-install-certificates-in-sbs-2008.aspx

The next issue is waht you are doing with access. Are you trying to secure external access with this as in outlok anywhere? Are you just trying to connect to outlook 2007 from within the domain.


Assuming you are trying the latter.

1. google the  outllook autoconfiguration test  (ctrl- rt click)
2. Verify your SCP and autodiscover.
3. Go to exchange 2007 and get-clientaccessserver |fl
4. test-outlookwebservices |fl
5. From these you should determin if you have to run a set command of if you have to make a chnage in IIS, ot to certificatres.

I hope this helps troubleshoot. Perhaps you could post some results for us ?

http://blog.sembee.co.uk/post/More-on-SSL-Certificates-with-Exchange-2007.aspx

http://blog.sembee.co.uk/post/Exchange-2007-and-SSL-Certificates-Take-2.aspx
0
 

Accepted Solution

by:
Lanopy earned 0 total points
ID: 35016597
I beleive I may have resoved the issue.  I did not realize I had not approved the Update rollups in WSUS.  Once I applied Exchange Rollup 10 my issue seems to have resolved itself.  Both of htese responses touch on issues I may need to consider.  I applied a UCC Multi domian cert from a third party using the SBS certificate wizards.  It applied succesfully and both "mail" and "remote" domian.com work as intended.  I plan on trying the https://testexchangeconnectivity.com/ tool as soon as I cut my MX records.  Thanks for the repsonses.  Not sure if I shold leave the question open or start a new issue if it does not work in two days.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 37419205
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

I work for a company that primarily works with small businesses as their outsourced IT vendor. As such the majority of these customers utilize some version of Small Business Server. Due to the economics of running a small business, many of these cus…
You may have discovered the 'Compatibility View Settings' workaround for making your SBS 2008 Remote Web Workplace 'connect to a computer' section stops 'working around' after a Windows 10 client upgrade.  That can be fixed so it 'works around' agai…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now