Solved

Restarted SBS 2008 and OWA stopped working!

Posted on 2011-03-01
40
2,123 Views
Last Modified: 2012-05-11
Hello,
I just restarted my SBS 2008 box and now I have no access to OWA.  I have a feeling its an SSL issue.  Can anyone help?
0
Comment
Question by:SteveMat11
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 24
  • 9
  • 4
  • +1
40 Comments
 
LVL 6

Expert Comment

by:Dustin99352
ID: 35013409
What does it say when you attempt to access OWA?
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35013418
Did you recieve any errors?
Try restarting IIS.
Can you access any portion of the default website?
0
 

Author Comment

by:SteveMat11
ID: 35013451
Cannot access any portion of the default website.  It gives me the usual IE cannot display the webpage.  I received no errors on startup.  Tried several times to iisreset.

Thanks for the help guys, im going nuts here.
0
Get MySQL database support online, now!

At Percona’s web store you can order your MySQL database support needs in minutes. No hassles, no fuss, just pick and click. Pay online with a credit card.

 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35013460
Are you connecting to an IP or a URL?
Try the https:// IP /OWA
If that works it is a DNS issue.
0
 

Author Comment

by:SteveMat11
ID: 35013477
Nope, tried them all.
0
 
LVL 6

Expert Comment

by:Dustin99352
ID: 35013484
go to run and type services.msc

Scroll down to the Microsoft Exchange services and make sure they are running.
Make sure that IIS is started in the console as well.  It's quite possible it isn't, and that's why you're recieving the issue.

If you don't see anything on those two, then go to server manager, diagnostics, and look at the events under system, and under applications for Microsoft Exchange and see if anything is popping up in there.
0
 

Author Comment

by:SteveMat11
ID: 35013496
I have two sites running under iis.  The second site is non SSL and is running fine.  Its just my default which redirects to /owa that isnt running.  When i look at ssl settings they are all grayed out.  All services are running.  
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35013508
Are you attempting to connect from whithin the LAN?
Can you ping the URL?
0
 

Author Comment

by:SteveMat11
ID: 35013511
im sorry the site is running according to iis however cant display a page.
0
 

Author Comment

by:SteveMat11
ID: 35013517
I am connecting from outside.  I cannot ping the URL however I can RDP the machine by using the URL.  Doesn't make any sense to me.
0
 
LVL 6

Expert Comment

by:Dustin99352
ID: 35013524
Did you check the MS Exchange Services?  
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35013545
If you have not tried to ping the URL in the past, the router may be set to ingore ping requests to protect from DOS attacks.
You are attempting to connect to OWA through the browser on the server in question?
0
 
LVL 15

Expert Comment

by:WalkaboutTigger
ID: 35013550
With the SSL-related settings grayed-out, it implies you have no SSL certificate associated with the website.  Regardless of this, let us start with the basics.
From the IIS console, when you select the Properties of the default website, what IP address is it assigned to?  Does it have any host headers associated with it?
On the Documents tab, what is the default document?
If you have a redirect in place from the root of the default site, are you being correctly redirected or are you being redirected to an HTTPS URL?
If you go to the Server Certificate dialog, does the server have a certificate in the Certificate Store?  If so, have you attempted to reassign it to the site?
For what reason was the server rebooted?  Had anything changed prior to that reboot?

0
 

Author Comment

by:SteveMat11
ID: 35013575
Its assignesd to 192.168.1.95:80 which is correct, default doc is index.htm on top.  Dont see anything about host headers.  It is correctly redirected.  Where do I find info on the cert?  Im in iis7.  Nothing has changed prior to reboot.  I had to reboot because mail was getting held up at my 3rd party spam company.  It was getting an "out of resources" error.  Mail has since been delivered after reboot however owa will not work.
0
 

Author Comment

by:SteveMat11
ID: 35013689
Ahhh.... when I click SSL settings under default site an alert pops up in the top right corner saying this site does not have ssl bindings and cannot accept ssl connections.  
0
 

Author Comment

by:SteveMat11
ID: 35013756
Were making progress... I added port 443 to bindings since it was missing and now i get redirected to an IIS error, "404 - File or directory not found.
The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable."
0
 
LVL 15

Expert Comment

by:WalkaboutTigger
ID: 35013769
You'll actually need to assign an SSL certificate to the server and not just bind port 443.

If you open the Properties of the website and go to the Directory Security tab and select Server Certificate, do you have an option to assign a certificate?

If so, select that option and see what certificates it show you as eligible to be installed.
0
 

Author Comment

by:SteveMat11
ID: 35013792
There was a pull down of all of the certs and I attached one to it.  When I open the site in IE i see the lock and when I click it the correct godaddy cert appears.  Just getting a 403 error from iis.
0
 

Author Comment

by:SteveMat11
ID: 35013793
im sorry 404 not 403
0
 
LVL 15

Expert Comment

by:WalkaboutTigger
ID: 35013921
what is the URI that is giving a 403?

Https://host.domain.com/?????
0
 

Author Comment

by:SteveMat11
ID: 35013933
yes, 404 not 403
0
 

Author Comment

by:SteveMat11
ID: 35013936
I can access in on the server from https://localhost/owa
0
 

Author Comment

by:SteveMat11
ID: 35013982
Does anyone have ideas why I can see the OWA login page if im in the server and i point IE to https://localhost/owa however if I try that (replacing the localhost with the ip obviously) I get a 404 error??  Any help is greatly appreciated.
0
 

Author Comment

by:SteveMat11
ID: 35014188
Why is it that https://localhost/owa works however if I replace localhost with my external IP address I get a 404 error?
0
 
LVL 15

Expert Comment

by:WalkaboutTigger
ID: 35014232
What IP addresses is the default website bound to?
You said you have another website on the server - what IP addresses and ports are it bound to?
0
 

Author Comment

by:SteveMat11
ID: 35014245
The default website is bound to: http    mail.mydomain.org   80   192.168.1.95 (.95 is exchange)
                                                     https                                  443   192.168.1.95

443 has the mail.mydomain.org SSL cert selected.


The other site has 1 entry for http     80 192.168.1.99


The other site is non SSL and works fine.  I can access it externally.  The OWA however I can only access from the server itself by using "localhost" as opposed to the ip address.  I DONT GET IT!
0
 
LVL 15

Expert Comment

by:WalkaboutTigger
ID: 35014256
So going to http://192.168.1.95 performs the redirect to what URL?

Does it go to https://192.168.1.95/owa or is it something different?

I presume the 443 is listed under Secure Socket Layer and not at the top.
0
 

Author Comment

by:SteveMat11
ID: 35014290
http://192.168.1.95 returns an IE error HTTP 404 not found.
https://192.168.1.95/owa returns Server error 404, looks like a friendlier message, not the IE default.  by typing 192,168.1.95 it should redirect to the https version with /owa at the end.

What do you mean by 443 is listed under SSL and not at the top??  In the bindings?  Yes, it has an https next to it.
0
 
LVL 15

Expert Comment

by:WalkaboutTigger
ID: 35014322
So if you look at the virtual directory configuration for the OWA directory and select Properties, what is the default document?  If you look in the directory, does that document exist?
0
 

Author Comment

by:SteveMat11
ID: 35014332
All there.  I noticed that when I right click default website and choose browse, IE opens and it tries opening a page that is https://mail.mydomain.org/owa/owa.  Is there supossed to be two /owa's at the end?  I checked the redirect and its there only once, not sure of why its putting a second one in.  Can this be the issue?  I have a feeling something is wrong with either the bindings or the redirect for either the default website or the SBS web applications site.  Which one should I be working with?  Weird how all of these problems after a simple reboot with no application changes or updates installed.  Thanks for all your help by the way, im completely lost/frustrated!
0
 
LVL 15

Expert Comment

by:WalkaboutTigger
ID: 35014353
Do you have any  stopped websites on the server?
0
 

Author Comment

by:SteveMat11
ID: 35014356
nope
0
 
LVL 15

Accepted Solution

by:
WalkaboutTigger earned 500 total points
ID: 35014360
In SBS2008, OWA is in the SBS Web Applications site by default.  This is the site that should have the SSL cert installed.

Verify the OWA virtual directory exists in the SBS Web Applications site.
0
 

Author Comment

by:SteveMat11
ID: 35014369
The OWA virtual directory is there.  How do I make sure the cert is installed there?  If I check the bindings of the SBS Web Applications I have two entries:

http   80    *(under IP address)
https 443  * (under IP address)  If I hit edit the correct SSL Cert is selected from the dropdown.
0
 

Author Comment

by:SteveMat11
ID: 35014378
Also if I look at the SSL settings under the SBS Web Applications the require SSL box isn't checked.  (However I tried checking it and it still doesn't work)
0
 
LVL 15

Expert Comment

by:WalkaboutTigger
ID: 35014381
So which IP is this site bound to?  If you go directly to https://ipaddressOfSBSWebApps/owa do you still get the 404 error?

If so, what service pack is installed?  You may need to reinstall the service pack.  404 errors for OWA in SBS can be caused by a corruption which can only be resolved by reinstalling the SP.
0
 

Author Comment

by:SteveMat11
ID: 35014397
I get the error however if I enter that URL it redirects to https://IPAddress/owa/owa.  Not sure why its throwing the extra owa in there.  If I use local host it works fine so not sure anything is corrupt.
0
 

Author Comment

by:SteveMat11
ID: 35014411
If I give you RDP access would you mind taking a look?
0
 

Author Comment

by:SteveMat11
ID: 35014419
What bindings should I have listed for the default site and what should be under SBS Web Apps?  I think there may be a conflict here somewhere.
0
 

Author Comment

by:SteveMat11
ID: 35014426
Fixed it, it was a binding issue.  I had two conflicing that cause the double /owa's.  Sorry for this mess!  Points will be awarded to you for all your help.
0

Featured Post

Creating Instructional Tutorials  

For Any Use & On Any Platform

Contextual Guidance at the moment of need helps your employees/users adopt software o& achieve even the most complex tasks instantly. Boost knowledge retention, software adoption & employee engagement with easy solution.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
If you troubleshoot Outlook for clients, you may want to know a bit more about the OST file before doing your next job. IMAP can cause a lot of drama if removed in the accounts without backing up.
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses

622 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question