• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1111
  • Last Modified:

Visual Studio 2010 Web Part Project Prompted to Run at Elevated Permissions

I am new to SharePoint development.  I am working with Visual Studio 2010 C#, SharePoint 2010 and C#.  I have created a SilverLight WebPart.  When I attempt to debug or deploy the WebPart Visual Studio prompts me saying that it needs to run using elevated permissions.  Visual Studion then prompts me for userID and credentials of an eleveated permission user.  I have been entering the domain adminstrator credentials.  Visual Studio restarts and I'm off and running.  What I am confused about is that I am configured as an adminstrator of the SharePoint site with 'Full Control'.  What am I getting prompted for elevated permissions?
Thanks in advance,
  • 3
  • 2
1 Solution
please open the visual studio with elevated permission or add the domain user in debugging (Local) group. Debugger requires the elevated permission to execute.
wahlsterAuthor Commented:
Hi Navdeepmadan,
I'm interested in how to the domain user in debugging (local) group.  Can you please elaborate on steps necessary to accomplish this?
Thanks again,
Hello Terry,

Visual studio allows debugging to only those who is part of local debugging group. By default, local administrator user is part of this group. if you start the visual studio in local administrator group , you will not see this issue.

Steps of verify :-

1) Go to start :- programs -  Visual Studio 2010 - Right Click on "Visual Studio 2010" -> Run as administrator
2) Now try to reproduce the issue

Resolution of this issue :-

1) Go to start -> open the Run prompt -> trype services.msc - >Debugger Users group
2) Add your domain user in this group
3) try to reproduce this steps.

For windows 7 :--
 [[Debugger Users group enables you to remotely access debugging components
> on other machines.]]

> [[Debug programs
> Computer Configuration\Windows Settings\Security Settings\Local
> Policies\User Rights Assignment

> Description
> Determines which users can attach a debugger to any process. This
> privilege
> provides powerful access to sensitive and critical operating system
> components.

> This user right is defined in the Default Domain Controller Group Policy
> object (GPO) and in the local security policy of workstations and servers.

> By default, only administrators and LocalSystem accounts have the
> privileges
> to debug programs.]]


wahlsterAuthor Commented:
I order for your user account to be considered a SharePoint administrator you account need to be a member of the following groups.  Once you have done this you can simply right click on Visual Studio and select 'Run as Administrator'.  Visual Studio will start using your credential but with administrative rights.  The groups you need to be part of are:

User must be in the local administrators group
User must be in the WSS_ADMIN_WPG group
User must be SharePoint Farm administrator
User must be db_owner of the corresponding content database
User must be Site Collection administrator of the Site Collection Where Custom Solution will be deployed to
wahlsterAuthor Commented:
Researched and this was the solution that I was looking for.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now