Solved

Exchnage server 2007 VSS backup taking long time .

Posted on 2011-03-01
17
1,165 Views
Last Modified: 2012-05-11
hi team,
 We are using Exchange server 2007, and backup tool is HP DPM .
currently we integrated VSS into it . but the backup tkae longtime , approximatley more than 48 hrs for 300GB data, Is it usual time or anything wrong ?
0
Comment
Question by:Abhilaash
  • 6
  • 5
  • 4
  • +1
17 Comments
 
LVL 15

Expert Comment

by:WalkaboutTigger
ID: 35014871
That is an excessive amount of time to backup 300 GB.  I would expect 300 GB to backup in about 6 to 12 hours depending upon destination.

Is the Exchange server virtualized?

In any event, the first place I would look would be the storage network - check counters, check error logs, insure your network media is within spec and operating at the expected speeds.

Has it always taken this long to backup?  Is this performance impact only since integrating VSS?
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35014890
Ensure you are running the latest NIC and storage firmware/drivers
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35014902
Hmmm, not so sure that 6.25GB an hour isn't about right for a VSS backup.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
LVL 74

Expert Comment

by:Glen Knight
ID: 35014918
Ignore my comment, need coffee :)
0
 

Author Comment

by:Abhilaash
ID: 35019470
hi team, we are not using any virtualization, the mailbox servers are physical servers,
we could find out that a lot of VSS errors, itshowing idle time out, ("maximum number parallel backup are exceded") , but only one session is still runnning , i dont know how it says maxmum number of parallel backups are exceded  ?
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35019919
Is this a CCR server?
Ensure you are running at least Exchange 2007 SP3
If you are doing VSS backups on the passive node of a CCR cluster then you need to have at least SP3 RU1 installed.

Run ExBPA and see if it highlights any other misconfigurations...

It might be time to reboot this server and see if the throughput increases.
0
 

Author Comment

by:Abhilaash
ID: 35024385
yes . we are using CCR , The exchange is already SP3,
i hope the team is taking backup from Active node , Do you mean taking backup from -
active node will increase the time of backup ?
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35024722
Depends on your infrastructure - if the passive node has the same network bandwidth to the DPM server then backing up from the passive node will be quicker because the passive node is not servicing users.

Make sure you are on least SP3 Rollup 1 before backing up the passive node via VSS, otherwise the logs won't truncate properly.

Another thing to check is your NICs, ensure they are set to max speed and full duplex e.g. 1000/Full instead of Auto/Auto otherwise you might find it operating at 10Mb half duplex
0
 

Author Comment

by:Abhilaash
ID: 35026313
hi MegaNuk,
 Are you talking about the Adapter ( Is it Hearbeat/node-to-node adapter ) or Public/MAPI adapter?
i checked both i saw "speed & Duplex" vlaue is Auto . Please correct me ?
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35029718
Set them and the switch they connect to, to the max speed and full Duplex.

So if they are connected to a 1gb switch and you have 1gb NIC then set the NIC to 1000/Full and see if network team can set the switch port to 1000/Full too.

Have a look and see if it is showing the current connection speed as 100/half (usually seen on the 'Information' tab of HP Teaming software)
0
 

Author Comment

by:Abhilaash
ID: 35162990
hi team .
              Do you think this backup delay delay occured why because of "circular logging enabled" ?
becuase if circular logging is enabled daily we need to take FULL backup, righ ?
ceratin times there are parallel backups running with diffrent Sesssion-ID , the full back up is not yet completed in a full day, VSS also stoped becasue of maxmimum number of parllael backup excedded,

Please give share some recommemded backup methoods for Exchnage server 2007 CCR .
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35163020
If you are taking more than one Backup at a time then performance will be effected.
0
 
LVL 15

Expert Comment

by:WalkaboutTigger
ID: 35163043
How many storage groups do you have configured?
Is the 300 GB on separate LUNs?  Comprised of several storage groups?
Did you get your NICs reconfigured and verify you have the latest firmware and drivers for the NICs?
0
 

Author Comment

by:Abhilaash
ID: 35163056
Backup status
--------------------------------------------------------------
SessionID          Type            Status
=========================================
2011/03/17-10      Backup          In Progress/Errors
2011/03/17-20      Backup          In Progress
2011/03/18-2        Backup          In Progress/Errors
       The backup scheduled on 17/MARCH/2011 still running not completed,
todays backup also running .  
 so currently 3 backup sets are running ,
event viewer shows the following error

-----------------
Volume Shadow Copy Service error: Unexpected error VSS_E_WRITER_STATUS_NOT_AVAILABLE. An older active writer session state is being overwritten by a newer session. The most common cause is that the number of parallel backups has exceeded the maximum supported limit.  hr = 0x80042409.
---------------------
so i checked the services.msc, the VSS is stopped, i resatrted the service.
---------------------
the most of the time the hp backup log showing IPC read error
---------------------
 please give some ideas ?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35163063
Yep, you need to cancel the previous jobs.  How much time is between the scheduled jobs?
0
 

Author Comment

by:Abhilaash
ID: 35163122
one backup started 17 th 12.00 night (not completedd yet) ,  
the second backup sarted 18 th 12.00 night ( not completed yet )
0
 
LVL 31

Accepted Solution

by:
MegaNuk3 earned 500 total points
ID: 35163243
Cancel all backups and disable the scheduling of them until you sort out the backup speed.

Did you change the network speed & Duplex like I said?
When a backup is happening open task manager and look at the Network tab, it should show how much bandwidth is being used to backup.

If backing up to tape then ensure none of the drives are faulty - run cleaning tapes regularly.

Did you ever run ExBPA?
0

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

679 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question