Solved

There was a problem sending the command to the program ... [sigh]

Posted on 2011-03-02
11
1,021 Views
Last Modified: 2013-12-07
Got a proggy that reads data and writes .html files to the PC. My machine runs Windows 7 professional 64-bit. When I double click on such a generated .html file, Firefox shows an error message:

"There was a problem sending the command to the program"

Yet it still launches the page after that. The same thing happens sometimes with links in e-mails and such.

Obviously this is extremely irritating and it needs to stop. Here is what I have tried so far. As you can imagine I have been googling until I'm googly-eyed, and I tried some of the suggestions made by others. To wit:

- "Making Internet Explorer Your Default Browser and then Switching Back to Firefox"
Yeah. Tried that. It made no difference.

- "Setting the launch defaults to not use DDE"
Er... yeah. While that instruction seemed like there may be something to it, the instructions were given for "windows 2000/XP" Can someone explain to me HOW to do that in Windows 7 because I can't seem to find any such option. I went to the "Default Programs" section in the control panel but all that allows me to do is change the default program from IE to FireFox and vice versa, it doesn't let me specify any additional options for launch parameters.

- "Your Windoze profile may be corrupted. Try fixing your profile"
Thankfully I didn't go too far down THAT garden path. I created a brand new profile and tried launching a local .html file through that and the same thing happened. No point taking *that* suggestion any further.



So now I'm stuck. Any ideas, anyone? Ta muchly.
0
Comment
Question by:WernerVonBraun
  • 7
  • 3
11 Comments
 
LVL 25

Assisted Solution

by:Rouchie
Rouchie earned 150 total points
ID: 35016647
I get this error sometimes when a program tries to launch an HTML file (in Firefox because its the default browser) but Firefox is busy searching for updates (which it does on startup by default).  For some reason Firefox doesn't 'register' that it has in fact started up okay and the page is in a queue waiting to be processed.

Perhaps try disabling the automatic updating of Firefox...?
0
 
LVL 4

Author Comment

by:WernerVonBraun
ID: 35025221
How?
0
 
LVL 4

Author Comment

by:WernerVonBraun
ID: 35025278
Never mind. I found the setting. I switched it off. Made no difference :-(
0
 
LVL 30

Expert Comment

by:mtz1of4
ID: 35025959
Werner, would it be possible for you to post some of the HTML code that is causing this?  That may lead us to better ideas.
It sounds more likely that the html may be malformed or trying to access something FF doesn't
Understand.
0
 
LVL 4

Author Comment

by:WernerVonBraun
ID: 35026011
Nope. It does this on random HTML files or links, and *before* it launches the page. It doesn't throw any errors in IE, Safari or Chrome.

But let me double check that.
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 
LVL 4

Author Comment

by:WernerVonBraun
ID: 35026231
LOL

Ok - I reduced the HTML to the bare minimum and it still fails. The following is the full content of the file:


<HTML>
<HEAD>
<TITLE>ZOMG</TITLE>
</HEAD>
<BODY>ZOMG IT FAILS *sob*</BODY>
</HTML>



:-)
<HTML>
<HEAD>
<TITLE>ZOMG</TITLE>
</HEAD>
<BODY>ZOMG IT FAILS *sob*</BODY>
</HTML>

Open in new window

0
 
LVL 30

Accepted Solution

by:
mtz1of4 earned 350 total points
ID: 35026531
WernerVonBraun,

Couple things we can try as I can't replicate your error on my end. My first suggestion -
1. Download a NEW Full install of the Firefox browser.
2. Uninstall Firefox.  This doesn't delete your profile.   It should be left alone.  But you could take a copy of it, just in case.  It's been a while since I ran the uninstall on Firefox, so I don't remember if they ask you if you want to delete your Info, if they do, say No.
3. Reboot machine.  
4. Install the New install to a DIFFERENT folder, not the default, put it somewhere like c:\TESTING PROGRAMS\
5. Run Firefox after install, set it to Default, restart browser, confirm in
Control Panel\All Control Panel Items\Default Programs\Set Default Programs that Firefox has been set as Default, but then also open Internet Explorer go to it's Tools->Internet Options->Programs tab and make sure the "Tell me if Internet Explorer is not the default web browser." is UNCHECKED, and OK out.  If you are see a note under that setting that "IE 64 Bit cannot be set as the Default Browser", you are in IE (64-bit), so repeat that setting under Start->Internet Explorer 32 Bit and make sure that's not interfering.
6. After that, let's test your html pages.


I'd like a report back on that before we attempt the next step, as the next step really is going backward by setting Compatibility mode, but that just shouldn't be needed.

Is this a Work computer, that IT may have certain Controls over, or is this your own personal machine?  It almost seems like something is interfering with Firefox, like an Antivirus/antimalware/security software, so please list any security software that you have installed as well.  Perhaps something is trying to scan that html, but since it's local, it's breaking that program and not Firefox.

Wondering if you opened Windows in Safe Mode, and tried opening a local html of you could repeat the error.
0
 
LVL 4

Author Comment

by:WernerVonBraun
ID: 35026607
okeedoke. I'll go and give that a whizz. Back in a mo
0
 
LVL 4

Author Comment

by:WernerVonBraun
ID: 35026665
Right

I tried that and it didn't help. But I had a long hard look at my add-ons and I uninstalled them one by one. When I got to one called "foxyproxy" it stopped doing this.

So foxyproxy has the problem. Not firefox. Or at best there is a compatibility issue here. and since I don't actually *use* foxyproxy anyway, I felt a deep and overwhelming sense of indifference at having just uninstalled that Add-on. Good riddance, I say, GOOOOOOOOD riddance. :-)
0
 
LVL 4

Author Closing Comment

by:WernerVonBraun
ID: 35026670
Thank you, all
0
 
LVL 30

Expert Comment

by:mtz1of4
ID: 35026796
ok, that is really STRANGE. Add-ons SHOULD only be effective in your current FF Profile.
If you actually opened a Different Windows Profile and tried to open FF with one of those files, that SHOULD not be touching your regular Users FF Profile.
Perhaps Foxy Proxy is more integrated than it should be, obviously, as removing it fixed it for you.
Glad to have helped.
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

Introduction If you're like most people, you have occasionally made a typographical error when you're entering information into an online form.  And to your consternation, the browser remembers the error, and offers to autocomplete your future entr…
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum editing capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now