Solved

Cisco asa 5505 won't connect to internet

Posted on 2011-03-02
13
1,415 Views
Last Modified: 2012-05-11
Hi Folks,

Having a nightmare here with a brand new cisco asa 5505. About 6 hours into trying to get the thing working.

Firstly windows 7 refuses to get to its https://ip/admin web interface, but i solved that by connecting from XP.

So, now I have factory reset it with the IP 10.5.0.1

I've got this simple topology:

Win XP Laptop on dhcp > ASA 5505 > Cable Modem > Internet

Now I run through the startup wizard, all seems obvious so hopefully no need to change much in there.

But I cannot get internet access and in ASDM it says "no ip address" on the outside interface. I think this is the problem I need to solve first ??

I tried setting the MAC address of the outside interface to the address of my old router in asdm, in case the ISP is securing by mac address. that didn;t work.

I wasnt sure which port address translation to use. I tried "no address translation" and also "PAT" with "use the ip address on the outside interface". Neither worked

Please help !!!!

thanks



0
Comment
Question by:plq
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 3
13 Comments
 
LVL 8

Author Comment

by:plq
ID: 35016095
Also whenever I try to run the startup wizard now it give me this

"This license does not allow configuring more than 2 interfaces with nameif and without a "no forward" command on this interface or on 1 interfacess) with nameif already configured"

Only way out of that is to factory reset every time I want to run startup wizard. This is a really bad experience.
0
 
LVL 8

Author Comment

by:plq
ID: 35016297
Progress, but still need help:

The outside IP is now showing as the internet facing ip - good news I guess. But clients inside the firewall cannot access the internet still.

Please help if you can. thanks
0
 
LVL 3

Expert Comment

by:mrmozaffari
ID: 35016466
Would you please send your running Config ?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 8

Author Comment

by:plq
ID: 35016482
: Saved
:
ASA Version 8.3(1)
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.5.0.1 255.255.255.0
!
interface Vlan2
 mac-address 0012.4349.5cc0
 nameif outside
 security-level 0
 ip address dhcp setroute
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
object network obj_any
 subnet 0.0.0.0 0.0.0.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
nat (inside,outside) source dynamic any interface
!
object network obj_any
 nat (inside,outside) dynamic interface
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.5.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 10.5.0.5-10.5.0.132 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:9cbe91cd417109a1d4d9bae74a6860ab
: end
no asdm history enable

0
 
LVL 8

Author Comment

by:plq
ID: 35016646
I can get onto the cable modem from the laptop now, but still no internet access.

Cable modem does of course work fine direct to a pc or through a cisco 501.

The cable modems http interface log says "No Ranging Response received - T3 time out" whatever that means !

thanks

0
 
LVL 3

Expert Comment

by:mrmozaffari
ID: 35016750
now we have to check that vlan 2 has got its IP address and Also is there any route or gateway via dhcp.

so :
please send your show route results, and also show int vlan2.
0
 
LVL 3

Assisted Solution

by:mrmozaffari
mrmozaffari earned 250 total points
ID: 35016777
We need to check that we have internet on ASA ,After you check for vlan and Routes ,then try ping 4.2.2.4 from your ASA.
ping outside 4.2.2.4
0
 
LVL 2

Assisted Solution

by:alewis9777
alewis9777 earned 250 total points
ID: 35016786
Have you plugged your pc directly into cable modem to make sure you have. Hot Line to the cable provider?
0
 
LVL 8

Author Comment

by:plq
ID: 35017273
Its was half working, sort of.

When I go google.com I get the links across the top but no pictures or search box ! weird. It just hangs there for ages.

Since then its gone back to page cannot be displayed. I wonder if it is the ISP validating mac addresses. I didn't change anything between these states.

Pinging 4.2.2.4 returns no response 0/5

Pinging the modem 192.168.100.1 is fine.

When I do ipconfig/renew on the laptop, it seems to take about 2 minutes after changing any settings before i can get my ip address again

0
 
LVL 8

Author Comment

by:plq
ID: 35017352
How can I ask my cisco 501 what its web facing mac address is?

Lets get that out of the equation before we go further.

thanks
0
 
LVL 8

Author Comment

by:plq
ID: 35020406
I just changed the topology to this


    Laptop > Cisco ASA 5505 > Cheap Dlink Router > Virgin Modem


Now I have full internet access. So there's something about the Cisco ASA 5505 and the Virgin Modem which are incompatible when they are directly connected to each other.
 

The old architecture:
 

    Laptop > Cisco ASA 5505 > Virgin Modem


still does not work - the asa is given a web facing IP by the virgin modem but internet access is not possible.

 

If anyone knows of a configuration on the cisco that could fix this, please let me know.. thanks

0
 
LVL 8

Accepted Solution

by:
plq earned 0 total points
ID: 35025731
It was virgin banning the mac address for some reason. Golden rule seems to be turn off the modem every time you change routers
0
 
LVL 8

Author Closing Comment

by:plq
ID: 35067762
Own comment answers
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Content Filtering by Search Term with a Smoothwall Firewall 1 226
network error 8 65
How to get windows DNS resolve to internal address? 3 175
Check Spoof email 6 70
Network traffic routing plays key role in your network, if you have single site with heavy browsing or multiple sites, replicating important application data from your Primary Default Gateway ,you have to route your other network traffic from your p…
I found an issue or “bug” in the SonicOS platform (the firmware controlling SonicWALL security appliances) that has to do with renaming Default Service Objects, which then causes a portion of the system to become uncontrollable and unstable. BACK…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
Finds all prime numbers in a range requested and places them in a public primes() array. I've demostrated a template size of 30 (2 * 3 * 5) but larger templates can be built such 210  (2 * 3 * 5 * 7) or 2310  (2 * 3 * 5 * 7 * 11). The larger templa…

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question