Solved

Windows RDP  access to multiple computers with D-Link DSL-2740B router

Posted on 2011-03-02
9
2,238 Views
Last Modified: 2012-05-11
We have a D-Link DSL-2740B (Rev_E) router and a static IP address.
I have set up port forwarding to connect to different computers on our LAN from the outside.
The server is Windows 2008 R2. The default RDP port, 3389 points to the server's internal IP and this works, meaning we can connect to the server from an external PC on Windows XP Pro with Windows Remote Desktop, no problem. We cannot connect to other computers on the LAN. The setup is like this :
Name          Address          External Port    Internal Port        Protocol     WAN Interface
SERVEUR   192.168.16.2    3389               3389                   TCP            ppp0_1
POSTE1      192.168.16.29  3396               3396                   TCP            ppp0_1
POSTE2      192.168.16.32  3395               3395                   TCP            ppp0_1
etc...

We can connect with RDP within the LAN to all the computers, no problem

From the outside we can connect with RDP to
217.xxx.xxx.49
or 217.xxx.xxx.49:3389 (specifying the default RDP port) - no problem,

but we cannot connect to, for example:
217.xxx.xxx.49:3396

I tried disabling the firewall and the antivirus - that didn't work
I tried putting the server in a DMZ - that didn't work
I tried putting a specific computer in the DMZ - that didn't work

This is something that worked for us "before" - i.e. it worked with our old modem-router provided to us from our ISP (Orange.fr) - the old one was a Livebox Inventel Pro. Unfortunately it broke down so the ISP replaced it with their new model. The new model didn't work for the external RDP (and it's not possible to get an old model anymore). So we assumed that getting a brand new D-Link router would solve the problem...
I have also tried using the Windows 2008 RDP Web Access, which works internally but not externally - we keep getting the same error saying it's impossible to connect to the PC in question
0
Comment
Question by:jdailey59
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 7

Expert Comment

by:wparrott
ID: 35017389
Are the client computers setup to listen for RDP on port 3396, 3395, etc? If not, you have to change the ports that RDP listens on:

http://support.microsoft.com/kb/306759 (don't use the 'Fix it for me' tool, do it manually via regedit).

HTH,

-W
0
 

Author Comment

by:jdailey59
ID: 35017707
This worked perfectly before with our old router without having to change the RDP listening port on each individual client. I went ahead and tried this anyway on one client, modifying the registry manually, then rebooting it, but it still doesn't work - sorry :(  - but thank you for the suggestion
0
 
LVL 2

Expert Comment

by:ROMAD77
ID: 35017954
I'm not familiar with your particular D-Link model, but the D-Link I have had better success using the "NAT - Virutual Servers" feature rather than port mapping/port forwarding. If you have NAT enabled on the router, you can go to the Advanced tab and configure Virtual servers for each of your RDP hosts. Just configure the External Port Start - End and Internal Port Start - End with the custom RDP port for each PC, i.e. 192.168.16.29 Start 3396 End 3396

This worked for me hope it helps.

0
Simple, centralized multimedia control

Watch and learn to see how ATEN provided an easy and effective way for three jointly-owned pubs to control the 60 televisions located across their three venues utilizing the ATEN Control System, Modular Matrix Switch and HDBaseT extenders.

 

Author Comment

by:jdailey59
ID: 35018948
NAT is enabled on my router and in the manual I see that Virtual Servers is supposed to be in the Advanced menu, just under Firewall Settings, but it's not there - do you know where I can find it?
0
 
LVL 2

Expert Comment

by:ROMAD77
ID: 35019227
You might check D-Link's website for firmware updates. It appears there was one update that involved NAT support. Maybe start here:

http://www.dlink.co.uk/cs/Satellite?c=TechSupport_C&childpagename=DLinkEurope-GB%2FDLTechProduct&cid=1197319446523&p=1197318962293&packedargs=locale%3D1195806691854&pagename=DLinkEurope-GB%2FDLWrapper
0
 

Author Comment

by:jdailey59
ID: 35025009
I just spoke with D-Link tech support and the Virtual Server doesn't exist for my model anymore, and it's not possible to downgrade the firmware to get it back. They now tell me that Port Forwarding is the only option available now for the DSL-2740B and that if that doesn't work then I'd need to get a different (e.g. more expensive) VPN router.
0
 
LVL 3

Accepted Solution

by:
eviljester earned 500 total points
ID: 35032931
I've done a lot of this.... you need to set all the internal ports to 3389, as this is the default ports on the servers themselves.
0
 

Author Closing Comment

by:jdailey59
ID: 35034977
This port forwarding solution for external RDP works for my router :
D-Link DSL-2740B Rev EU_5.17
Example :
Name External Port  Internal Port  Protocol
Server    3389             3389             TCP
PC1         3396             3389             TCP
PC2         3397             3389             TCP
etc.
Then access each individual machine on RDP with the public IP (ours is static)
example:
http://217.xxx.xxx.45:3396
0

Featured Post

Create the perfect environment for any meeting

You might have a modern environment with all sorts of high-tech equipment, but what makes it worthwhile is how you seamlessly bring together the presentation with audio, video and lighting. The ATEN Control System provides integrated control and system automation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Data center, now-a-days, is referred as the home of all the advanced technologies. In-fact, most of the businesses are now establishing their entire organizational structure around the IT capabilities.
David Varnum recently wrote up his impressions of PRTG, based on a presentation by my colleague Christian at Tech Field Day at VMworld in Barcelona. Thanks David, for your detailed and honest evaluation!
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question