Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 404
  • Last Modified:

Journaling Issue in Exchange 2007

We have an Exchange 2007 SP3 environment that had journaling enabled. We have disabled the Journaling agent, and restarted Transport service as well as removing the journaling on the database level but the emails are still coming into the Journal mailbox. We also have deleted the Journal rule that was existing. Any ideas what could be causing it or how we can fix it? I’m tempted to just delete the mailbox but don’t want to unless we have to.
0
NoMachines
Asked:
NoMachines
  • 6
  • 4
1 Solution
 
Hendrik WieseInformation Security ManagerCommented:
Restarting the server should resolve the issue. Are you able to restart the server at the moment?
0
 
NoMachinesAuthor Commented:
Which server are you referring to in particular? We have a pretty extensive setup:

3 Mail Server Role Servers per site
1 Hub Transport per site
1 CAS Per Site

And there are 3 different sites.
0
 
Hendrik WieseInformation Security ManagerCommented:
It would be the hub server on your primary site. Although, now that I know the site layout, have you given the servers enough time to propagate?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
NoMachinesAuthor Commented:
I restarted the Transport Service on the Hubs but I have not restarted them. Is there any other services we need to restart?
0
 
NoMachinesAuthor Commented:
I'm trying to avoid having to restart the servers, is there any other services I can restart?
0
 
Hendrik WieseInformation Security ManagerCommented:
Have you checked on all the hub servers if all the journaling rules has in fact been removed (just so we know if the propagation has completed)?  
0
 
Hendrik WieseInformation Security ManagerCommented:
Also ensure that he Journal Rule Status shows Disabled on all Hub Servers
0
 
Hendrik WieseInformation Security ManagerCommented:
Try running the following command in the shell to disable per-mailbox database journaling:

The following command will disable per-mailbox database journaling on the Finance Mailbox Database.
Set-MailboxDatabase "Finance Database" -JournalRecipient $Null
0
 
Hendrik WieseInformation Security ManagerCommented:
Or use the following shell command to disable journaling on all mailbox databases

Get-MailboxDatabase | Set-MailboxDatabase -JournalRecipient $Null
0
 
NoMachinesAuthor Commented:
The issue was that apparently the Journal rule existed on our Exchange 2010 environment (I thought it was shared rules with the 2007 servers) but it seems to have fixed it! THANK YOU!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 6
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now