Solved

Outlook 2007 stops updating subfolder from Exchange 2010 server.

Posted on 2011-03-02
2
1,825 Views
Last Modified: 2012-05-11
I have an odd issue where Outlook 2007 stops updating subfolders from Exchange 2010 after migrating from Exchange 2003.

Here's the issue:
1 - I migrated from Exchange 2003 on an SBS 2003 server to Exchange 2010 on a seperate 2008 R2 server.  All exchange roles should be moved (OAB, OWA, etc) unless I've missed something along the way.

2 - While both servers were still up and running, I opened outlook and let it reconfigure itself and point to the new server.  I tested sending and receiving, no issues internal or external.

3 - I then disabled the Exchange services on the SBS server, and retested, again, no issues.

4 - Now I'm having random issues with subfolders not updating properly.  If I close and reopen outlook, the folders update.  But, if I stay in outlook, after awhile, it stops updating.  As a test, with one user, I recreated her Outlook profile.  It then worked, updating those folders for about 9 hours, before it stopped again.  If I do a manual Send/Receive, it is slow, but it completes without any error messages.  However, if you look in the lower corner where it says "This folder was last updated", that time doesn't change, until I close and reopen outlook (at which point, all the missing mail also appears).

This user is running in Cached exchange mode, with a very large inbox.  OWA and her iPhone update correctly at all times.

I have verified that the mailbox size limits are disabled on the Exchange 2010 server.

I have seen this issue with at least 2 people, and I'm guessing others just haven't noticed.  One of the mailboxes is less than 2GB, so I don't think it's size related.

As a side note, I do have a user with Outlook 2003 that is having another issue, that may or may not be related...I'll post it here just in case, but I'm not certain it is really pertinent:
She has issues accessing shared calendars that she has permissions to.  If I remove the shared calendar, and re-add it, it works fine, for awhile.  At some seemingly random point, she loses the ability to open SOME of the shared calendars (and it's different ones every time). The error is: "The connection to the microsoft exchange server is unavailable.  Outlook must be online and connected to complete this action."  Outlook shows as online, and mail will come in while this error is occurring.
0
Comment
Question by:ptpadmin
  • 2
2 Comments
 

Author Comment

by:ptpadmin
ID: 35018499
I forgot to add, I did try turning the Exchange Services on again on the SBS server, in case there was something still residing there, but the issue remains.  I have since disable them again.
0
 

Accepted Solution

by:
ptpadmin earned 0 total points
ID: 35027310
Ok, so I think I figured it out.  Here is what I found:

On the Exchange 2010 server, in the Event Viewer (Custom Views>Microsoft Exchange with...) Log, I had an Event 9646 recorded.  The error was: "Mapi session "user information" exceeded the maximum of 500 objects of type "objtFolderView".

According to my research, this happens when users either have a large number of folders, OR have multiple mailboxes open that combined have a large number of folders.  So, I followed the directions here: http://social.technet.microsoft.com/Forums/en-US/exchangesvr3rdpartyapps/thread/3d1f8ce5-628e-4a2e-a752-1226ca539de7

Here are the exact steps I took (quoted from the above link):

"To resolve this problem:

1. Open Registry Editor and navigate to:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\MSExchangeIS
2. Right click ParametersSystem and create New -> Key

3. Enter MaxObjsPerMapiSession and confirm creation of the new sub-key

4. Right click newly created key, create new DWORD value called objtFolder and give it a decimal value bigger than default 500.

5. Create another DWORD value called objtFolderView and give it the same value.

There’s no need to restart Exchange server or even MSExchangeIS service. Give it some time and things will settle down. You might need to restart Outlook client to start synchronising folders again."

So far, so good.

It didn't fix the 2003 shared calendar issue I mentioned above.  I know that 2003 is supported, but not fully with Exchange 2010, so I am prepare to recommend upgrading to Outlook 2007/2010.

0

Featured Post

Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Read this checklist to learn more about the 15 things you should never include in an email signature.
This article explains how to install and use the NTBackup utility that comes with Windows Server.
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question