Solved

Can't access internet using Cisco ASA 5505

Posted on 2011-03-02
13
1,225 Views
Last Modified: 2012-05-11
I have a new ASA 5505 with a pretty basic config, but I can't get out on the internet.  Here is my config:

ASA Version 8.4(1)
!
hostname LV-ASA
domain-name xxxHQ.xxxUSA.COM
enable password PECp9le8VXXBpsRQxxxxx encrypted
passwd xxxxx encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.50 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 63.xxx.xxx.252 255.255.255.248
!
interface Vlan3
 nameif dmz
 security-level 50
 ip address 216.xxx.xxx.201 255.255.255.248
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
 switchport access vlan 3
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name xxxHQ.xxxUSA.COM
pager lines 24
mtu inside 1500
mtu outside 1500
mtu dmz 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-641.bin
no asdm history enable
arp timeout 14400
!
nat (inside,outside) after-auto source dynamic any interface
route outside 0.0.0.0 0.0.0.0 63.xxx.xxx.249 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
telnet timeout 5
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 5
console timeout 0

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
username user1 password xxxxx encrypted privilege 15
username user2 password xxxxx encrypted privilege 15
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect ip-options
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp
!
service-policy global_policy global
prompt hostname context
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:dcb0d43f62fc6d6741cef6c8bfd05985
: end
0
Comment
Question by:fd1906
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 2
  • +1
13 Comments
 
LVL 33

Expert Comment

by:MikeKane
ID: 35019799

1) From ASA can you ping the outside gateway? Can you ping beyond (i.e. 4.2.2.2)
2) From ASA can you ping an internal host
3) From internal host can you ping the ASA interface?  Can you ping beyond?  
4) From the ASA, do a SHOW XLATE, is the inside host grabbing the Nat'ed IP.
0
 
LVL 17

Expert Comment

by:Kvistofta
ID: 35019886
And, are the client sonfigured with 192.168.1.50 as default gateway?

/Kvistofta
0
 

Author Comment

by:fd1906
ID: 35020099
MikeKane:
1) Yes and Yes
2) Yes
3) host can ping inside interface (1.50) but not outside int (x.252) and not beyond
4) Yes the host has a PAT address assigned

Kristofta:
Yes gateway is assigned to 1.50
0
Are You Headed to Black Hat USA 2017?

Getting ready for Black Hat next week? Kick things off with the WatchGuard Badge Challenge and test your puzzle and cipher skills. Do you have what it takes to earn our limited edition Firebox Badge? Get started today - https://crimsonthorn.net

 
LVL 33

Expert Comment

by:MikeKane
ID: 35020161
The inside host would not be able to ping the outside interface IP...  this is by design.  

When the inside host tries to ping 4.2.2.2 or even tries to get http://www.canyouseeme.org, on the ASA do a SHOW LOGGING and check for any errors that result in dropped packets.   I would expect none, but you never know.  

0
 

Author Comment

by:fd1906
ID: 35020185
all logging is disabled.  Which logs should i enable?
0
 
LVL 33

Expert Comment

by:MikeKane
ID: 35020522
#logging monitor level [0-7]        I suggest level 5 to start with.  
#show logging        


This will start to spit out messaged to the monitor, so be careful using this in a heavily used ASA....   Not an issue in this case I think.
0
 
LVL 17

Expert Comment

by:Kvistofta
ID: 35020938
logging on
logging mon 5
term mon


/Kvistofta
0
 

Accepted Solution

by:
fd1906 earned 0 total points
ID: 35021664
It seems like the outside interface of the ASA doesn't like to connect through a switch, I had to plug directly into a free dsl port and it worked like a charm.
0
 
LVL 33

Expert Comment

by:MikeKane
ID: 35021726
Ah, well ok then, that makes it easy.

0
 
LVL 16

Expert Comment

by:Michael Ortega
ID: 35036861
Perhaps the switch you had the wan int of the ASA plugged into was vlan'd and the DSL modem/router was plugged into a port on that same switch but in a different vlan?

I have plenty of ASA's in various configurations plug into a switch first before connecting to a Cable/DSL/T1/etc. modem/router.

MO
0
 

Author Comment

by:fd1906
ID: 35037103
Thanks yes I figured that out..should have posted it. My 2960 has vlans 1-3 configured but the Internet router is on vlan 1. The default configuration for asa is to have te wan link on vlan 2.
0
 
LVL 16

Expert Comment

by:Michael Ortega
ID: 35037320
Done that before. =)

Glad you got it figured out.

MO
0
 

Author Closing Comment

by:fd1906
ID: 35067777
There may have been switch config issues here.  Plugging the WAN assigned interface directly to the DSL modem got the current config up an running.
0

Featured Post

[Live Webinar] The Cloud Skills Gap

As Cloud technologies come of age, business leaders grapple with the impact it has on their team's skills and the gap associated with the use of a cloud platform.

Join experts from 451 Research and Concerto Cloud Services on July 27th where we will examine fact and fiction.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Concerto Cloud Services, a provider of fully managed private, public and hybrid cloud solutions, announced today it was named to the 20 Coolest Cloud Infrastructure Vendors Of The 2017 Cloud  (http://www.concertocloud.com/about/in-the-news/2017/02/0…
Many of the companies I’ve worked with have embraced cloud solutions due to their desire to “get out of the datacenter business.” The ability to achieve better security and availability, and the speed with which they are able to deploy, is far grea…
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question