• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4688
  • Last Modified:

cannot access remote registry

I open regedit, click file->Connect Network Registry. I enter the name of the domain controller and check the name, then click OK. The name comes up in the regedit tree with HKLM and HKU hives listed. So far so good.

But when I try to expand the HKLM key, I get "HKEY_LOCAL_MACHINE cannot be opened. An error is preventing this key from being opened."

I can do this on one of our other domains just fine. Any suggestions what the problem might be?
0
rickblalock
Asked:
rickblalock
1 Solution
 
jhill777Commented:
1.  Click Start, click Run, type regedit, and then click OK.
2.  Expand the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ SecurePipeServers
3.  Right-click winreg, and then click Permissions.
4.  Click Add.
5.  In the Enter the object names to select box, type Local Service, and then click OK.

Alternatively, you can type the name of a user or group that you want to grant access permission.
In the Permissions for LOCAL SERVICE list, next to Read, click to select the Allow check box.
Quit Registry Editor, and then restart your computer.
1
 
mlongohCommented:
You might try to RDP into the server and verify that you can access the registry keys just fine without attempting it via remote registry connection.  If you encounter the same problem you might have some registry corruption as opposed to a permissions issue affecting remote registry access.
0
 
rickblalockAuthor Commented:
I can RDP into this DC and open the registry from login just fine.
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now