Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1127
  • Last Modified:

WCF setup issue - Getting an empty response

Ok I am trying to get a secure WCF service setup, but it is returning a blank response when I view the ?WSDL or /mex/ meta-data.

Here's my web.config:



Any ideas?
<system.serviceModel>
    <bindings>
        <wsHttpBinding>
            <binding name="WsHttpBindingConfig">
                <security mode="TransportWithMessageCredential">
                    <transport clientCredentialType="None" />
                    <message clientCredentialType="UserName" />
                </security>
            </binding>
        </wsHttpBinding>
    </bindings>
    <services>
        <service name="WService" behaviorConfiguration="ServiceBehavior">
            <!-- Service Endpoints -->
            <endpoint address="" binding="wsHttpBinding" bindingConfiguration="WsHttpBindingConfig" name="wsHttpEndpoint" contract="IWService"></endpoint>
            <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange"/>
            <host>
                <baseAddresses>
                    <add baseAddress="https://MyHost.com/MyApp/"  />
                </baseAddresses>
                
                
            </host>
        </service>
    </services>
    <behaviors>
        <serviceBehaviors>
            <behavior name="ServiceBehavior">
                
                <!-- To avoid disclosing metadata information, set the value below to false and remove the metadata endpoint above before deployment -->
                <serviceMetadata httpGetEnabled="true" httpsGetEnabled="true"/>
                <!-- To receive exception details in faults for debugging purposes, set the value below to true.  Set to false before deployment to avoid disclosing exception information -->
                <serviceDebug includeExceptionDetailInFaults="false"/>
                <serviceCredentials>
                    <userNameAuthentication
                        userNamePasswordValidationMode="MembershipProvider"
                        membershipProviderName="AspNetSqlMembershipProvider"/>
                </serviceCredentials>
                <serviceAuthorization
                    principalPermissionMode="UseAspNetRoles"
                    roleProviderName="AspNetSqlRoleProvider" />
            </behavior>
        </serviceBehaviors>
    </behaviors>
</system.serviceModel>

Open in new window

0
imseasick
Asked:
imseasick
1 Solution
 
apeterCommented:
Did you test your wcf service separately, and it is working fine?

Is your call from client reaches wcf service?

If yes then enable tracing to see to details.http://msdn.microsoft.com/en-us/library/ms733025.aspx
0
 
imseasickAuthor Commented:
I figured this out, and it turns out that I am in fact an idiot. I use chrome, which hides XML responses. View:Source did it.

0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now