Solved

Inserting HTML into Joomla article

Posted on 2011-03-02
8
843 Views
Last Modified: 2012-05-11
I am trying to insert this into my joomla article:

<div class="body">
These are the contents of the body
</div>

However, the code is output in the raw...  which is not what I want, I obviously want it to be an actual DIV, not just say "div."  I noticed joomla puts the article contents into a div...  I don't really want that to happen either.
0
Comment
Question by:EMB01
  • 4
  • 3
8 Comments
 
LVL 8

Expert Comment

by:jimsweb
ID: 35021398
0
 
LVL 11

Accepted Solution

by:
Amanda Watson earned 500 total points
ID: 35021576
If you want to create your own div tag then you can easily add that into the html code of the article.
There is a button in the article editing saying show/hide
then you get into the html code and can add your own div within that article if that is what you are after?
0
 
LVL 14

Author Comment

by:EMB01
ID: 35021698
Thanks, but how do I get rid of the extra divs it makes?  I attached a screenshot for clarification.
ss030211.jpg
0
 
LVL 11

Expert Comment

by:Amanda Watson
ID: 35021952
Any chance of seeing a link to your site?
Is this unexpected layout a result of you using the div in your article?  If so did you close the div?

0
6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

 
LVL 14

Author Comment

by:EMB01
ID: 35022148
Sure:

http://leslehmandesign.com/signature/joomla/article

I just used that HTML for brevity; the actual HTML is different.  For the content, I'm using:

<jdoc:include type="component" />
0
 
LVL 11

Expert Comment

by:Amanda Watson
ID: 35022246
Ok so your content isn't displaying properly..
I am getting a little confused as to what you wanted to do and what you have done and whether this article info is showing badly because of what you have added into your code?

I am not clear if you have added divs into your index.php or into the actual article in the article manager.

With the items that are showing with no styling etc they are part of the article parameters.   You can actually disable these parameters in the article manager by hitting "hide" for the pdf/email/article publisher etc.

Do you know where that is?

Also did you close your div tag in wherever you added it...it seems the styling may be off because you didn't close a div tag somewhere
0
 
LVL 14

Author Comment

by:EMB01
ID: 35022363
I tried to hide everything, but it still shows up.  See screenshot for my config settings.  Also, here's the live link:

http://leslehmandesign.com/signature/joomla/article
ss030211-2.jpg
0
 
LVL 14

Author Closing Comment

by:EMB01
ID: 35023381
Thanks, I'll open another question for the other since I need help now.
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

In the following article I will try to explain some of the issues I had learning Joomla and I hope this helps all of you beginners out there that love the concept but find it confusing and difficult to manage and configure a Joomla website. Like …
Have you ever wanted to use that sweet jQuery gallery plugin on your Joomla site but couldn't get it working due to jQuery conflicts or your lack of knowledge about what's under the Joomla hood? This article will step you through the process of impl…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now