Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Unable to enable outlook anywhere exchange 2010

Posted on 2011-03-02
29
1,738 Views
Last Modified: 2012-05-11
hi,
i am trying to enable outlook anywhere on exchange 2010.  as per technet i have both an SSL certificate installed and the RPC over HTTP feature installed. (i installed the certificate in IIS and it is bound to the default site and is working fine, does it need installing in exchange as well?).

the error i get is:

Summary: 1 item(s). 0 succeeded, 1 failed.
Elapsed time: 00:00:00



Error:
The term 'Enable-OutlookAnywhere' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.

Exchange Management Shell command attempted:
enable-OutlookAnywhere -Server 'NAHON-2K8-DC' -ExternalHostname 'email.nahon.co.uk' -DefaultAuthenticationMethod 'Basic' -SSLOffloading $false

Elapsed Time: 00:00:00
0
Comment
Question by:alexanderfoti
  • 17
  • 12
29 Comments
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35022160
Looks like you are not logged in as a user that is a member of the Organisation Management security group?
0
 
LVL 1

Author Comment

by:alexanderfoti
ID: 35022182
i'm logged in as domain admin and is a member of org managment group
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35022231
OK, firstly the SSL certificate should be installed using the Exchange Management Console.

Secondly, are you using the console to enable Outlook Anywhere or the Management Shell?

The command should be Set-OutlookAnywhere.  See here for further details: http://technet.microsoft.com/en-us/library/bb123545.aspx
0
Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

 
LVL 1

Author Comment

by:alexanderfoti
ID: 35022267
this is the error i have when trying to import a certificate error1
when i click ok, i then have the option to add a server to apply the certificate to, when i get this error: error2
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35022275
Interesting, did you complete all the pre-requisites before installation?
0
 
LVL 1

Author Comment

by:alexanderfoti
ID: 35022297
this article says i need a certificate, the RPC feature (feature which installed without error).

so i believe so as i'm now doing the cert...
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35022310
Yes you do need a cert, but it should be requested and completed using the Exchange Managament Shell or Console.

What I asked is when you installed Exchange 2010 did you complete all the pre-requisites?
0
 
LVL 1

Author Comment

by:alexanderfoti
ID: 35022329
the certificate i am trying to install into exchange is the same one i am using for IIS.  i exported it as a pfx and am trying to import it into exchange now.

i completed the exchange prerequisites and exchange is installed and running normally.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35022346
That's not the correct way to do it, you only need to install a certificate once and the way to do it is through the Exchange Console.  This will then assign it to the IIS services.

I would suggest you remove it using the Certificate snapin, and then re-request it.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35022352
0
 
LVL 1

Author Comment

by:alexanderfoti
ID: 35022414
i have followed your guide and at the last step:

(i have put the ***'s in :))


Error:
The term 'New-ExchangeCertificate' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.

Exchange Management Shell command attempted:
New-ExchangeCertificate -FriendlyName '***.***.co.uk' -GenerateRequest -PrivateKeyExportable $true -KeySize '2048' -SubjectName 'C=GB,S="London",L="London",O="***",OU="***",CN=***' -Server '***'

Elapsed Time: 00:00:00


Write file
Cancelled

0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35022428
OK, sounds like you have some problems with your exchange installation, is it a new install or is it being used?
0
 
LVL 1

Author Comment

by:alexanderfoti
ID: 35022446
new install with a few test mailboxes on it.  they all seem to be running ok.

FYI: when i run Get-ExchangeCertificate in a PS, it returns the two certificates on the server
0
 
LVL 74

Accepted Solution

by:
Glen Knight earned 500 total points
ID: 35022460
are you running with Exchange 2010 SP1? If not I would suggest installing it to see if it resolves the console issue you seem to be having.
0
 
LVL 1

Author Comment

by:alexanderfoti
ID: 35022479
i havent installed SP1, am downloading it now.

will update after i have installed it.

PS:
your article on migrating from 2003 - 2010 is superb!
0
 
LVL 1

Author Comment

by:alexanderfoti
ID: 35022510
SP1 prerequisite checks say server is pending a reboot...

rebooting now ...
0
 
LVL 1

Author Comment

by:alexanderfoti
ID: 35022587
so a whole host of errors have propped up.  i will address these one by one now...


Summary: 6 item(s). 4 succeeded, 2 failed.
Elapsed time: 00:01:39


Configuring Prerequisites
Completed

Elapsed Time: 00:00:02


Organization Prerequisites
Failed

Error:
Setup cannot continue with the upgrade because the resource property contains invalid data: Couldn't perform the operation because objects of type 'Microsoft.Exchange.Data.Directory.SystemConfiguration.ResourceBookingConfig' couldn't be found on ***
Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?v=14.1.218.11&e=ms.exch.err.Ex28883C&l=0&cl=cp

Elapsed Time: 00:00:39


Languages Prerequisites
Completed

Elapsed Time: 00:00:06


Hub Transport Role Prerequisites
Completed

Warning:
This computer requires the Microsoft Office 2010 Filter Packs. Please install the software from http://go.microsoft.com/fwlink/?LinkID=191548


Elapsed Time: 00:00:17


Client Access Role Prerequisites
Failed

Error:
Install hotfix Microsoft Knowledge Base article 982867 from http://code.msdn.microsoft.com/KB982867.
Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?v=14.1.218.11&e=ms.exch.err.Ex28883C&l=0&cl=cp

Error:
This computer requires the update described in Microsoft Knowledge Base article 979744 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=979744). Please install the required update to proceed.
Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?v=14.1.218.11&e=ms.exch.err.Ex28883C&l=0&cl=cp

Error:
Install hotfix Microsoft Knowledge Base article 983440 from http://code.msdn.microsoft.com/KB983440.
Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?v=14.1.218.11&e=ms.exch.err.Ex28883C&l=0&cl=cp

Error:
This computer requires the update described in Microsoft Knowledge Base article 977020 (http://support.microsoft.com/kb/977020). Please install the required update to proceed.
Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?v=14.1.218.11&e=ms.exch.err.Ex28883C&l=0&cl=cp

Elapsed Time: 00:00:17


Mailbox Role Prerequisites
Completed

Warning:
This computer requires the Microsoft Office 2010 Filter Packs. Please install the software from http://go.microsoft.com/fwlink/?LinkID=191548


Elapsed Time: 00:00:16
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35022684
These are the pre-requisites for SP1, quite normal ;)
0
 
LVL 1

Author Comment

by:alexanderfoti
ID: 35022711
phew!

hating having to reboot after each one!
0
 
LVL 1

Author Comment

by:alexanderfoti
ID: 35025052
i have installed all the patches, but one error still reamins, and when i click the link for help, there is a page not found ...


Summary: 6 item(s). 5 succeeded, 1 failed.
Elapsed time: 00:01:03


Configuring Prerequisites
Completed

Elapsed Time: 00:00:00


Organization Prerequisites
Failed

Error:
Setup cannot continue with the upgrade because the resource property contains invalid data: Couldn't perform the operation because objects of type 'Microsoft.Exchange.Data.Directory.SystemConfiguration.ResourceBookingConfig' couldn't be found on ****.local'.
Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?v=14.1.218.11&e=ms.exch.err.Ex28883C&l=0&cl=cp

Elapsed Time: 00:00:12


Languages Prerequisites
Completed

Elapsed Time: 00:00:03


Hub Transport Role Prerequisites
Completed

Elapsed Time: 00:00:16


Client Access Role Prerequisites
Completed

Elapsed Time: 00:00:13


Mailbox Role Prerequisites
Completed

Elapsed Time: 00:00:16
0
 
LVL 1

Author Comment

by:alexanderfoti
ID: 35025080
i have tried to follow http://support.microsoft.com/kb/949526/en-us but everything was already in place.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35025102
Can you try the following: http://support.microsoft.com/kb/949526
0
 
LVL 1

Author Comment

by:alexanderfoti
ID: 35025126
see above comment :)
0
 
LVL 1

Author Comment

by:alexanderfoti
ID: 35025847
this is odd, i reran the check and they all passed.  i double check by rerunning again and am now attempting the sp install...


Summary: 6 item(s). 6 succeeded, 0 failed.
Elapsed time: 00:02:29


Configuring Prerequisites
Completed

Elapsed Time: 00:00:00


Organization Prerequisites
Completed

Elapsed Time: 00:00:09


Languages Prerequisites
Completed

Elapsed Time: 00:00:04


Hub Transport Role Prerequisites
Completed

Elapsed Time: 00:00:13


Client Access Role Prerequisites
Completed

Elapsed Time: 00:00:18


Mailbox Role Prerequisites
Completed

Elapsed Time: 00:00:14
0
 
LVL 1

Author Comment

by:alexanderfoti
ID: 35026110
SP1 installed without error.

the correct certificate is now showing up in exchange and has the services IMAP, POP, IIS, SMTP.  do i need to do anything else with this certificate to make sure that it is used with outlook anywhere rather than the self signed one that is also listed there?

i have enabled outlook anywhere and it says it will take 15 minutes.

i will try it this evening.

0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35026126
it won't take 15 minutes.

All looks good then :)
0
 
LVL 1

Author Comment

by:alexanderfoti
ID: 35026132
is there an easy way to test without setting up a remote outlook client?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35026139
0
 
LVL 1

Author Comment

by:alexanderfoti
ID: 35026177
ok, i will do some testing later.

SP1 has made OWA significantly quicker as well!

thanks for the help
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
how to add IIS SMTP to handle application/Scanner relays into office 365.

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question