• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 7344
  • Last Modified:

Internet Explorer 8 Certificate Error - Cannot be verified up to a trusted certificate authority

Hi all,

I am having problems with installing a digital certificate in IE8 under Windows 7. I have looked through several solutions already posted & other searches, however none of these fixes have solved my problem.

I have several sites which are presenting the same problem. The certificate error states "This certificate cannot be verified up to a trusted certification authority", it was issued by VeriSign Class 3 International Server CA - G3.


I have added the site "merchantportal.gemoney.com.au" to the trusted sites list, no https required.
I have tried installing the certificate manually to "Trusted Root Certification Authorities".
I am testing under an administrator account however ideally this will need to apply to a user account.
I have tried disabling "Check for publisher's certificate revocation" & "Check for server certificate revocation" under IE's advanced security settings.
Service Pack 1 is installed, the machine is up to date.


Thanks in advance for any help provided.
screen1.jpg
0
MHJITSUPPORT
Asked:
MHJITSUPPORT
  • 2
1 Solution
 
jrwarrenCommented:
There is a known root CA problem for windows 7.
    Make sure you re-install/install the most current root certificate authorities.  I have read of many Microsoft shops having similar problems and the root CA updates are listed as optional not critical, so they sometimes get skipped in WSUS/SMS pushes.

  If that does not correct the problem, I would suggest going to Internet Options
      Select Advanced and click on RESET (near the bottom) and reset IE to default settings and attempting to view the site.

I used the url provided and am able to view it without SSL errors on 3 machines related to the OS
   1 win7 Pro 32bit without SP1
   1 win7 Pro 64bit without SP1
   1 win7 Pro 64bit with SP1

Good luck.

0
 
praveenkumare_spCommented:
go to the certificate path on the certificate (see ur picture)

and see the path over there


go to start > run > type mmc > file> add/remove snapin >certificate > local machine> select the trusted root under certificate  and see whether u see all the certificate listed in certificate path there ,,

if not doublew click on all the missing certificate in the certificate path and install the same under trusted Root
0
 
MHJITSUPPORTAuthor Commented:
The solution to this was solved by a colleague by going to Tools, Internet Options, Content & Clearing the SSL State.

Thanks to all for the comments.
0
 
MHJITSUPPORTAuthor Commented:
It is the solution that worked.
0

Featured Post

SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now