Solved

exchange 2010 autodiscovery problems

Posted on 2011-03-02
70
10,550 Views
Last Modified: 2012-05-11
if i go to https://localhost/autodiscover/autodiscover.xml, i get a page cant be displayed. get same error with external url.

ive tried to delete and recreate the directory, but no luck.  

any ideas?

thanks
0
Comment
Question by:Comptx
  • 37
  • 30
  • 2
  • +1
70 Comments
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35024762
What happens if you put in the CAS servers internal IP instead of localhost? Same thing?

Have you checked IIS to ensure you have an Autodiscover Virtual Directory? Do any other websites work? Like OWA?
0
 
LVL 10

Expert Comment

by:Muzafar Momin
ID: 35024764
patch the latest service pack on exchange and share the result
0
 

Author Comment

by:Comptx
ID: 35024811
All other services work, I see the autodiscover directory on iis.

 server has all latest patches and updates. Will try the ip in the morning and report back
0
 
LVL 20

Expert Comment

by:Hendrik Wiese
ID: 35024835
Have a look at the following 2 EE Articles for troubleshooting your Autodiscover settings:

1. Exchange 2007/2010 Web services and Autodiscover Ultimate Troubleshooting Guide


2. Exchange Autodiscover and Web Services (OOF and OAB)
0
 

Author Comment

by:Comptx
ID: 35028935
i tried the IP but still same result

Hendrik: i will try that now. thanks
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35029491
Did you do an iisreset after recreating the directory? If you browse to the directory in windows explorer is it empty / does it exist?
0
 

Author Comment

by:Comptx
ID: 35030306
i did an iisreset, and the directory exists on the iis

i am not able to get in to the directory.  is it just doing \\localhost\autodiscover ?
0
 
LVL 20

Expert Comment

by:Hendrik Wiese
ID: 35030537
Have you gone through the trouble shooting guides I suggested?
0
 

Author Comment

by:Comptx
ID: 35030936
Not yet, but I will
0
 

Author Comment

by:Comptx
ID: 35119292
Hendrik, i tried all that you posted,. but im still getting the error when i try to use the out of office on outlook. let me know if you have any other ideas
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35123716
Time to test outlook autoconfig:
With outlook open, hold down CTRL key and right click on the Outlook icon in the bottom right hand side of your screen, them on the popup menu select the "Test Autoconfiguration". Select that, enter valid credentials and select the "autodiscover" option only and test.

Does the autoconfig complete or error out?
0
 

Author Comment

by:Comptx
ID: 35133150
Hi, It errors out.

AutoConfig was unable to determine your settings
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35133715
Are you testing from an internal client that is in the same domain as the Exchange server? It should find the autodiscover service through AD SCP (Service Connection Point). Did it give you any error codes like 80072F0C?
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35133732
Otherwise you can try adding an internal SRV record in DNS that points to a name on your cert that is resolvable internally to the INTERNAL ip address of your CAS server ( you may need to set up split DNS for this to work):
http://support.microsoft.com/kb/940881
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35133745
Also have a look at the autodiscoverserviceinternaluri value from this command
Get-clientAccessServer | fl
0
 

Author Comment

by:Comptx
ID: 35133765
HI I tested from the outlook 2007 client directly on the mail server. Workstation clients also give the same errors for the autodiscovery. only error i can see its 0x800c8204


the get client access command shows me the address used for the autoconfigure xml, and i get a page cannot be displayed
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35133817
If you go into IIS and then drill down to the AutoDiscover Virtual Directory you should be able to right click on it and say Browse/explore, can you see the autodiscover.XML in that folder?
0
 

Author Comment

by:Comptx
ID: 35133843
if i browse with autodiscover selected, i get the certificate warning (since its localhost or ip) then i proceed and i get a page cannot be displayed.

if it helps, if i expand autodiscovery i see a Bin and a help directory
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35136041
Sounds like you are doing redirection.
Have a look at the solution here:
http://social.technet.microsoft.com/Forums/en-US/exchangesvrclients/thread/94818a78-be14-4fb4-87a5-7841d9ba87ec/
0
 

Author Comment

by:Comptx
ID: 35148689
I went to check the settings, i have redirection checked on the autodiscover directory, but then on the error pages im not sure what im supposed to look at.

i clicked on "edit feature settings" under the default website directory and path is empty, but its set to "file".

redirection happens on my webpage from http to https., however the http redirect is not checked under default website.

what should i do?
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35149441
Go onto the CAS server and do
Test-OutlookWebServices | fl
and see where that errors out
0
 

Author Comment

by:Comptx
ID: 35149549
[PS] C:\Windows\system32>Test-OutlookWebServices | fl
WARNING: An unexpected error has occurred and a Watson dump is being generated: Failed to find the mailbox. Mailbox =
'extest_047afb6cbd394@domain.local'.
Failed to find the mailbox. Mailbox = 'extest_047afb6cbd394@domain.local.
    + CategoryInfo          : NotSpecified: (:) [Test-OutlookWebServices], MailboxNotFoundException
    + FullyQualifiedErrorId : Microsoft.Exchange.Monitoring.MailboxNotFoundException,Microsoft.Exchange.Management.Sys
   temConfigurationTasks.TestOutlookWebServicesTask
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35149588
Try
Test-OutlookWebservices "<internal email address>" | fl

Where < internal email address> is a valid internal email address like you@company.local
0
 

Author Comment

by:Comptx
ID: 35149659
[PS] C:\Windows\system32>Test-OutlookWebservices gilbert@domain.local | fl


RunspaceId : 29ef3a97-414c-4fbb-9546-a09bcf14edf4
Id         : 1019
Type       : Information
Message    : A valid Autodiscover service connection point was found. The Autodiscover URL on this object is https://email server internal/Autodiscover/Autodiscover.xml.

RunspaceId : 29ef3a97-414c-4fbb-9546-a09bcf14edf4
Id         : 1013
Type       : Error
Message    : When contacting https://email server internal/Autodiscover/Autodiscover.xml received the error The r
             emote server returned an error: (400) Bad Request.

RunspaceId : 29ef3a97-414c-4fbb-9546-a09bcf14edf4
Id         : 1023
Type       : Error
Message    : The Autodiscover service couldn't be contacted.

RunspaceId : 29ef3a97-414c-4fbb-9546-a09bcf14edf4
Id         : 1024
Type       : Success
Message    : [EXCH] Successfully contacted the AS service at https://email server internal/EWS/Exchange.asmx. The
              elapsed time was 125 milliseconds.

RunspaceId : 29ef3a97-414c-4fbb-9546-a09bcf14edf4
Id         : 1026
Type       : Success
Message    : [EXCH] Successfully contacted the UM service at https://email server internal/EWS/Exchange.asmx. The
              elapsed time was 109 milliseconds.

RunspaceId : 29ef3a97-414c-4fbb-9546-a09bcf14edf4
Id         : 1024
Type       : Success
Message    : [EXPR] Successfully contacted the AS service at https://email server external/EWS/Exchange.asmx. The elapsed
             time was 15 milliseconds.

RunspaceId : 29ef3a97-414c-4fbb-9546-a09bcf14edf4
Id         : 1026
Type       : Success
Message    : [EXPR] Successfully contacted the UM service at https://email server external/EWS/Exchange.asmx. The elapsed
             time was 15 milliseconds.

RunspaceId : 29ef3a97-414c-4fbb-9546-a09bcf14edf4
Id         : 1124
Type       : Success
Message    : [Server] Successfully contacted the AS service at https://email server internal/ews/exchange.asmx. T
             he elapsed time was 31 milliseconds.

RunspaceId : 29ef3a97-414c-4fbb-9546-a09bcf14edf4
Id         : 1126
Type       : Success
Message    : [Server] Successfully contacted the UM service at https://email server internal/ews/exchange.asmx. T
             he elapsed time was 15 milliseconds.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35149795
Do you have an autodiscover.XML in the Autodiscover folder? Do authenticated users have read, read & execute and 'list folder contents' NTFS permissions on the autodiscover folder?
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35149914
Also confirm in IIS that the Autodiscover  VD has SSL settings of:
Require SSL and ignore client certificates.

On authentication you should have Basic and Windows enabled and nothing else. Right click on the windows auth and select 'Advanced Settings' and confirm kernel mode authentication is not enabled.

Try and hit https://casname/autodiscover/autodiscover.XML in IE from the CAS server and verify if you get any cert or credentials prompts. You should eventually get a page with error 600=Invalid Request
0
 

Author Comment

by:Comptx
ID: 35149981
i cannot find an .xml file in the autodiscovery.

ssl settings are correct.

had anno auth on, disabled it.

checked for kernal mode, it was off.

when i go to the url, i get the prompt, and after that i get page cannot be displayed.
0
 
LVL 31

Accepted Solution

by:
MegaNuk3 earned 500 total points
ID: 35150059
Copy autodiscover.XML from the e2k10 SP1 files
0
 

Author Comment

by:Comptx
ID: 35150308
ok sorry, i found the autodiscovery directory by right clicking and selecting browse. i see the xlm file there. when i open it it says

The XML page cannot be displayed
Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.


--------------------------------------------------------------------------------

A name was started with an invalid character. Error processing resource 'file:///C:/Program Files/Microsoft/Exchange Server...

<%@ServiceHost Service="Microsoft.Exchange.Autodiscover.WCF.LegacyAutodiscoverService" %>
-^
 

0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35150474
When you try and access
https://casname/autodiscover/autodiscover.XML
Try changing <casname> with a name that is on your cert that resolves to the internal IP address of your CAS server if you ping it.

At the credentials prompt enter credentials for a non admin user who has a mailbox (you can create a test admin /user for this) and see if it gives you a different result.

Is there a default.aspx and web.config file in the 'AutoDiscover' folder?
Did you check the NTFS permissions on the autodiscover folder from Windows Explorer?
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35150510
CORRECTION: You can create a test mailbox NOT admin
0
 

Author Comment

by:Comptx
ID: 35150846
i use a multiname certificate, has all the names for the mail server on it.

i tried with an existing non-admin account and still got the same page cannot be displayed after the credentials.


then theres the web.config file, but not the default.aspx. and permissions are correct for the folder
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 500 total points
ID: 35151054
Rename your Autodiscover folder in Windows Explorer and then Copy the 'autodiscover' folder over from the ClientAccess\ autodiscover on the E2k10 SP1 install files (or earlier if you are not on SP1 yet)
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35151069
Have you got IE set to bypass proxy for local addreses?
0
 

Author Comment

by:Comptx
ID: 35151643
i dont use proxy on my network, would that make any difference?
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 

Author Comment

by:Comptx
ID: 35151815
I copied the contents of the current autodisc folder elsewhere and moved the ones from the setup to it, but there is still no default.aspx file on it

and no when i try to open the https://server.domain.autodiscovery/autodiscovery.xml i get this:

Server Error in '/Autodiscover' Application.
--------------------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'Microsoft.Exchange.Security, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

Source Error:


Line 853:          <!--add assembly="Microsoft.Exchange.Common, Version=8.0.00207.0, Culture=neutral, publicKeyToken=31bf3856ad364e35"/-->
Line 854:          <!--add assembly="Microsoft.Exchange.Data.Common, Version=8.0.00207.0, Culture=neutral, publicKeyToken=31bf3856ad364e35"/-->
Line 855:          <add assembly="Microsoft.Exchange.Security, Version=14.0.0.0, Culture=neutral, publicKeyToken=31bf3856ad364e35" />
Line 856:        </assemblies>
Line 857:      </compilation>
 

Source File: C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Autodiscover\web.config    Line: 855

Assembly Load Trace: The following information can be helpful to determine why the assembly 'Microsoft.Exchange.Security, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' could not be loaded.


WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

 


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.5420; ASP.NET Version:2.0.50727.5420
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35151820
Shouldn't do.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35151839
Ok, now copy the web.config file back from your old files into the autodiscover folder, then test again
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35151854
Don't forget the NTFS permissions on the autodiscover folder for authenticated users as I mentioned above
0
 

Author Comment

by:Comptx
ID: 35151937
now i get page cannot be displayed again after credentials, permissions are as you said earlier
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35152609
Ok, put the web.config from the source files in there again and edit the web.config
Do a search and replace
Replace %exchangeInstallDir%
with C:\Program Files\Microsoft\Exchange Server
Or wherever your exchange is installed
Replace All

Test
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35152741
CORRECTION:

Ok, put the web.config from the source files in there again and edit the web.config
Do a search and replace
Replace %exchangeInstallDir%
with C:\Program Files\Microsoft\Exchange Server\
Or wherever your exchange is installed
Replace All

Test
0
 

Author Comment

by:Comptx
ID: 35152773
i get this now.


Server Error in '/Autodiscover' Application.
--------------------------------------------------------------------------------

Could not load file or assembly 'Microsoft.Exchange.Net, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.Exchange.Net, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.  

Assembly Load Trace: The following information can be helpful to determine why the assembly 'Microsoft.Exchange.Net, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' could not be loaded.


WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

 

Stack Trace:


[FileNotFoundException: Could not load file or assembly 'Microsoft.Exchange.Net, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.]
   Microsoft.Exchange.Autodiscover.Global.Application_Start(Object sender, EventArgs e) +0

[HttpException (0x80004005): Could not load file or assembly 'Microsoft.Exchange.Net, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.]
   System.Web.HttpApplicationFactory.EnsureAppStartCalledForIntegratedMode(HttpContext context, HttpApplication app) +4179473
   System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +205
   System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +336
   System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +350
   System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +382

[HttpException (0x80004005): Could not load file or assembly 'Microsoft.Exchange.Net, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.]
   System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +11318198
   System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +88
   System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +4348404

 


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.5420; ASP.NET Version:2.0.50727.5420
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35154248
Can you output me 1 line of where you did the replace? I.e file:///c:\program files\Microsoft\exchange server\bin

Or even better can you post your old web.config and the new one we editted?
0
 

Author Comment

by:Comptx
ID: 35156967
i attached both files
newWEB.CONFIG
oldweb.config
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 500 total points
ID: 35158103
Open the new web.config
Replace
"Exchange Server\bin"
With
"exchange server\V14\bin"
Without the quotes

Replace all

Then test again
0
 

Author Comment

by:Comptx
ID: 35158148
ok i did. now after credentials i get this

  <?xml version="1.0" encoding="utf-8" ?>
- <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
- <Response>
- <Error Time="09:29:39.2535603" Id="754607992">
  <ErrorCode>600</ErrorCode>
  <Message>Invalid Request</Message>
  <DebugData />
  </Error>
  </Response>
  </Autodiscover>
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35158174
Excellent! That is what you want.

Do
Test-outlookwebservices "<valid internal address>" | fl
0
 

Author Comment

by:Comptx
ID: 35158215
ok results are

[PS] C:\Windows\system32>Test-outlookwebservices email@domain.local | fl


RunspaceId : 72de8ed9-af7f-4e2b-b811-2871d8b0cb48
Id         : 1019
Type       : Information
Message    : A valid Autodiscover service connection point was found. The Autodiscover URL on this object is https://email.domain.local/Autodiscover/Autodiscover.xml.

RunspaceId : 72de8ed9-af7f-4e2b-b811-2871d8b0cb48
Id         : 1013
Type       : Error
Message    : When contacting https://email.domain.local/Autodiscover/Autodiscover.xml received the error The r
             emote server returned an error: (500) Internal Server Error.
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 500 total points
ID: 35158388
Ok
How many CAS servers do you have?
If it is just one you can do:
Get-AutoDiscoverVirtualDirectory | Remove-AutoDiscoverVirtualDirectory

Then
New-AutoDiscoverVirtualDirectory

Then test
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35158414
Also confirm that hitting https://email.domain.local/Autodiscover/Autodiscover.xml in IE gives you the errorcode 600 "Invalid Request"
0
 

Author Comment

by:Comptx
ID: 35158541
Hi, thanks for that.  the textexchangeconnectivity url autodiscovery test passes now, but the outlook one still sats autodiscovery is unable todetermine your settings, and on the log it says it fails all tests
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35158583
If you can do it, now or out of hours do an iisreset on the CAS and test again.

What does the outlook autoconfig test say now?
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35158604
When testing outlook autoconfig try it with an internal email address like me@mydomain.local
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35158624
You can also test by creating a new user + mailbox and logging into a machine as the new user and seeing if outlook gets configured automatically
0
 

Author Comment

by:Comptx
ID: 35158648
ive been trying a non admin account of user@domain.local

log says attempting url blah blah found through scp
autodiscover https://email.domain.local/autodiscover/autodiscover.xml starting
autodiscover https://email.domain.local/autodiscover/autodiscover.xml failed
then samething for
https domain.local/autodiscover
https autodiscover.domain.local
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35158934
Is email.domain.local on your cert and does it resolve to the internal IP address of your CAS server when you ping it?

Does it give any error codes for the autodiscover autoconfig test like 0x80072F0C ?
Have you tried logging into a PC and seeing if Outlook actually autoconfigures itself correctly?
0
 

Author Comment

by:Comptx
ID: 35159400
Outlook has always confogured itself automatically inside the network.

if i try to ping server.communicare.local i get a could not find host error. i might need to add it on the dns. i will check

i changed the address to the external email address instead of domain.local for the outlook test and it succeded.

i was able to add an user accoutn in my outlook using the autodiscovery, however, it kept asking for the user/pass  and wouldn work unless i used domain\user format.  how can i make it to work with just user/pass?

thanks so much for your help so far
0
 

Author Comment

by:Comptx
ID: 35159485
nvm i do have the dns added for that domain.local zone and it pings fine. i was pinging from the wrong computer.

so just need to figure out why the domain.local address test fails...
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35159535
How many AD domains do you have?

With autodiscovery you should just have to press next because the password and the email address should be filled in for you already.

If you are testing Outlook Anywhere or a machine that is not on the domain and hasn't been then you might need to fill in the email address and password and then there should be no further password prompts.
Can you confirm at what stage you are getting the username/password prompt?
0
 

Author Comment

by:Comptx
ID: 35160115
Got it, its working beautifuly now. my out of office issue has also been resolved with this.

.

thanks alot!
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35160417
No problem, glad we got there in the end.

Did you have to do anymore config/changes to get it to work?

Have a think about implementing Split DNS and internal and external SRV records, which can help with autodiscover and means you don't have to pay for so many names on your cert:
http://support.microsoft.com/kb/940881
0
 

Author Comment

by:Comptx
ID: 35193986
actually, on outlook after i add the account using the autodiscovery, it prompts me for the login on startup and will not accept anything i put unless i use the

domain\name format

the default it comes up with is user@email
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35194376
Reset the autodiscoverserviceinternaluri to http://

And Untick 'require ssl' on autodiscover VD under IIS
0
 

Author Comment

by:Comptx
ID: 35194409
the get-autodiscovery command shows the internail url empty, is that fine too?
0
 

Author Comment

by:Comptx
ID: 35194431
and the ssl is already off with only basic and windows auth on
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35194562
Get-clientaccessServer |fl
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35194633
Is where you see the autodiscoverserviceinternaluri
0
 

Author Comment

by:Comptx
ID: 35204738
ok the address that shows there is the https://email server.domain.local/autodiscover/autodiscover.xml.

do a set-clientaccessServer https://   command?
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35204844
Do a
Get-clientaccessServer | set-clientaccessServer -autodiscoverserviceinternaluri "http://<internally resolvable CAS server FQDN>/autodiscover/autodiscover.XML"

Once that is shown to work, you can either leave it as http:// or change it back to https:// and an internally resolvable name on your cert
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Join & Write a Comment

Easy CSR creation in Exchange 2007,2010 and 2013
If you don't know how to downgrade, my instructions below should be helpful.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
how to add IIS SMTP to handle application/Scanner relays into office 365.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now