Exchange 2007 the name on the security certificate is invalid or does not match the name of the site

hi
i have bought from two different providers and i am still facing this issue of mismatch name in the outlook however certificate works fine in the web browser

the name on the security certificate is invalid or does not match the name of the site

i believe now its an issue with the exchange configuration somewhere i just cant figure out please advice
LVL 11
mattibuttAsked:
Who is Participating?
 
IamTheMorsaConnect With a Mentor Commented:
Few area's to look at:

Open up EMC, expand server config, click on Client Access, click on your Hub transport server, right click on OWA, your internal and external url's will be listed.  Your certificate should match your external url.

You can also use the EMS to see all of the certs you have; get-exchangecertificate

0
 
Suliman Abu KharroubConnect With a Mentor IT Consultant Commented:
on the top right of the warning window, where does the outlook trying to connect ? for example mail.domain.com or autodiscover.domain.com ?
0
 
mattibuttAuthor Commented:
it tried to connect to mail.domain.com i believe however i do not see the domain there i see a word sites in outlook 2010 this is shown as mail.domain.com
0
 
mattibuttAuthor Commented:
thanks guys its ressolved now after adding sites in the alternative subjects strange and freaky but it does the trick
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.