Solved

Regular Infopath form tries to open in browswer

Posted on 2011-03-03
14
1,021 Views
Last Modified: 2012-05-11
I have an infopath form that submits to a form library, it has been working fine however all of a sudden it is now trying to open in Infopath Forms Service and I keep getting the error "the form has been closed"  

 The form will open fine from the document library it is stored in but I have a link in each of my project sites that links back to the original request form.  It is here that the problem occurs.  Instead of opening the proper location it is redirecting to _layouts/FormServer.aspx?XmlLocation=/THE LOCATION OF THE FORM

It should just open SERVER/SITE/LOCATION OF FORM.

Any ideas?  I can try repuslishing the form but since it is opening fine from the document library I'm inclined to think it is not an issue with the form.
0
Comment
Question by:scooter1977
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 6
14 Comments
 
LVL 8

Accepted Solution

by:
nsyyoung earned 500 total points
ID: 35028549
Two thoughts:

1. Make sure the user has the same version or later that the form was created in.  This is exactly what happens when an Office 2003 user tries to open an InfoPath 2007 form.  We have both Office versions installed on Citrix, and we have 2003 users open 2007 forms via Internet Explorer on Citrix without a problem.

2. There might be an error in your URL. We also have forms linked from other places than the doc lib and have to be careful that the exact URL of the blank form open in the browser is the one we link to.  Are you trying to open the form from another location or simply go to the library?

If the xsn string in bold in the URL is missing, I get an error (see image).

Here's what our distance URL looks like:

http://<server>/<webapp>/teamSites/RWTeam/_layouts/FormServer.aspx?XsnLocation=http://gfweb/GFWeb/teamSites/RWTeam/Travel%20Profile%20Form%20Library/Forms/template.xsn&SaveLocation=http%3A%2F%2Fgfweb%2FGFWeb%2FteamSites%2FRWTeam%2FTravel%20Profile%20Form%20Library&Source=http%3A%2F%2Fgfweb%2FGFWeb%2FteamSites%2FRWTeam%2FTravel%2520Profile%2520Form%2520Library%2FForms%2FAllItems%2Easpx&DefaultItemOpen=1

If I remove the "&DefaultItemOpen=1" from the end, the form opens in the client instead of the browser.  Does the distance URL work from the site that houses the actual form?  If you have the document library open and paste the URL into the address bar, does the form open?

Has it ever worked from a distance?

Hope this helps.
N.
IPerror.gif
0
 
LVL 15

Expert Comment

by:melli111
ID: 35028633
Also check the form library settings... Settings > Library Settings > Advanced Settings and make sure "Open in the Client-Application" is selected
0
 

Author Comment

by:scooter1977
ID: 35030628

Well my form shouldn't be opening in form server at all.  It is not a browser enabled form.  I double checked the library setting and "Open in client application" is selected

when i click on the link which is in the form of HTTP://SERVER/SITE/DOCUMENT LIBRARY/FORM NAME it is automatically throwing it to _layouts/FormServer.aspx?XmlLocation=/THE LOCATION OF THE FORM

I don't understand why it won't go directly to the link?  what is telling it to use forms server?  I also noticed that the link has XMLLocation= instead of XSNLocation=  as nsyyoung pointed out it the example. I tried manually changing the URL in the browswer to XSNLocation and voila, it opens in infopath but what the heck ????
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 8

Expert Comment

by:nsyyoung
ID: 35030857
The xml is the finished form file, which is stored in the doc library, and the xsn is the form template.  

SharePoint uses Forms Server to serve the forms in SharePoint , regardless of whether the form is browser-enabled or should open in the client.  If you're running Enterprise version of SharePoint, Forms Server is integrated with SharePoint.

If you just want to link to the location the form is in, without opening it, just use the regular URL to the library.  Otherwise, SharePoint will helpfully involve Forms Server to server your blank form.

Do they live in the same library?

0
 
LVL 8

Expert Comment

by:nsyyoung
ID: 35030884
Oh, and your link above is looking for the finished XML file, not the blank form:   _layouts/FormServer.aspx?XmlLocation.

What changed either in the form itself, the library, or the SharePoint server between the time the form was submitting gracefully and now?
0
 

Author Comment

by:scooter1977
ID: 35030996
Yes, I klnow its looking for the finished XML file. We upgraded from standard to enterprise

once the user submits their form it is stored in a doc library (there I can open them fine, no problems, they open in the infopath client) After their form is approved a subsite is created for their project. I have a workflow built in Visual Studio that creates the subsite, adds the appropriate users and I add a link on the navigation bar back to their originally submitted form in case they need to review the original request.  Otherwise if they need to look at the form they have to go back to the submitted form library and pull it up.  This has always worked in the past but now since we upgraded to Enterprise it now tries to open it in Forms Server. I've tried deactivating Ent Features on that site collection and nothing works.  

I can take the URL that I coded into the quick launch navigation and copy/paste it into an empty browser and it opens fine so its not an issue with the URL.  Its only when I try to open the link from the subsite that seems to be an issue.  

I found this article: http://msdn.microsoft.com/en-us/library/ms772417.aspx  so I added
 and that is working fine.  I can change the code in my workflow to add the ??NoRedirect=false to the end of the URL so it works properly but I'm just perplexed why this is necessary. Not to mention all  the old project sites now have a broken link.  It seems like there has got to be a setting SOMEWHERE that is telling it to open in Forms server but I can't find anything.  My form is not set to be browser compatible, the library it is stored in specifies that it be opened in the browser and I went to the site collection and deactived enterprise features and still Nada.  I don't get it.
0
 

Author Comment

by:scooter1977
ID: 35031023
TYPO in that last paragraph.


I found this article: http://msdn.microsoft.com/en-us/library/ms772417.aspx  so I added
 ?NoRedirect=false  to the end of the URL and that makes it work, it opens in Infopath client.  I can change the code in my workflow to add the ?NoRedirect=false to the end of the URL so it works properly but I'm just perplexed why this is necessary. Not to mention all  the old project sites now have a broken link.  It seems like there has got to be a setting SOMEWHERE that is telling it to open in Forms server but I can't find anything.  My form is not set to be browser compatible, the library it is stored in specifies that it be opened in the browser and I went to the site collection and deactived enterprise features and still Nada.  I don't get it.
0
 
LVL 8

Expert Comment

by:nsyyoung
ID: 35032569
Have you checked permissions?  I'm grasping here.  What version of SharePoint and InfoPath are you using?
0
 
LVL 8

Expert Comment

by:nsyyoung
ID: 35032612
From the link you sent (the OpenIn parameter in your URL):

If XmlLocation is specified, the default value is the setting used in the library.
If only XsnLocation is specified, the default value is PreferClient.

So it's doing what it's expected to do, instead of what you want.  
0
 

Author Comment

by:scooter1977
ID: 35036493
well the thing is, I'm not specifying anything,   I click on the link which is in the syntax of Server/Sites/File.xml and it automatically redirects to /_layouts/FormServer.aspx?XmlLocation=

I read the part about "If XmlLocation is specified, the default value is the setting used in the library" but the library specifies to open in client which of course its not doing.  

There is nowhere where I have specified XSNlocation vs XMLlocattion.  If I knew where it was getting that from I'd just change it to XSNlocation because when I manually change XML to XSN in the URL it opens fine.  I just don't know where its getting those settings.
0
 

Author Comment

by:scooter1977
ID: 35036496
I'm on MOSS 2007 and Infopath 2007
0
 

Author Comment

by:scooter1977
ID: 35039013
Well, I found a work around for this problem.  I'm still not quite sure what the issue is but I found this article

http://social.msdn.microsoft.com/Forums/en/sharepointinfopath/thread/25233f5b-cd5a-47e6-bb37-0e2f92988a4a 

Since I know that the form will open when using XSNlocation as opposed to xmlLocation I manually changed the redirect in the  serverfiles_FormServer.xml in C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\XML
0
 

Author Closing Comment

by:scooter1977
ID: 35039037
I am accepting this as a solution because had you not clued me into the XsnLocation part of the URL I would have spent much more time tryint to figure out what the issue was.  It gave me a good starting point to be able to do some more refined/detailed googling.
0
 
LVL 8

Expert Comment

by:nsyyoung
ID: 35039065
I'm glad I could help.  
0

Featured Post

[Webinar] Code, Load, and Grow

Managing multiple websites, servers, applications, and security on a daily basis? Join us for a webinar on May 25th to learn how to simplify administration and management of virtual hosts for IT admins, create a secure environment, and deploy code more effectively and frequently.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Microsoft SharePoint Foundation 2010 and Microsoft SharePoint Server 2010 do not offer the option to configure the location of the SharePoint diagnostic trace log files during installation.  This can, however, be configured through Central Administr…
In case you ever have to remove a faulty web part from a page , add the following to the end of the page url ?contents=1
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question