• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 499
  • Last Modified:

How can I configure Mac OS X computers to connect to the Mac OS X 10.5.8 server using a Wi-Fi connection?

How can I configure Mac OS X computers to connect to the Mac OS X 10.5.8 server using a Wi-Fi connection?

I have just installed a wi fi router that several of the Mac computers in my office will be using (since there currently aren't enough network jacks available).

The wi fi router plugs directly into the same network switch that all of the other Mac desktop computers are connected to (through the network jacks in their offices). The Mac OS X 10.5.8 server is also plugged directly into this same network switch with a network cable.

The Mac desktop computers that are connected using the Wi-Fi network connection are currently able to browse the internet but are having problems accessing the shared files on the server using Finder and other Mac utilities and access methods.

Whenever these same desktop computers that are currently connected wirelessly are plugged into the network using network cables, they are able to access the Mac server files shares without any problems.

What do I need to do to fix this problem?

Are there special configurations that need to be made to the Mac server or to the Mac desktops?

Do I need to check and make sure that certain port numbers on the wi fi router have been opened?
0
IT Guy
Asked:
IT Guy
  • 2
3 Solutions
 
jasonconCommented:
As far as OS X server goes there is no difference.

Check the ip address configuration on on the LAN devices and the wireless devices and make sure that they are on the same subnet i.e. 192.168.1.x

my guess is that your wireless is actually a router and is giving the wifi clients a different ip range i.e. LAN= 192.168.1.x and WiFi 192.168.2.x

also would be helpful to know the config of the access point. is it a wireless router? what port are you plugging into on the back of it from the switch, is it a WAN port or a LAN port as in port 1,2,3,4,5

plug into port 1-5 for the easy fix and make sure that DHCP is turned off on your router.

if you want the devices to exist on seperate subnets then the router will need to be configured to support that. (u probably dont need this option)
0
 
Owen RubinPrincipalCommented:
Make sure you are using the Wifi device as a wireless router, and not an access point. Connect everything to the hub LAN ports, and NOT to the WAN port on the access port.  Turn OFF "assign address" for DHCP on the access point as well.

Now, all connected devices, wired and wireless will be on the same subnet. Wireless devices will get their IP address form the DHCP server the wired clients use, and NOT from the access point.

Let me know if this works. I do it this way in my office.
0
 
Owen RubinPrincipalCommented:
Correction, that first line above should say "Using the Wifi device as a wireless HUB, and not an access point"

Sorry for the confusion.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now