Solved

Installed UCC Cert for Exchange 2007, now Outlook Anywhere not working

Posted on 2011-03-03
9
535 Views
Last Modified: 2012-05-11
As the title suggests, I've installed a UCC certificate for Exchange 2007, replacing a wild card cert.  My internal and external webmail work fine, and ActiveSync clients are connecting with no problems.  But I can't get an Outlook Anywhere client to connect.  I keep getting prompted for a username/password and it won't accept anything.  I've tried fiddling around with every different setting, and at this point I'm at my wits end and need this resolved ASAP.  

Any suggestions, things to try, I've done some research on here and also other exchange forums but I'm stuck.  Thank you.
0
Comment
Question by:Sma11T0wnITGuy
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
9 Comments
 
LVL 11

Expert Comment

by:MichaelVH
ID: 35029872
Hi there,

what type of authentication have you set for Outlook Anywhere?

You can view the settings with Get-OutlookAnywhere from the shell.

Michael
0
 

Author Comment

by:Sma11T0wnITGuy
ID: 35029920
Output from Get-OutlookAnywhere command:

ServerName                      : LSIEXCHANGE
SSLOffloading                   : False
ExternalHostname                : getmymail.lsisolutions.com
ClientAuthenticationMethod      : Ntlm
IISAuthenticationMethods        : {Ntlm}
MetabasePath                    : IIS://LSIEXCHANGE.lsisolutions.com/W3SVC/1/RO
                                  OT/Rpc
Path                            : C:\Windows\System32\RpcProxy
ExtendedProtectionTokenChecking : None
ExtendedProtectionFlags         : {}
ExtendedProtectionSPNList       : {}
Server                          : LSIEXCHANGE
AdminDisplayName                :
ExchangeVersion                 : 0.1 (8.0.535.0)
Name                            : Rpc (Default Web Site)
DistinguishedName               : CN=Rpc (Default Web Site),CN=HTTP,CN=Protocol
                                  s,CN=LSIEXCHANGE,CN=Servers,CN=Exchange Admin
                                  istrative Group (FYDIBOHF23SPDLT),CN=Administ
                                  rative Groups,CN=LSI Solutions Inc,CN=Microso
                                  ft Exchange,CN=Services,CN=Configuration,DC=l
                                  sisolutions,DC=com
Identity                        : LSIEXCHANGE\Rpc (Default Web Site)
Guid                            : e07a7d60-fb53-4b20-b535-56ced82af173
ObjectCategory                  : lsisolutions.com/Configuration/Schema/ms-Exch
                                  -Rpc-Http-Virtual-Directory
ObjectClass                     : {top, msExchVirtualDirectory, msExchRpcHttpVi
                                  rtualDirectory}
WhenChanged                     : 3/3/2011 12:41:12 PM
WhenCreated                     : 7/21/2010 9:54:00 AM
OriginatingServer               : lsiadc02.lsisolutions.com
IsValid                         : True


0
 
LVL 11

Expert Comment

by:MichaelVH
ID: 35030273
Can you change the authentication from NTLM to basic please?
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
LVL 20

Expert Comment

by:Satya Pathak
ID: 35030280
did u rty to ran the https://www.testexchangeconnectivity.com/ and check it .
0
 

Author Comment

by:Sma11T0wnITGuy
ID: 35030450
Michael-Changing the authentication level does not help

Satya-The test is fine until the final step, Testing SSL mutual authentication with the RPC proxy server.  

The certificate common name lsiexchange.lsisolutions.com doesn't validate against the mutual authentication string that was provided: msstd:*.lsisolutions.com
0
 
LVL 11

Accepted Solution

by:
MichaelVH earned 500 total points
ID: 35030525
Your outlook still represents the config for the wildcard cert you had before. You should first of all change the Outlookprovider

first check the Outlookprovider "EXPR" to see what setting it has for the certprincipalname. (probably "*.etc")

You should (if it's set to "*.etc") change it like this:

Set-OutlookProvider -Identity EXPR -CertPrincipalName msstd:lsiexchange.lsisolutions.com

Grts,

Michael
0
 

Author Comment

by:Sma11T0wnITGuy
ID: 35030666
Michael,

I just ran that command, and it looks like I'm able to connect now.  I will try a few other clients as well.  testexchangeconnectivity.com is going through now as well.
0
 

Author Closing Comment

by:Sma11T0wnITGuy
ID: 35036719
Michael,

Great work, that fixed it up.  My remotes need to VPN in once to get the settings, but its working beyond that.  Thank you again.
0
 
LVL 11

Expert Comment

by:MichaelVH
ID: 35042111
You're most welcome.

I'm glad you got it working again.

Grts,

Michael
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

What does UTC stand for?  “Coordinated Universal Time” – Think of this as the true time on Planet Earth that never changes with the exception of minor leap seconds here and there to account for the changes in the planet's rotation.   What does th…
When you have clients or friends from around the world, it becomes a challenge to arrange a meeting or effectively manage your time. This is where Outlook's capability to show 2 time zones in one calendar comes in handy.
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question