Reportviewer rdlc .net parameters

1)I am adding paarmeters to reportviewer.

Code: 2 ways -both giving smae error
        private void setRepParam()
        {
            ReportParameter[] RptParameters = new Microsoft.Reporting.WinForms.ReportParameter[2];//declare the number of parameters
            string strTrxx = ddTrxx.SelectedItem.ToString();
            string strYear = ddYear.SelectedItem.ToString();
            RptParameters[0] = new Microsoft.Reporting.WinForms.ReportParameter("YEAR", strYear,false);// first parameter
            RptParameters[1] = new Microsoft.Reporting.WinForms.ReportParameter("TR_XX", strTrxx,false);//second parameter
            try
            {
            this.reportViewer1.LocalReport.SetParameters(RptParameters);
            this.reportViewer1.LocalReport.Refresh();
            this.reportViewer1.Show();
            this.reportViewer1.RefreshReport();
            }
            catch (Exception e)
            {
                throw (e);    
            }
          }
        private void SetReportParameters()
        {
            string strTrxx = ddTrxx.SelectedItem.ToString();
            string strYear = ddYear.SelectedItem.ToString();
           
            ReportParameter yearParameter = new ReportParameter("Year",strYear);
            ReportParameter trGrpParameter = new ReportParameter("Trade_Owner", strTrxx);
            this.reportViewer1.LocalReport.SetParameters(new ReportParameter[] { yearParameter, trGrpParameter });
        }
2)Did select rdlc report and add parameters to it through the builder.
3)But still --
If I add this --this.reportViewer1.LocalReport.Refresh(); no report appears
If I write --this reportViewer1.ReportRefresh()---original report appears without any filter based on parameter..
How do I make parameterized reports run ?????

rishaanAsked:
Who is Participating?
 
puffdaddy411Connect With a Mentor Commented:
It sounds like you are attempting to filter a reportviewer table using your parameter.  You need to open the Table Properties dialog box and select the "Filters" tab.  Under "Expression", select the column on which you need to filter.  Select your desired operator.  Under "Value", your expression should look like "=Parameters!xx.value".

In your previous step #2, you need to revert that change.  Ensure "=Fields!XX.Value" is in your textbox.

If you are using a reportviewer List object, this will work the same using the list properties window / Filters tab.
0
 
Rahul AgarwalConnect With a Mentor Team LeaderCommented:
0
 
rishaanAuthor Commented:
Thanks..I tries the 3 steps---
1)Creating report parameter in the rdlc report
2)Changed the Fields!XX.Value in textbox  to Parameters!xx.value ----in rdlc report
3)Added reportparamters to reportviweer.localreport.paarmeters.add(..) in .net code...
Now I can run report and see the results but the result is just replaced by that value eg. ASIA
Everwhere the fileds!XX value is is replaced by PArametr entered.
Its not actually filtering records...WHAT AM I Missing ???
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
rishaanAuthor Commented:
reportviewer table dialog bo x ?how to open ?

0
 
puffdaddy411Commented:
Select the entire table, right-click the table border, and select properties.
0
 
rishaanAuthor Commented:
GREAT!!!!!!!!!!!!!!!!!!!!!!!It works like   charm..................................................
0
 
puffdaddy411Commented:
Very good!  =D
0
 
rishaanAuthor Commented:
THANKS A LOT for the quick and perfect response..
0
All Courses

From novice to tech pro — start learning today.